aboutsummaryrefslogtreecommitdiff
path: root/cad/electric-ng
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-09-30 09:41:07 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-09-30 09:41:07 +0000
commita99bfaeb5370029bc1908aff320792b5bf9ed2e0 (patch)
treeae09a0563094659f5f2f3e2d98e324879ee6e0b7 /cad/electric-ng
parent1b39ccc97bb4ac9884f765d4289fef7e1c327fd0 (diff)
downloadports-a99bfaeb5370029bc1908aff320792b5bf9ed2e0.tar.gz
ports-a99bfaeb5370029bc1908aff320792b5bf9ed2e0.zip
Electric is a sophisticated electrical CAD system that can handle
many forms of circuit design, including: - Custom IC layout (ASICs) - Schematic drawing - Hardware description language specifications Author: Static Free Software & Sun Microsystems, Inc. WWW: http://www.staticfreesoft.com/ PR: ports/100355 Submitted by: me (stas) Approved by: sem (mentor)
Notes
Notes: svn path=/head/; revision=174152
Diffstat (limited to 'cad/electric-ng')
-rw-r--r--cad/electric-ng/Makefile49
-rw-r--r--cad/electric-ng/distinfo3
-rw-r--r--cad/electric-ng/files/electric-ng.in18
-rw-r--r--cad/electric-ng/pkg-descr31
4 files changed, 101 insertions, 0 deletions
diff --git a/cad/electric-ng/Makefile b/cad/electric-ng/Makefile
new file mode 100644
index 000000000000..2b30d4977eb4
--- /dev/null
+++ b/cad/electric-ng/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: electric-ng
+# Date created: 2006-07-14
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= electric-ng
+PORTVERSION= 8.03
+CATEGORIES= cad java
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= ${PORTNAME:S/-ng//}
+DISTNAME= electric-${PORTVERSION}
+EXTRACT_SUFX= .jar
+EXTRACT_ONLY=
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= A sophisticated VLSI design system
+
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
+NO_BUILD= yes
+PLIST_FILES= %%JAVAJARDIR%%/${JARFILE} \
+ bin/electric-ng
+SUB_LIST+= LIBFILES="${LIBFILES}" \
+ JARFILE="${JARFILE}"
+SUB_FILES= electric-ng
+
+OPTIONS= BSH "Enable embedded java interpreter via BSH" off
+
+JARFILE= ${DISTNAME}${EXTRACT_SUFX}
+
+.include <bsd.port.pre.mk>
+
+.if exists(${JAVALIBDIR}/bsh.jar)
+WITH_BSH= yes
+.endif
+.if defined(WITH_BSH)
+RUN_DEPENDS+= ${JAVALIBDIR}/bsh.jar:${PORTSDIR}/java/bsh
+LIBFILES+= bsh
+.endif
+
+do-install:
+ @${MKDIR} ${JAVAJARDIR}
+ ${INSTALL_DATA} ${DISTDIR}/${JARFILE} ${JAVAJARDIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/electric-ng ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/cad/electric-ng/distinfo b/cad/electric-ng/distinfo
new file mode 100644
index 000000000000..9597a4eadf0d
--- /dev/null
+++ b/cad/electric-ng/distinfo
@@ -0,0 +1,3 @@
+MD5 (electric-8.03.jar) = 2d03bbfde105c05584404be525b1daf7
+SHA256 (electric-8.03.jar) = 01dc30f73f31916002836f7195e950c23538345e9099763f2a63e130f40a1f02
+SIZE (electric-8.03.jar) = 10718231
diff --git a/cad/electric-ng/files/electric-ng.in b/cad/electric-ng/files/electric-ng.in
new file mode 100644
index 000000000000..2e8429b37ea2
--- /dev/null
+++ b/cad/electric-ng/files/electric-ng.in
@@ -0,0 +1,18 @@
+#!/bin/csh
+#
+# $MBSDlabs$
+# $FreeBSD$
+
+set JAVA = "%%LOCALBASE%%/bin/java"
+set LIBFILES = "%%LIBFILES%%"
+set JARPATH = "%%JAVALIBDIR%%"
+setenv JAVA_VERSION "%%JAVA_VERSION%%"
+
+set CLASSPATH = ""
+foreach i (${LIBFILES})
+ set CLASSPATH = ${CLASSPATH}":"${JARPATH}/$i.jar
+end
+
+set CLASSPATH = `echo ${CLASSPATH} | /usr/bin/sed -e "s#^:##"`
+
+exec "${JAVA}" -cp "${CLASSPATH}" -jar %%JAVAJARDIR%%/%%JARFILE%%
diff --git a/cad/electric-ng/pkg-descr b/cad/electric-ng/pkg-descr
new file mode 100644
index 000000000000..fb859c551652
--- /dev/null
+++ b/cad/electric-ng/pkg-descr
@@ -0,0 +1,31 @@
+Electric is a sophisticated electrical CAD system that can handle
+many forms of circuit design, including:
+ - Custom IC layout (ASICs)
+ - Schematic drawing
+ - Hardware description language specifications
+
+Electric has these CAD operations:
+ - Design rule checking
+ - Electrical rule checking
+ - Simulation and simulation interface (many options)
+ - Generation (ROMs, PLAs, Pad Frames, etc.)
+ - Compaction
+ - Routing
+ - VHDL compilation
+ - Silicon compilation
+ - Network consistency checking (LVS)
+ - Logical Effort analysis
+ - Project Management
+
+Electric can display these types of design:
+ - MOS (many CMOS and nMOS variations)
+ - Bipolar and BiCMOS
+ - Schematics and printed circuits
+ - Digital filters, Temporal logic
+ - Artwork
+
+For real funcionality, one should consider installing
+support simulation software such as cad/spice.
+
+Author: Static Free Software & Sun Microsystems, Inc.
+WWW: http://www.staticfreesoft.com/