aboutsummaryrefslogtreecommitdiff
path: root/cad/klayout/files
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2007-06-02 08:36:21 +0000
committerHiroki Sato <hrs@FreeBSD.org>2007-06-02 08:36:21 +0000
commit5328ce0f2868cefc4b9522c050819248e0f33820 (patch)
treea787029098ab21ab7ec825451880a727ab8f3e4f /cad/klayout/files
parentbda9441c6a285790fe7d6a18415f206f7893e892 (diff)
downloadports-5328ce0f2868cefc4b9522c050819248e0f33820.tar.gz
ports-5328ce0f2868cefc4b9522c050819248e0f33820.zip
Update to 0.10. Changes include:
- OASIS files can be read as well now. The reader automatically determines the kind of file. OASIS layer names are supported. Due to the complexity of the OASIS specification, or more precisely the effort required to test a reader for meeting the specification, OASIS support currently is regarded to be in "beta" state. - Layers can now be organized hierarchically. Layers can be grouped which allows to control visibility and other properties for the group as a whole. Layers can be removed from the layer view list or new layer views can be created. - The layout can be transformed (rotated, shifted, mirrored) now. This transformation is specified in the layer panel as a part of the layer source specification. An optional transformation can be applied per layer or layer group. This way for example, different layouts can be aligned over each other. - Shape properties now are supported. Each shape may carry optional properties that are read from GDS or OASIS files. A property selector can be applied per layer view, so that a layer only shows these shapes that match the given property selection. - As an experimental feature, the inverse layout tree can be visualised by allowing the minimum hierarchy level to go into the negative range. The effect of this is, that a cell is shown in the context of all of it's direct parents, if the first hierarchy level is set to -1. If set to -2, the cell is shown in the context of all of it's parents and grandparents and so on. Since there is no particular optimiziation for this feature, performance may be poor, if a cell must be painted in a huge number of contexts. In addition, the context displayed does not participate in selection or ruler snapping.
Notes
Notes: svn path=/head/; revision=192574
Diffstat (limited to 'cad/klayout/files')
-rw-r--r--cad/klayout/files/patch-build.sh37
-rw-r--r--cad/klayout/files/patch-config-Makefile.conf27
-rw-r--r--cad/klayout/files/patch-src-Makefile.main13
-rw-r--r--cad/klayout/files/patch-src-Makefile.rules13
4 files changed, 50 insertions, 40 deletions
diff --git a/cad/klayout/files/patch-build.sh b/cad/klayout/files/patch-build.sh
index 00c838da0d60..e0d4374c06ef 100644
--- a/cad/klayout/files/patch-build.sh
+++ b/cad/klayout/files/patch-build.sh
@@ -1,6 +1,6 @@
---- build.sh.orig Tue Mar 6 06:58:29 2007
-+++ build.sh Sat Jun 2 13:57:50 2007
-@@ -61,12 +61,12 @@
+--- build.sh.orig Tue May 8 04:41:18 2007
++++ build.sh Sat Jun 2 16:43:04 2007
+@@ -77,12 +77,12 @@
exit 1
fi
@@ -15,20 +15,21 @@
echo "*** ERROR: unable to locate Qt UIC in $QTDIR/bin"
exit 1
fi
-@@ -107,11 +107,11 @@
-
- echo "Build done."
- echo "Final binary is ready in ./$BIN/$EXEC_NAME."
--echo "To run it, you may need to add the following to your LD_LIBRARY_PATH:"
--echo "$QTDIR/lib"
-+#echo "To run it, you may need to add the following to your LD_LIBRARY_PATH:"
-+#echo "$QTDIR/lib"
-
--LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
--./$BIN/$EXEC_NAME -v
--./$BIN/$EXEC_NAME -h
-+#LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
-+#./$BIN/$EXEC_NAME -v
-+#./$BIN/$EXEC_NAME -h
+@@ -153,12 +153,12 @@
+ echo "Build done."
+ echo ""
+ echo "Final binary is ready in $BIN/$EXEC_NAME."
+- echo "To run it, you may need to add the following to your LD_LIBRARY_PATH:"
+- echo "$QTDIR/lib"
++ #echo "To run it, you may need to add the following to your LD_LIBRARY_PATH:"
++ #echo "$QTDIR/lib"
+
+- LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
+- $BIN/$EXEC_NAME -v
+- $BIN/$EXEC_NAME -h
++ #LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
++ #$BIN/$EXEC_NAME -v
++ #$BIN/$EXEC_NAME -h
+ else
diff --git a/cad/klayout/files/patch-config-Makefile.conf b/cad/klayout/files/patch-config-Makefile.conf
index 3d6143fe17c6..18ebee5a12e1 100644
--- a/cad/klayout/files/patch-config-Makefile.conf
+++ b/cad/klayout/files/patch-config-Makefile.conf
@@ -1,17 +1,26 @@
---- /dev/null Sat Apr 28 23:11:00 2007
-+++ config/Makefile.conf.freebsd-32-gcc-release Sat Apr 28 23:13:51 2007
-@@ -0,0 +1,14 @@
+--- /dev/null Sat Jun 2 16:46:55 2007
++++ config/Makefile.conf.freebsd-32-gcc-release Sat Jun 2 16:49:48 2007
+@@ -0,0 +1,23 @@
+CC=gcc
-+LINK=g++
+
+CCOPT_DEP=-MM -MG -x c++
++
+CCWARN=-Wall -pedantic -Wno-deprecated -Woverloaded-virtual \
+ -Wsign-promo -Wsynth -Wno-long-long
-+LOPT=
-+LIBS=-L$(QTDIR)/lib -pthread -lQt3Support -lQtGui -lQtCore -lQtXml -lstdc++
-+CCOPT=-O
+
-+INC=-I$(QTDIR)/include
++CCOPT=-c -O -x c++ -o
++CCOPT_SO=-fPIC $(CCOPT)
++
++INC=-I$(TOP_SOURCE) -I$(SOURCE) -I. -I$(QTDIR)/include
++
++DEFS=-DQT_THREAD_SUPPORT -DQT3_SUPPORT
+
-+DEFS=
++# Linker options
++
++LINK=g++
++
++LOPT=-Wl,-E -o
++LOPT_SO=-shared -fPIC -o
++
++LIBS=-L$(QTDIR)/lib -pthread -lQt3Support -lQtGui -lQtCore -lQtXml -lstdc++
+
diff --git a/cad/klayout/files/patch-src-Makefile.main b/cad/klayout/files/patch-src-Makefile.main
deleted file mode 100644
index 395dbc29264c..000000000000
--- a/cad/klayout/files/patch-src-Makefile.main
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/Makefile.main.orig Sat Apr 28 23:22:53 2007
-+++ src/Makefile.main Sat Apr 28 23:23:04 2007
-@@ -142,8 +142,8 @@
- layRenderer.ut \
- dbArray.ut \
-
--MOC=$(QTDIR)/bin/moc
--UIC=$(QTDIR)/bin/uic
-+MOC=$(QTDIR)/bin/moc-qt4
-+UIC=$(QTDIR)/bin/uic-qt4
- RCC=$(QTDIR)/bin/rcc
-
- INCFLAGS=\
diff --git a/cad/klayout/files/patch-src-Makefile.rules b/cad/klayout/files/patch-src-Makefile.rules
new file mode 100644
index 000000000000..4bf96bf5ce62
--- /dev/null
+++ b/cad/klayout/files/patch-src-Makefile.rules
@@ -0,0 +1,13 @@
+--- src/Makefile.rules.orig Tue May 8 04:41:19 2007
++++ src/Makefile.rules Sat Jun 2 16:45:56 2007
+@@ -16,8 +16,8 @@
+ endif
+ CCOPTS=$(CCWARN) $(DEFS) $(CCOPT)
+
+-MOC=$(QTDIR)/bin/moc
+-UIC=$(QTDIR)/bin/uic
++MOC=$(QTDIR)/bin/moc-qt4
++UIC=$(QTDIR)/bin/uic-qt4
+ RCC=$(QTDIR)/bin/rcc
+
+ # this target must be first: