aboutsummaryrefslogtreecommitdiff
path: root/cad/libgeda/Makefile
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-02-21 11:43:23 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-02-21 11:43:23 +0000
commit98130c3c16717c3337634ac1e924b9dd4e3df27f (patch)
tree16a2733a669c0bbe164aa8b881df9d60a67de753 /cad/libgeda/Makefile
parent5f6ba2a345062d46d2e16bd1d6c5854e528a096e (diff)
downloadports-98130c3c16717c3337634ac1e924b9dd4e3df27f.tar.gz
ports-98130c3c16717c3337634ac1e924b9dd4e3df27f.zip
- Bump PORTEPOCH, this was missed in previous update [1].
- Use proper shebang line in perl and python scripts [1]. - Define INSTALLS_ICONS and USE_GETTEXT where appropriate. - Implement WITHOUT_NLS knob. Reported by: Nick Withers <nick@nickwithers.com> [1]
Notes
Notes: svn path=/head/; revision=228772
Diffstat (limited to 'cad/libgeda/Makefile')
-rw-r--r--cad/libgeda/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/cad/libgeda/Makefile b/cad/libgeda/Makefile
index ad59ce51d350..4a85ef4e85b4 100644
--- a/cad/libgeda/Makefile
+++ b/cad/libgeda/Makefile
@@ -8,6 +8,7 @@
PORTNAME= libgeda
PORTVERSION= 1.4.3
PORTREVISION= 0
+PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/release/v1.4/${PORTVERSION}/ \
http://geda.seul.org/release/v1.4/${PORTVERSION}/
@@ -27,6 +28,14 @@ CONFIGURE_ARGS= --disable-update-mime-database \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -E \
-e "s,^(DATADIR[[:space:]]*=[[:space:]]*)gEDA,\1geda," \