aboutsummaryrefslogtreecommitdiff
path: root/cad/opencascade
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /cad/opencascade
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'cad/opencascade')
-rw-r--r--cad/opencascade/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/cad/opencascade/Makefile b/cad/opencascade/Makefile
index b4130e0672f0..06549b89e7aa 100644
--- a/cad/opencascade/Makefile
+++ b/cad/opencascade/Makefile
@@ -56,17 +56,17 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
--with-tk=${TK_LIBDIR} \
--with-java-include=${JAVA_HOME}/include \
- --with-dps-include=${X11BASE}/include \
- --with-dps-library=${X11BASE}/lib \
- --with-gl-include=${X11BASE}/include \
- --with-gl-library=${X11BASE}/lib \
- --with-xmu-include=${X11BASE}/include/X11 \
- --with-xmu-library=${X11BASE}/lib \
+ --with-dps-include=${LOCALBASE}/include \
+ --with-dps-library=${LOCALBASE}/lib \
+ --with-gl-include=${LOCALBASE}/include \
+ --with-gl-library=${LOCALBASE}/lib \
+ --with-xmu-include=${LOCALBASE}/include/X11 \
+ --with-xmu-library=${LOCALBASE}/lib \
--with-stlport-include=${LOCALBASE}/include/stlport \
--with-stlport-libname=stlport_${STL_COMPILER} \
--with-stlport-library=${LOCALBASE}/lib \
--enable-production=yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} ${GCC4WA} -I${X11BASE}/include \
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} ${GCC4WA} -I${LOCALBASE}/include \
-I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR}" ARCH=${ARCH}
# We strip the libs
MAKE_ENV= INSTALL_STRIP_FLAG=-s OCC_BUILDDIR="${PATCH_WRKSRC}" \
@@ -177,12 +177,12 @@ pre-configure:
-e 's|/usr/bin/gcc|${CC}|' \
-e 's|%%JAVAHOME%%|${JAVA_HOME}|' \
-e 's|/usr/local|${LOCALBASE}|' \
- -e 's|/usr/X11R6|${X11BASE}|' \
+ -e 's|/usr/X11R6|${LOCALBASE}|' \
${WRKSRC}/src/OS/Draw.tcl \
${WRKSRC}/src/OS/Visualization.tcl \
${WRKSRC}/src/OS/ApplicationFramework.tcl
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|'\
- -e 's|/usr/X11R6|${X11BASE}|' \
+ -e 's|/usr/X11R6|${LOCALBASE}|' \
-e 's|/usr/local/bin/tclsh8.4|${TCLSH}|'\
${PATCH_WRKSRC}/wok/site/wokinit.csh \
${WRKSRC}/src/WOKsite/wokinit.csh \