aboutsummaryrefslogtreecommitdiff
path: root/cad/opencascade
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /cad/opencascade
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Notes
Notes: svn path=/head/; revision=282282
Diffstat (limited to 'cad/opencascade')
-rw-r--r--cad/opencascade/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/cad/opencascade/Makefile b/cad/opencascade/Makefile
index b19a6c0e4551..b6a1cc3987a4 100644
--- a/cad/opencascade/Makefile
+++ b/cad/opencascade/Makefile
@@ -65,8 +65,9 @@ CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
--with-stlport-libname=stlport_${STL_COMPILER} \
--with-stlport-library=${LOCALBASE}/lib \
--enable-production=yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} ${GCC4WA} -I${LOCALBASE}/include \
- -I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR}" ARCH=${ARCH} LD=${CXX}
+CONFIGURE_ENV= ARCH=${ARCH} LD=${CXX}
+CPPFLAGS+= ${CXXFLAGS} ${GCC4WA} -I${LOCALBASE}/include \
+ -I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR}
# We strip the libs
MAKE_ENV= INSTALL_STRIP_FLAG=-s OCC_BUILDDIR="${PATCH_WRKSRC}" \
OCC_INSTALLDIR="${OCCROOT}" PTHREAD_LIBS="${PTHREAD_LIBS}" LD=${CXX}