aboutsummaryrefslogtreecommitdiff
path: root/cad/slffea
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /cad/slffea
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'cad/slffea')
-rw-r--r--cad/slffea/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/cad/slffea/Makefile b/cad/slffea/Makefile
index 2ad219d57640..955bab8b2c57 100644
--- a/cad/slffea/Makefile
+++ b/cad/slffea/Makefile
@@ -10,8 +10,7 @@ PORTNAME= slffea
PORTVERSION= 1.3
PORTREVISION= 4
CATEGORIES= cad
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
DISTNAME= ${PORTNAME}13
EXTRACT_SUFX= .tgz
@@ -22,7 +21,7 @@ LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
CONFLICTS= swi-pl-[0-9]* TenDRA-[0-9]*
-CFLAGS+= -I${X11BASE}/include ${PTHREAD_CFLAGS}
+CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
WRKSRC= ${WRKDIR}/${PORTNAME}-1.3
ALL_TARGET= everything
@@ -39,9 +38,9 @@ post-patch:
${REINPLACE_CMD} -E -e "s|^CC = .*|CC = ${CC} ${CFLAGS}|g" \
-e "s|-lglut|-lglut ${PTHREAD_LIBS}|g" \
-e "s|/usr/local|${LOCALBASE}|g" \
- -e "s|/usr/X/|${X11BASE}/|g" \
- -e "s|/usr/X11/|${X11BASE}/|g" \
- -e "s|/usr/X11R6/|${X11BASE}/|g")
+ -e "s|/usr/X/|${LOCALBASE}/|g" \
+ -e "s|/usr/X11/|${LOCALBASE}/|g" \
+ -e "s|/usr/X11R6/|${LOCALBASE}/|g")
do-install:
.for file in ${EXEC}