aboutsummaryrefslogtreecommitdiff
path: root/cad/spice
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1996-12-23 07:26:19 +0000
committerThomas Gellekum <tg@FreeBSD.org>1996-12-23 07:26:19 +0000
commit32b8c8be6c854fabf120e7c9ae54c630ca589d28 (patch)
treefc6ec8bcc816dfc933e5c13a867b5ca5b8330ed0 /cad/spice
parent63708858784fdeb2279e2a8bf5d0981b04320780 (diff)
downloadports-32b8c8be6c854fabf120e7c9ae54c630ca589d28.tar.gz
ports-32b8c8be6c854fabf120e7c9ae54c630ca589d28.zip
Use the original version from EECS, not the patched linux stuff.
Closes PR 2254. Submitted by: Julian Jenkins <kaveman@magna.com.au>
Notes
Notes: svn path=/head/; revision=5070
Diffstat (limited to 'cad/spice')
-rw-r--r--cad/spice/Makefile15
-rw-r--r--cad/spice/distinfo2
-rw-r--r--cad/spice/files/Makefile10
-rw-r--r--cad/spice/files/patch-aa99
4 files changed, 62 insertions, 64 deletions
diff --git a/cad/spice/Makefile b/cad/spice/Makefile
index e55d152586a0..cc61a4627466 100644
--- a/cad/spice/Makefile
+++ b/cad/spice/Makefile
@@ -3,14 +3,15 @@
# Date created: 26 Mar 96
# Whom: Julian Jenkins <kaveman@magna.com.au>
#
-# $Id: Makefile,v 1.4 1996/11/15 23:31:01 obrien Exp $
+# $Id: Makefile,v 1.5 1996/11/18 10:34:54 asami Exp $
#
-DISTNAME= spice3f4
+DISTNAME= sp3f4.kit
PKGNAME= spice-3f4
CATEGORIES= cad
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR= apps/circuits
+MASTER_SITES= ftp://ic.eecs.berkeley.edu/pub/Spice3/
+EXTRACT_SUFX= .tar.Z
+WRKSRC= ${WRKDIR}
#PATCH_SITES= ftp://ic.eecs.berkeley.edu/pub/Spice3/3f4patches
#PATCHFILES= grid.patch newcoms.patch spsmp.patch
@@ -19,6 +20,9 @@ MASTER_SITE_SUBDIR= apps/circuits
MAINTAINER= kaveman@magna.com.au
RESTRICTED= "export restrictions"
+MAN1= sconvert.1 nutmeg.1 spice.1
+MAN3= mfb.3
+MAN5= mfbcap.5
post-install:
chmod a+rx ${PREFIX}/bin/spice3 ${PREFIX}/bin/nutmeg \
@@ -28,8 +32,5 @@ post-install:
${PREFIX}/bin/sconvert ${PREFIX}/bin/help ${PREFIX}/bin/proc2mod \
${PREFIX}/bin/multidec
chmod -R a+rX ${PREFIX}/share/spice
- chmod a+rx ${PREFIX}/man/man5/mfbcap.5.gz \
- ${PREFIX}/man/man1/sconvert.1.gz ${PREFIX}/man/man1/nutmeg.1.gz \
- ${PREFIX}/man/man1/spice.1.gz ${PREFIX}/man/man3/mfb.3.gz
.include <bsd.port.mk>
diff --git a/cad/spice/distinfo b/cad/spice/distinfo
index c5b80aa80425..06e45db8691c 100644
--- a/cad/spice/distinfo
+++ b/cad/spice/distinfo
@@ -1 +1 @@
-MD5 (spice3f4.tar.gz) = 8b0daf037e68aa675e37e23632150b4d
+MD5 (sp3f4.kit.tar.Z) = d55eb08a7f523248b1b509092a444aeb
diff --git a/cad/spice/files/Makefile b/cad/spice/files/Makefile
index 15c041ef2099..0327cb4ac36c 100644
--- a/cad/spice/files/Makefile
+++ b/cad/spice/files/Makefile
@@ -4,8 +4,8 @@ all:
install:
util/build FreeBSD install
- gzip < man/man5/mfbcap.5 > ${PREFIX}/man/man5/mfbcap.5.gz
- gzip < man/man1/sconvert.1 > ${PREFIX}/man/man1/sconvert.1.gz
- gzip < man/man1/nutmeg.1 > ${PREFIX}/man/man1/nutmeg.1.gz
- gzip < man/man1/spice.1 > ${PREFIX}/man/man1/spice.1.gz
- gzip < man/man3/mfb.3 > ${PREFIX}/man/man3/mfb.3.gz
+ install -c -m 644 -o bin -g bin man/man5/mfbcap.5 ${PREFIX}/man/man5/mfbcap.5
+ install -c -m 644 -o bin -g bin man/man1/sconvert.1 ${PREFIX}/man/man1/sconvert.1
+ install -c -m 644 -o bin -g bin man/man1/nutmeg.1 ${PREFIX}/man/man1/nutmeg.1
+ install -c -m 644 -o bin -g bin man/man1/spice.1 ${PREFIX}/man/man1/spice.1
+ install -c -m 644 -o bin -g bin man/man3/mfb.3 ${PREFIX}/man/man3/mfb.3
diff --git a/cad/spice/files/patch-aa b/cad/spice/files/patch-aa
index e3b82b47b0d5..9b4c5d314d90 100644
--- a/cad/spice/files/patch-aa
+++ b/cad/spice/files/patch-aa
@@ -1,11 +1,28 @@
-*** conf/defaults.orig Thu Mar 28 21:25:24 1996
---- conf/defaults Sun Mar 31 11:04:30 1996
+*** conf/defaults.orig Thu Jul 29 23:33:56 1993
+--- conf/defaults Sat Dec 21 14:15:35 1996
***************
-*** 108,119 ****
+*** 65,71 ****
+ # the following definition:
+ # SYS_DIR = $(DIST_DIR)
+
+! SYS_DIR = $(TOP1)/$(SYSTEM)
+
+ # OBJ_TOP is the directory in which intermidiate files reside
+ # These are ".o" files, synthesized ".c" files, ".a" files,
+--- 65,71 ----
+ # the following definition:
+ # SYS_DIR = $(DIST_DIR)
+
+! SYS_DIR = $(TOP0)/$(SYSTEM)
+
+ # OBJ_TOP is the directory in which intermidiate files reside
+ # These are ".o" files, synthesized ".c" files, ".a" files,
+***************
+*** 105,116 ****
+ # identified as and SYSTEM is the name of the per-system definitions
# file listed on the "build" command line.
- # SPICE_DIR = $(TOP1)/$(SYSTEM)
-! SPICE_DIR = $(DIST_DIR)
+! SPICE_DIR = $(TOP1)/$(SYSTEM)
! SPICE_LIB_DIR = $(SPICE_DIR)/lib
SPICE_EXEC_DIR = $(SPICE_DIR)/bin
@@ -14,10 +31,10 @@
S_SPICE_EXEC_DIR= $(S_SPICE_DIR)/bin
# INSTALL_DIRS lists the directories that need to be created before
---- 108,119 ----
+--- 105,116 ----
+ # identified as and SYSTEM is the name of the per-system definitions
# file listed on the "build" command line.
- # SPICE_DIR = $(TOP1)/$(SYSTEM)
! SPICE_DIR = ${PREFIX}
! SPICE_LIB_DIR = $(SPICE_DIR)/share/spice
SPICE_EXEC_DIR = $(SPICE_DIR)/bin
@@ -28,7 +45,7 @@
# INSTALL_DIRS lists the directories that need to be created before
***************
-*** 132,142 ****
+*** 129,135 ****
# an extra definition to work around the same strange bug. See either
# file "conf/vax" or "conf/gcc".
@@ -36,11 +53,7 @@
# CC_OPT: Default compile options (optimization/debug level, other)
-! CC_OPT = -g
-
- # CC_OPT_SAFE: Special compile options to override CC_OPT for code
- # which typically causes problems for most compilers (bsim1 and bsim2).
---- 132,142 ----
+--- 129,135 ----
# an extra definition to work around the same strange bug. See either
# file "conf/vax" or "conf/gcc".
@@ -48,12 +61,8 @@
# CC_OPT: Default compile options (optimization/debug level, other)
-! CC_OPT =
-
- # CC_OPT_SAFE: Special compile options to override CC_OPT for code
- # which typically causes problems for most compilers (bsim1 and bsim2).
***************
-*** 206,212 ****
+*** 203,209 ****
# X_DIR indicates the top of the X11 lib/include hierarchy; it is only
# a convenience that is used in the following definitions.
@@ -61,7 +70,7 @@
# INCX lists the X include directories. This may be different between
# MIT X11r5, X11r4, and your vendor's version of X11, though listing
---- 206,212 ----
+--- 203,209 ----
# X_DIR indicates the top of the X11 lib/include hierarchy; it is only
# a convenience that is used in the following definitions.
@@ -70,7 +79,7 @@
# INCX lists the X include directories. This may be different between
# MIT X11r5, X11r4, and your vendor's version of X11, though listing
***************
-*** 286,292 ****
+*** 282,288 ****
# code for either or both MFB (a terminal independent graphics
# interface) or X11.
@@ -78,7 +87,7 @@
# BUGADDR is the e-mail address to send bug reports. If left blank
# the "bug" command in spice will not operate.
---- 286,292 ----
+--- 282,288 ----
# code for either or both MFB (a terminal independent graphics
# interface) or X11.
@@ -87,15 +96,15 @@
# BUGADDR is the e-mail address to send bug reports. If left blank
# the "bug" command in spice will not operate.
***************
-*** 296,302 ****
+*** 292,298 ****
# DEFAULT_EDITOR lists where the default editor used by the "edit"
# command is located.
-! DEFAULT_EDITOR = jove
+! DEFAULT_EDITOR = vi
# ASCII_RAWFILE indicates that the default format of the spice3 raw data
# file should be in human-readable format ( = 1 ) or in the smaller,
---- 296,302 ----
+--- 292,298 ----
# DEFAULT_EDITOR lists where the default editor used by the "edit"
# command is located.
@@ -150,32 +159,20 @@
extern char *getenv();
extern char *getwd();
extern int rand();
-*** src/lib/misc/math.c.orig Sat Jun 19 06:13:39 1993
---- src/lib/misc/math.c Sun Mar 31 13:38:40 1996
***************
-*** 11,17 ****
- #include "misc.h"
- #include "suffix.h"
+*** 111,122 ****
+--- 111,124 ----
+ # endif /* clearerr */
+ # endif /* HAS_CLEARERR */
-! #ifdef HAS_NO_IEEE_LOGB
-
- /* changed all instances of logb to normslogb (NJ) */
- double normslogb(x)
---- 11,17 ----
- #include "misc.h"
- #include "suffix.h"
-
-! #if (defined(HAS_NO_IEEE_LOGB) || defined(__FreeBSD__))
-
- /* changed all instances of logb to normslogb (NJ) */
- double normslogb(x)
-***************
-*** 58,64 ****
-
- return x * z;
- }
--
- #endif
-
- #ifdef HAS_NO_ERFC
---- 58,63 ----
++ #ifndef __FreeBSD__
+ # ifndef bzero
+ extern int bzero();
+ # endif
+ # ifndef bcopy
+ extern void bcopy();
+ # endif
++ #endif /* __FreeBSD__ */
+
+ # ifndef index
+ # ifdef HAS_INDEX