aboutsummaryrefslogtreecommitdiff
path: root/cad/sweethome3d
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-03-21 20:16:53 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-03-21 20:16:53 +0000
commitd2a582db5c6aefe633f06533704bd6d61196cd83 (patch)
tree476f06f942dfff3c0b8a9c34498b46d7c2d6ec4c /cad/sweethome3d
parente42cf961914010624bc8dbe300813c63f2eb1dc1 (diff)
downloadports-d2a582db5c6aefe633f06533704bd6d61196cd83.tar.gz
ports-d2a582db5c6aefe633f06533704bd6d61196cd83.zip
Sweet Home 3D is a free interior design application that helps you place your
furniture on a house 2D plan, with a 3D preview. WWW: http://www.sweethome3d.com PR: ports/171760 Submitted by: Matthias Petermann <matthias@petermann.it>
Notes
Notes: svn path=/head/; revision=314867
Diffstat (limited to 'cad/sweethome3d')
-rw-r--r--cad/sweethome3d/Makefile41
-rw-r--r--cad/sweethome3d/distinfo2
-rw-r--r--cad/sweethome3d/files/patch-build.xml15
-rw-r--r--cad/sweethome3d/files/patch-src__com__eteks__sweethome3d__SweetHome3DBootstrap.java37
-rw-r--r--cad/sweethome3d/files/sweethome3d.sh.in9
-rw-r--r--cad/sweethome3d/pkg-descr4
6 files changed, 108 insertions, 0 deletions
diff --git a/cad/sweethome3d/Makefile b/cad/sweethome3d/Makefile
new file mode 100644
index 000000000000..41448d9ab527
--- /dev/null
+++ b/cad/sweethome3d/Makefile
@@ -0,0 +1,41 @@
+# Created by: Matthias Petermann <matthias@petermann.it>
+# $FreeBSD$
+
+PORTNAME= sweethome3d
+PORTVERSION= 3.6
+CATEGORIES= cad java
+MASTER_SITES= SF/${PORTNAME}/SweetHome3D-source/${DISTNAME}/
+DISTNAME= SweetHome3D-${PORTVERSION}-src
+
+MAINTAINER= matthias@petermann.it
+COMMENT= Free interior design application
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= java3d>=0:${PORTSDIR}/java/java3d
+RUN_DEPENDS= java3d>=0:${PORTSDIR}/java/java3d
+
+USE_ZIP= yes
+USE_ANT= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.6+
+
+ALL_TARGET= jarExecutable
+JARNAME= SweetHome3D-${PORTVERSION}.jar
+
+SUB_FILES= sweethome3d.sh
+SUB_LIST= JARNAME=${JARNAME}
+
+PLIST_FILES= bin/sweethome3d \
+ %%JAVAJARDIR%%/${JARNAME} \
+ share/pixmaps/sweethome3d-icon.png
+
+DESKTOP_ENTRIES="Sweet Home 3D" "" "${PORTNAME}-icon" "${PORTNAME}" "" false
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/install/${JARNAME} ${JAVAJARDIR}/${JARNAME}
+ ${INSTALL_SCRIPT} ${WRKDIR}/sweethome3d.sh ${PREFIX}/bin/sweethome3d
+ ${INSTALL_DATA} ${WRKSRC}/deploy/SweetHome3DIcon32x32.png \
+ ${PREFIX}/share/pixmaps/sweethome3d-icon.png
+
+.include <bsd.port.mk>
diff --git a/cad/sweethome3d/distinfo b/cad/sweethome3d/distinfo
new file mode 100644
index 000000000000..197c721974b8
--- /dev/null
+++ b/cad/sweethome3d/distinfo
@@ -0,0 +1,2 @@
+SHA256 (SweetHome3D-3.6-src.zip) = 944d7c5b3b145504ad28fcc0da831e7b03855cd20770f18f6cb86b75feaecb04
+SIZE (SweetHome3D-3.6-src.zip) = 18303801
diff --git a/cad/sweethome3d/files/patch-build.xml b/cad/sweethome3d/files/patch-build.xml
new file mode 100644
index 000000000000..700a37dbec86
--- /dev/null
+++ b/cad/sweethome3d/files/patch-build.xml
@@ -0,0 +1,15 @@
+--- ./build.xml.orig 2012-09-18 23:53:21.000000000 +0200
++++ ./build.xml 2012-09-18 23:53:37.000000000 +0200
+@@ -388,12 +388,6 @@
+ <zipfileset src="build/Textures.jar"/>
+ <zipfileset src="build/Help.jar"/>
+ <fileset dir="lib">
+- <include name="windows/**/*.dll"/>
+- <include name="linux/**/*.so"/>
+- <include name="macosx/*.jnilib"/>
+- <include name="macosx/*.jar"/>
+- </fileset>
+- <fileset dir="lib">
+ <include name="*.jar"/>
+ </fileset>
+ <fileset dir="libtest">
diff --git a/cad/sweethome3d/files/patch-src__com__eteks__sweethome3d__SweetHome3DBootstrap.java b/cad/sweethome3d/files/patch-src__com__eteks__sweethome3d__SweetHome3DBootstrap.java
new file mode 100644
index 000000000000..35f77a8abd60
--- /dev/null
+++ b/cad/sweethome3d/files/patch-src__com__eteks__sweethome3d__SweetHome3DBootstrap.java
@@ -0,0 +1,37 @@
+--- ./src/com/eteks/sweethome3d/SweetHome3DBootstrap.java.orig 2012-09-18 23:50:39.000000000 +0200
++++ ./src/com/eteks/sweethome3d/SweetHome3DBootstrap.java 2012-09-18 23:52:55.000000000 +0200
+@@ -48,23 +48,12 @@
+ "jnlp.jar",
+ "j3dcore.jar", // Main Java 3D jars
+ "vecmath.jar",
+- "j3dutils.jar",
+- "macosx/gluegen-rt.jar", // Mac OS X jars and DLLs
+- "macosx/jogl.jar",
+- "macosx/libgluegen-rt.jnilib",
+- "macosx/libjogl.jnilib",
+- "macosx/libjogl_awt.jnilib",
+- "macosx/libjogl_cg.jnilib"}));
++ "j3dutils.jar"
++ }));
+ if ("64".equals(System.getProperty("sun.arch.data.model"))) {
+- extensionJarsAndDlls.add("linux/x64/libj3dcore-ogl.so"); // Linux 64 bits DLLs
+- extensionJarsAndDlls.add("windows/x64/j3dcore-ogl.dll"); // Windows 64 bits DLLs
++ extensionJarsAndDlls.add("/usr/local/openjdk6/jre/lib/amd64/libj3dcore-ogl.so");
+ } else {
+- extensionJarsAndDlls.add("linux/i386/libj3dcore-ogl.so"); // Linux 32 bits DLLs
+- extensionJarsAndDlls.add("linux/i386/libj3dcore-ogl-cg.so"); // Windows 32 bits DLLs
+- extensionJarsAndDlls.add("windows/i386/j3dcore-d3d.dll");
+- extensionJarsAndDlls.add("windows/i386/j3dcore-ogl.dll");
+- extensionJarsAndDlls.add("windows/i386/j3dcore-ogl-cg.dll");
+- extensionJarsAndDlls.add("windows/i386/j3dcore-ogl-chk.dll");
++ extensionJarsAndDlls.add("/usr/local/openjdk6/jre/lib/i386/libj3dcore-ogl.so");
+ }
+
+ String [] applicationPackages = {
+@@ -93,4 +82,4 @@
+ // Call application class main method with reflection
+ applicationClassMain.invoke(null, new Object [] {args});
+ }
+-}
+\ No newline at end of file
++}
diff --git a/cad/sweethome3d/files/sweethome3d.sh.in b/cad/sweethome3d/files/sweethome3d.sh.in
new file mode 100644
index 000000000000..5380e161581c
--- /dev/null
+++ b/cad/sweethome3d/files/sweethome3d.sh.in
@@ -0,0 +1,9 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+JAVA="%%LOCALBASE%%/bin/java"
+JARPATH="%%JAVALIBDIR%%"
+export JAVA_VERSION="%%JAVA_VERSION%%"
+
+exec "${JAVA}" -Xmx1024m -jar "${JARPATH}/%%JARNAME%%" "$@"
diff --git a/cad/sweethome3d/pkg-descr b/cad/sweethome3d/pkg-descr
new file mode 100644
index 000000000000..7517b943591d
--- /dev/null
+++ b/cad/sweethome3d/pkg-descr
@@ -0,0 +1,4 @@
+Sweet Home 3D is a free interior design application that helps you place your
+furniture on a house 2D plan, with a 3D preview.
+
+WWW: http://www.sweethome3d.com