aboutsummaryrefslogtreecommitdiff
path: root/cad/vipec
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-03 05:30:51 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-03 05:30:51 +0000
commitbb9c476eb6387426d25b3926cedad6f431d0a299 (patch)
tree93fd10174f4ea45d153baeaac04555d0a96ad344 /cad/vipec
parent23623ef149fcefebce9f81b86e2de8ea2b96ce98 (diff)
downloadports-bb9c476eb6387426d25b3926cedad6f431d0a299.tar.gz
ports-bb9c476eb6387426d25b3926cedad6f431d0a299.zip
add vipec
ViPEC is a powerful tool for the analysis of high frequency, linear electrical networks
Notes
Notes: svn path=/head/; revision=40787
Diffstat (limited to 'cad/vipec')
-rw-r--r--cad/vipec/Makefile24
-rw-r--r--cad/vipec/distinfo1
-rw-r--r--cad/vipec/files/patch-Makefile11
-rw-r--r--cad/vipec/pkg-comment1
-rw-r--r--cad/vipec/pkg-descr15
-rw-r--r--cad/vipec/pkg-plist62
6 files changed, 114 insertions, 0 deletions
diff --git a/cad/vipec/Makefile b/cad/vipec/Makefile
new file mode 100644
index 000000000000..bc7e54a1d173
--- /dev/null
+++ b/cad/vipec/Makefile
@@ -0,0 +1,24 @@
+# ex:ts=8
+# New ports collection makefile for: vipec
+# Date created: Aprll 3, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vipec
+PORTVERSION= 3.0.3
+CATEGORIES= cad
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+BUILD_DEPENDS= tmake:${PORTSDIR}/devel/tmake
+
+USE_QT2= yes
+USE_GMAKE= yes
+MAKE_ENV+= TMAKEPATH="${LOCALBASE}/share/tmake/freebsd-g++" \
+ QTDIR="${X11BASE}" MOC="${X11BASE}/bin/moc2"
+
+.include <bsd.port.mk>
diff --git a/cad/vipec/distinfo b/cad/vipec/distinfo
new file mode 100644
index 000000000000..86681144000d
--- /dev/null
+++ b/cad/vipec/distinfo
@@ -0,0 +1 @@
+MD5 (vipec-3.0.3.tar.gz) = 67db1d0c199d31505c7891db1489552f
diff --git a/cad/vipec/files/patch-Makefile b/cad/vipec/files/patch-Makefile
new file mode 100644
index 000000000000..4bdcc00c8310
--- /dev/null
+++ b/cad/vipec/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig Tue Apr 3 12:24:18 2001
++++ Makefile Tue Apr 3 12:32:56 2001
+@@ -9,7 +9,7 @@
+ SUBDIRS = src
+ SOURCEPATH = `pwd`
+ VERSION = 3.0.3
+-INSTALLDIR = /opt/vipec
++INSTALLDIR = ${PREFIX}/vipec
+
+ export VERSION
+
diff --git a/cad/vipec/pkg-comment b/cad/vipec/pkg-comment
new file mode 100644
index 000000000000..45c1059afb52
--- /dev/null
+++ b/cad/vipec/pkg-comment
@@ -0,0 +1 @@
+Analyze high frequency, linear electrical networks
diff --git a/cad/vipec/pkg-descr b/cad/vipec/pkg-descr
new file mode 100644
index 000000000000..341b536dcee3
--- /dev/null
+++ b/cad/vipec/pkg-descr
@@ -0,0 +1,15 @@
+ViPEC is a powerful tool for the analysis of high frequency, linear
+electrical networks. It takes a schematic description of the electrical
+network and performs a linear analysis in the frequency domain. The output
+is in the form of port parameters (S, Y or Z) with results presented on a
+user defined grid, Smithchart or table. It can also be used to compute
+other characteristics like stability factors and group delay.
+
+ViPEC supports various lumped elements (capacitors, resistors etc.) as well
+as distributed networks like transmission lines, microstrip and stripline
+structures. Two port data files are also supported (e.g. the 2-port frequency
+parameters of various RF transistors as supplied by the manufacturer). The
+component library is under constant development with new elements added at
+regular intervals.
+
+WWW: http://vipec.sourceforge.net/
diff --git a/cad/vipec/pkg-plist b/cad/vipec/pkg-plist
new file mode 100644
index 000000000000..36271f192265
--- /dev/null
+++ b/cad/vipec/pkg-plist
@@ -0,0 +1,62 @@
+vipec/vipec
+vipec/CHANGES
+vipec/COPYRIGHT
+vipec/INTERNATIONALIZATION
+vipec/README
+vipec/COPYING
+vipec/LICENSE
+vipec/help/models/block.html
+vipec/help/models/block.png
+vipec/help/models/capacitor.html
+vipec/help/models/capacitor.png
+vipec/help/models/coupled.png
+vipec/help/models/gyrator.html
+vipec/help/models/gyrator.png
+vipec/help/models/idealcoupled.html
+vipec/help/models/inductor.html
+vipec/help/models/inductor.png
+vipec/help/models/inductorq.html
+vipec/help/models/inductorq.png
+vipec/help/models/port.html
+vipec/help/models/port.png
+vipec/help/models/resistor.html
+vipec/help/models/resistor.png
+vipec/help/models/tlin2port.html
+vipec/help/models/tlin2port.png
+vipec/help/models/tlin4port.html
+vipec/help/models/tlin4port.png
+vipec/help/models/tlinphysical.html
+vipec/help/models/tlinphysical.png
+vipec/help/models/vccs.html
+vipec/help/models/vccs.png
+vipec/help/analysing.html
+vipec/help/components.html
+vipec/help/disclaimer.html
+vipec/help/frequency.html
+vipec/help/index.html
+vipec/help/license.html
+vipec/help/navigation.html
+vipec/help/outputs.html
+vipec/help/placing.html
+vipec/help/schematics.html
+vipec/help/substrates.html
+vipec/help/units.html
+vipec/help/variables.html
+vipec/help/what_is.html
+vipec/ckt/amplifier.ckt
+vipec/ckt/bandpass.ckt
+vipec/ckt/bandpass.s2p
+vipec/ckt/bandpass2.ckt
+vipec/ckt/coupled_line_filter.ckt
+vipec/ckt/coupler.ckt
+vipec/ckt/datafile.ckt
+vipec/ckt/highpass.ckt
+vipec/ckt/nec70000.s2p
+vipec/ckt/stripline.ckt
+vipec/messages/vipec_fr.qm
+vipec/messages/vipec_fr.ts
+@dirrm vipec/help/models
+@dirrm vipec/help
+@dirrm vipec/ckt
+@dirrm vipec/messages
+@dirrm vipec