aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2008-08-23 00:51:40 +0000
committerHiroki Sato <hrs@FreeBSD.org>2008-08-23 00:51:40 +0000
commit0f60c9ed8fea985fd07a0aa310965e9569b708f5 (patch)
treec479fb55705e9ff6b67ddf38d68ae6f6e74a7862 /cad
parentfa0f7dbc277024fdbadc25fee5d6c66fce48a5fc (diff)
downloadports-0f60c9ed8fea985fd07a0aa310965e9569b708f5.tar.gz
ports-0f60c9ed8fea985fd07a0aa310965e9569b708f5.zip
Update to 0.15. Changes include:
* Editing capabilities. "klayout" in it's basic form still operates as pure viewer. However, a mode is available that enables editing capabilities. See Editor mode quickstart manual for a more detailed description * Some RBA extensions: i.e. conversion from "double" type polygons to "integer" type ones. * A default layer table can be configured in the "Application" tab of the setup dialog. This table will be loaded whenever a layout is opened or created. * A installer for Windows is provided now. * Properties are supported on instances now as well. * Code is compatible with gcc 4.3.0 now. * Enhanced compatibility with SunStudio 11 compiler (in particular in RBA). * Various bug fixes (i.e. in GDS reader and OASIS writer).
Notes
Notes: svn path=/head/; revision=219026
Diffstat (limited to 'cad')
-rw-r--r--cad/klayout/Makefile22
-rw-r--r--cad/klayout/distinfo6
-rw-r--r--cad/klayout/files/patch-build.sh17
3 files changed, 29 insertions, 16 deletions
diff --git a/cad/klayout/Makefile b/cad/klayout/Makefile
index 288d4f7aad94..1218ab46f156 100644
--- a/cad/klayout/Makefile
+++ b/cad/klayout/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= klayout
-PORTVERSION= 0.14
-PORTREVISION= 2
+PORTVERSION= 0.15
CATEGORIES= cad
MASTER_SITES= http://www.klayout.de/
@@ -17,19 +16,24 @@ COMMENT= A Qt-based GDS2 Viewer
USE_GMAKE= yes
USE_QT_VER= 4
QT_COMPONENTS= corelib gui network moc sql uic rcc qt3support xml
-PLIST_FILES= bin/klayout
+PLIST_FILES= bin/klayout \
+ bin/strm2gds \
+ bin/strm2oas \
+ bin/strmclip \
+ bin/strmcmp
PLATFORMKEYWORD= freebsd-32-gcc-release
do-build:
- cd ${WRKSRC} \
- && ${SH} build.sh -platform ${PLATFORMKEYWORD} \
- -qtbin ${QT_PREFIX}/bin \
- -qtinc ${QT_INCDIR} \
- -qtlib ${QT_LIBDIR}
+ cd ${WRKSRC} && \
+ ${SH} build.sh -platform ${PLATFORMKEYWORD} \
+ -qtbin ${QT_PREFIX}/bin \
+ -qtinc ${QT_INCDIR} \
+ -qtlib ${QT_LIBDIR}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin.${PLATFORMKEYWORD}/klayout \
+ cd ${WRKSRC}/bin.${PLATFORMKEYWORD} && \
+ ${INSTALL_PROGRAM} ${PLIST_FILES:S,^bin/,,} \
${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/cad/klayout/distinfo b/cad/klayout/distinfo
index af39cc91f4dd..66b6947eeeef 100644
--- a/cad/klayout/distinfo
+++ b/cad/klayout/distinfo
@@ -1,3 +1,3 @@
-MD5 (klayout-0.14.tar.gz) = 0c0fa79aabc67ff42dc613cd2ed567cb
-SHA256 (klayout-0.14.tar.gz) = fecbcdf2d9a33627bfa7ee45c8282c5112c9faad37e2ac4727576dd20f5a3cb3
-SIZE (klayout-0.14.tar.gz) = 766242
+MD5 (klayout-0.15.tar.gz) = 07dee91db693b9d4d9577f7bc265fbe2
+SHA256 (klayout-0.15.tar.gz) = 72f69852e116bdeeee7a93cd896f1bc8dd7feaeefe5a17e5c967af51e4b56b71
+SIZE (klayout-0.15.tar.gz) = 863520
diff --git a/cad/klayout/files/patch-build.sh b/cad/klayout/files/patch-build.sh
index cd6495b21678..72cad97b3b06 100644
--- a/cad/klayout/files/patch-build.sh
+++ b/cad/klayout/files/patch-build.sh
@@ -1,6 +1,6 @@
---- build.sh.orig Fri Nov 9 04:31:36 2007
-+++ build.sh Sun Jan 6 18:57:53 2008
-@@ -126,11 +126,11 @@
+--- build.sh.orig 2008-08-17 06:40:32.000000000 +0900
++++ build.sh 2008-08-23 09:47:35.000000000 +0900
+@@ -136,11 +136,11 @@
exit 1
fi
@@ -14,7 +14,16 @@
echo "*** ERROR: unable to locate Qt UIC in $QTBIN"
exit 1
fi
-@@ -231,12 +231,12 @@
+@@ -238,7 +238,7 @@
+ mkdir -p $BIN
+ cp $BUILD/main/$EXEC_NAME $BIN
+ for bin in $OTHER_BIN; do
+- cp $BUILD/$bin $BIN
++ cp $BUILD/main/$bin $BIN
+ done
+ for plugin in $PLUGINS; do
+ cp $BUILD/$plugin/*.so $BIN
+@@ -249,12 +249,12 @@
echo "Build done."
echo ""
echo "Final binary is ready in $BIN/$EXEC_NAME."