aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2003-08-08 16:06:50 +0000
committerMaho Nakata <maho@FreeBSD.org>2003-08-08 16:06:50 +0000
commit02ca99bd5f0fb806476d75d9b772f77fd23b1efa (patch)
tree781a374362405d68a1b79d734ea788df261e14e0 /cad
parent0b699f42b34b600b2b42151ebc278b23172b0d7a (diff)
downloadports-02ca99bd5f0fb806476d75d9b772f77fd23b1efa.tar.gz
ports-02ca99bd5f0fb806476d75d9b772f77fd23b1efa.zip
update to 1.1
Submitted by: "Pedro F. Giffuni" <giffunip@yahoo.com>
Notes
Notes: svn path=/head/; revision=86596
Diffstat (limited to 'cad')
-rw-r--r--cad/calculix/Makefile24
-rw-r--r--cad/calculix/distinfo14
-rw-r--r--cad/calculix/files/patch-ccx_1.0+src+Makefile33
-rw-r--r--cad/calculix/files/patch-ccx_1.0+src+ccx_1.0.c11
-rw-r--r--cad/calculix/files/patch-ccx_1.0+src+profil.f10
-rw-r--r--cad/calculix/files/patch-ccx_VER+src+CalculiX.h (renamed from cad/calculix/files/patch-ccx_1.0+src+CalculiX.h)4
-rw-r--r--cad/calculix/files/patch-ccx_VER+src+Makefile33
-rw-r--r--cad/calculix/files/patch-ccx_VER+src+geometry.cpp11
-rw-r--r--cad/calculix/files/patch-cgx_1.0+src+Makefile23
-rw-r--r--cad/calculix/files/patch-cgx_1.0+src+cgx.h21
-rw-r--r--cad/calculix/files/patch-cgx_1.0+src+readccx.c127
-rw-r--r--cad/calculix/files/patch-cgx_VER+src+Makefile29
-rw-r--r--cad/calculix/files/patch-cgx_VER+src+cgx.h13
-rw-r--r--cad/calculix/files/patch-cgx_VER+src+cgxToCdsm.cpp11
-rw-r--r--cad/calculix/files/patch-cgx_VER+src+ctrlPoint.cpp12
-rw-r--r--cad/calculix/files/patch-cgx_VER+src+knotVect.cpp11
-rw-r--r--cad/calculix/files/patch-cgx_VER+src+nurbsBase.cpp11
-rw-r--r--cad/calculix/files/patch-cgx_VER+src+nurbsBase.h11
-rw-r--r--cad/calculix/files/patch-cgx_VER+src+smeUndo.cpp11
-rw-r--r--cad/calculix/pkg-plist100
20 files changed, 275 insertions, 245 deletions
diff --git a/cad/calculix/Makefile b/cad/calculix/Makefile
index 836f1a7775fd..91957da058cf 100644
--- a/cad/calculix/Makefile
+++ b/cad/calculix/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= CalculiX
-PORTVERSION= 1.0
+PORTVERSION= 1.1
CATEGORIES= cad
MASTER_SITES= http://www.dhondt.de/
DISTFILES= ccx_${PORTVERSION}.src.tar.gz cgx_${PORTVERSION}.tar.gz
@@ -17,6 +17,7 @@ DISTFILES+= ccx_${PORTVERSION}.ps.tar.gz cgx_${PORTVERSION}.ps.tar.gz \
.ifdef WITH_EXAMPLES
DISTFILES+= ccx_${PORTVERSION}.test.tar.gz
.endif
+DIST_SUBDIR= calculix
MAINTAINER= maho@FreeBSD.org
COMMENT= A Three-Dimensional Structural Finite Element Program
@@ -30,6 +31,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_MESA= yes
USE_REINPLACE= yes
BLAS_LIBS= -lf77blas -latlas
+BROWSER?= mozilla
+PSVIEWER?= gv
.if !defined(WITH_EXAMPLES)
PLIST_SUB= WITH_EXAMPLES="@comment "
@@ -45,21 +48,26 @@ pre-everything::
pre-build:
@${REINPLACE_CMD} -e 's+%%FC%%+${FC}+g ; s+%%CC%%+${CC}+g ; \
s+%%BLAS_LIBS%%+${BLAS_LIBS}+ ; \
- s+%%LOCALBASE%%+${LOCALBASE}+g;' ${WRKSRC}/ccx_${PORTVERSION}/src/Makefile
- @${REINPLACE_CMD} -e 's+%%X11BASE%%+${X11BASE}+g ; \
- s+%%CFLAGS%%+${CFLAGS}+g;' ${WRKSRC}/cgx_${PORTVERSION}/src/Makefile
- @${REINPLACE_CMD} -e 's+%%DOCSDIR%%+${DOCSDIR}+g;' ${WRKSRC}/cgx_${PORTVERSION}/src/cgx.h
+ s+%%LOCALBASE%%+${LOCALBASE}+g;' \
+ ${WRKSRC}/ccx_${PORTVERSION}/src/Makefile
+ @${REINPLACE_CMD} -e 's+%%X11BASE%%+${X11BASE}+g; \
+ s+%%PTHREAD_CFLAGS%%+${PTHREAD_CFLAGS}+g; \
+ s+%%PTHREAD_LIBS%%+${PTHREAD_LIBS}+g;' \
+ ${WRKSRC}/cgx_${PORTVERSION}/src/Makefile
+ @${REINPLACE_CMD} -e 's+%%DOCSDIR%%+${DOCSDIR}+g; \
+ s+"netscape"+"${BROWSER}"+ ; \
+ s+"ghostview"+"${PSVIEWER}"+ ;' \
+ ${WRKSRC}/cgx_${PORTVERSION}/src/cgx.h
do-build:
- @(cd ${WRKSRC}/ccx_${PORTVERSION}/src; $(MAKE) )
- @(cd ${WRKSRC}/cgx_${PORTVERSION}/src; $(MAKE) )
+ @(cd ${WRKSRC}/ccx_${PORTVERSION}/src; ${SETENV} ${MAKE_ENV} $(MAKE) )
+ @(cd ${WRKSRC}/cgx_${PORTVERSION}/src; ${SETENV} ${MAKE_ENV} $(MAKE) )
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/ccx_${PORTVERSION}/src/ccx_${PORTVERSION} \
${PREFIX}/bin/ccx
@${INSTALL_PROGRAM} ${WRKSRC}/cgx_${PORTVERSION}/src/cgx \
${PREFIX}/bin/cgx
-#The online help system requires the html documentation
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${MKDIR} ${DOCSDIR}/ccx
diff --git a/cad/calculix/distinfo b/cad/calculix/distinfo
index cf7b35792a4d..0bbd0b841ab1 100644
--- a/cad/calculix/distinfo
+++ b/cad/calculix/distinfo
@@ -1,7 +1,7 @@
-MD5 (ccx_1.0.src.tar.gz) = 09073b6365bfe1ac7e1ddc55c86dc229
-MD5 (cgx_1.0.tar.gz) = 3c86372fe880526c48b8cb3f6221f02a
-MD5 (ccx_1.0.ps.tar.gz) = 43a9cf8ea307eadc9383e2c13db8b05f
-MD5 (cgx_1.0.ps.tar.gz) = 4b2e32c3cb924161b51161e35d2b3748
-MD5 (ccx_1.0.htm.tar.gz) = e2c0fc79804e0292fcda57878c3830a3
-MD5 (cgx_1.0.htm.tar.gz) = 4af6c72a3377acfd1098fa4a0d829eff
-MD5 (ccx_1.0.test.tar.gz) = c7788208acb8703f2055fb5899acca47
+MD5 (calculix/ccx_1.1.src.tar.gz) = a8468774cab93aea811a309348d51e25
+MD5 (calculix/cgx_1.1.tar.gz) = 0794dfd5130f16dac785f0744def1403
+MD5 (calculix/ccx_1.1.ps.tar.gz) = ebd20e20724d9061bf193f20aeabbf05
+MD5 (calculix/cgx_1.1.ps.tar.gz) = 213f89fbe12c3acffa724f47f24cddc2
+MD5 (calculix/ccx_1.1.htm.tar.gz) = 392b97c0cb5b9af789aa4ccb45a1d932
+MD5 (calculix/cgx_1.1.htm.tar.gz) = cdbfbbc480e431fcd666ce0b5e90c19e
+MD5 (calculix/ccx_1.1.test.tar.gz) = 45ecbeeaa2444ddf340aa46186814993
diff --git a/cad/calculix/files/patch-ccx_1.0+src+Makefile b/cad/calculix/files/patch-ccx_1.0+src+Makefile
deleted file mode 100644
index b2606bf3a181..000000000000
--- a/cad/calculix/files/patch-ccx_1.0+src+Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
---- ccx_1.0/src/Makefile.orig Sun Mar 2 10:35:58 2003
-+++ ccx_1.0/src/Makefile Thu May 29 14:54:42 2003
-@@ -1,8 +1,8 @@
--CFLAGS = -Wall -O -I ../../../SPOOLES.2.2 -DARCH="Linux"
--FFLAGS = -Wall -O
-+CFLAGS += -Wall -I%%LOCALBASE%%/include/spooles -DARCH="FreeBSD"
-+FFLAGS += -Wall
-
--CC=cc
--FC=g77
-+CC=%%CC%%
-+FC=%%FC%%
-
- .c.o :
- $(CC) $(CFLAGS) -c $<
-@@ -195,15 +195,11 @@
- OCCXC = $(SCCXC:.c=.o)
- OCCXMAIN = $(SCCXMAIN:.c=.o)
-
--DIR=../../../SPOOLES.2.2
-+LIBS = -lspooles -larpack %%BLAS_LIBS%% -lm
-
--LIBS = \
-- $(DIR)/spooles.a \
-- ../../../ARPACK/libarpack_INTEL.a \
-- -lm
-
- ccx_1.0: $(OCCXMAIN) ccx_1.0.a $(LIBS)
-- g77 -Wall -O -o $@ $(OCCXMAIN) ccx_1.0.a $(LIBS)
-+ $(FC) -o $@ $(OCCXMAIN) ccx_1.0.a $(LIBS) -L%%LOCALBASE%%/lib
-
- ccx_1.0.a: $(OCCXF) $(OCCXC)
- ar vr $@ $?
diff --git a/cad/calculix/files/patch-ccx_1.0+src+ccx_1.0.c b/cad/calculix/files/patch-ccx_1.0+src+ccx_1.0.c
deleted file mode 100644
index a40d2bd7b9a0..000000000000
--- a/cad/calculix/files/patch-ccx_1.0+src+ccx_1.0.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ccx_1.0/src/ccx_1.0.c.orig Sun Jun 22 00:33:19 2003
-+++ ccx_1.0/src/ccx_1.0.c Sun Jun 22 00:41:18 2003
-@@ -694,6 +694,8 @@
- mastruct(&nk,kon,ipkon,lakon,&ne,nodeboun,ndirboun,&nboun,ipompc,
- nodempc,&nmpc,nactdof,icol,jq,&mast1,&irow,&isolver,&neq,nnn,
- ikmpc,ilmpc,ikcol,ipointer,&nsky,&nzs,&nmethod);
-+ } else {
-+ neq = 1;
- }
- }
- else{
diff --git a/cad/calculix/files/patch-ccx_1.0+src+profil.f b/cad/calculix/files/patch-ccx_1.0+src+profil.f
deleted file mode 100644
index 67f9efaf6eff..000000000000
--- a/cad/calculix/files/patch-ccx_1.0+src+profil.f
+++ /dev/null
@@ -1,10 +0,0 @@
---- ccx_1.0/src/profil.f.orig Sun Jun 22 00:32:56 2003
-+++ ccx_1.0/src/profil.f Sun Jun 22 00:38:14 2003
-@@ -31,6 +31,7 @@
- do 20 i=1,n
- jstrt=xadj(i)
- jstop=xadj(i+1)-1
-+ if(jstrt.gt.jstop) cycle
- oldmin=adj(jstrt)
- newmin=nnn(adj(jstrt))
- !
diff --git a/cad/calculix/files/patch-ccx_1.0+src+CalculiX.h b/cad/calculix/files/patch-ccx_VER+src+CalculiX.h
index eb7e74173594..8b81c239eaeb 100644
--- a/cad/calculix/files/patch-ccx_1.0+src+CalculiX.h
+++ b/cad/calculix/files/patch-ccx_VER+src+CalculiX.h
@@ -1,5 +1,5 @@
---- ccx_1.0/src/CalculiX.h.orig Mon Mar 3 00:35:58 2003
-+++ ccx_1.0/src/CalculiX.h Mon May 5 21:15:50 2003
+--- ccx_1.1/src/CalculiX.h.orig Mon Mar 3 00:35:58 2003
++++ ccx_1.1/src/CalculiX.h Mon May 5 21:15:50 2003
@@ -24,6 +24,8 @@
#define FORTRAN(A,B) A##_##B
#elif ARCH == HP
diff --git a/cad/calculix/files/patch-ccx_VER+src+Makefile b/cad/calculix/files/patch-ccx_VER+src+Makefile
new file mode 100644
index 000000000000..dbd1fd57ff80
--- /dev/null
+++ b/cad/calculix/files/patch-ccx_VER+src+Makefile
@@ -0,0 +1,33 @@
+--- ccx_1.1/src/Makefile.orig Wed Aug 6 16:22:49 2003
++++ ccx_1.1/src/Makefile Thu Aug 7 08:48:23 2003
+@@ -1,8 +1,8 @@
+-CFLAGS = -Wall -O -I ../../../SPOOLES.2.2 -DARCH="Linux"
+-FFLAGS = -Wall -O
++CFLAGS += -I%%LOCALBASE%%/include/spooles -DARCH="FreeBSD"
++#FFLAGS = -Wall -O
+
+-CC=cc
+-FC=g77
++CC=%%CC%%
++FC=%%FC%%
+
+ .c.o :
+ $(CC) $(CFLAGS) -c $<
+@@ -225,15 +225,10 @@
+ OCCXC = $(SCCXC:.c=.o)
+ OCCXMAIN = $(SCCXMAIN:.c=.o)
+
+-DIR=../../../SPOOLES.2.2
+-
+-LIBS = \
+- $(DIR)/spooles.a \
+- ../../../ARPACK/libarpack_INTEL.a \
+- -lm
++LIBS = -lspooles -larpack %%BLAS_LIBS%% -lm
+
+ ccx_1.1: $(OCCXMAIN) ccx_1.1.a $(LIBS)
+- g77 -Wall -O -o $@ $(OCCXMAIN) ccx_1.1.a $(LIBS)
++ $(FC) -O -o $@ $(OCCXMAIN) ccx_1.1.a $(LIBS) -L%%LOCALBASE%%/lib
+
+ ccx_1.1.a: $(OCCXF) $(OCCXC)
+ ar vr $@ $?
diff --git a/cad/calculix/files/patch-ccx_VER+src+geometry.cpp b/cad/calculix/files/patch-ccx_VER+src+geometry.cpp
new file mode 100644
index 000000000000..dbd7e601c563
--- /dev/null
+++ b/cad/calculix/files/patch-ccx_VER+src+geometry.cpp
@@ -0,0 +1,11 @@
+--- cgx_1.1/src/geometry.cpp.orig Mon Aug 4 15:25:08 2003
++++ cgx_1.1/src/geometry.cpp Thu Aug 7 19:05:53 2003
+@@ -22,7 +22,7 @@
+ // ------------------------
+
+ #include <math.h>
+-#include <iostream.h>
++#include <iostream>
+
+ #include "geometry.h"
+
diff --git a/cad/calculix/files/patch-cgx_1.0+src+Makefile b/cad/calculix/files/patch-cgx_1.0+src+Makefile
deleted file mode 100644
index f65a324bd8b5..000000000000
--- a/cad/calculix/files/patch-cgx_1.0+src+Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
---- cgx_1.0/src/Makefile.orig Tue Apr 8 04:38:13 2003
-+++ cgx_1.0/src/Makefile Mon May 5 21:21:22 2003
-@@ -1,14 +1,12 @@
--CFLAGS = -O2 -Wall \
-+CFLAGS+= %%CFLAGS%% \
- -I./ \
-- -I/usr/include \
-- -I/usr/include/GL \
-- -I/usr/X11R6/include
-+ -I%%X11BASE%%/include/GL \
-+ -I%%X11BASE%%/include
-
- LFLAGS = \
-- -L/usr/lib -lGL -lGLU -lglut \
-- -L/usr/X11R6/lib -lX11 -lXext -lXi -lXmu -lXt -lSM -lICE \
-- -lm
--
-+ -L%%X11BASE%%/lib -lX11 -lXext -lXi -lXmu -lXt -lSM -lICE \
-+ -lGL -lGLU -lglut \
-+ -lm
-
- SLIB = \
- AsplitA.c \
diff --git a/cad/calculix/files/patch-cgx_1.0+src+cgx.h b/cad/calculix/files/patch-cgx_1.0+src+cgx.h
deleted file mode 100644
index 83458f0261f8..000000000000
--- a/cad/calculix/files/patch-cgx_1.0+src+cgx.h
+++ /dev/null
@@ -1,21 +0,0 @@
---- cgx_1.0/src/cgx.h.orig Mon Apr 7 14:28:01 2003
-+++ cgx_1.0/src/cgx.h Thu May 8 13:25:32 2003
-@@ -46,14 +46,14 @@
- #define MILLISECONDS_PER_PERIOD 1200
-
- /* default location of the help files, please insert the actual one */
--#define HELPFILE {"/usr/local/CalculiX/cgx_1.0/doc/cgx/cgx.html",\
-- "/usr/local/CalculiX/ccx_1.0/doc/ccx/ccx.html"}
-+#define HELPFILE {"%%DOCSDIR%%/cgx/cgx.html",\
-+ "%%DOCSDIR%%/ccx/ccx.html"}
-
- /* html browser, change if necessary */
--#define BROWSER {"netscape"}
-+#define BROWSER {"mozilla"}
-
- /* postscript viewer, change if necessary */
--#define PSVIEWER {"ghostview"}
-+#define PSVIEWER {"gv"}
-
- /* more parameters, better do not change them! */
- #define MINVALUE -1.e9
diff --git a/cad/calculix/files/patch-cgx_1.0+src+readccx.c b/cad/calculix/files/patch-cgx_1.0+src+readccx.c
deleted file mode 100644
index 883dfbd5b613..000000000000
--- a/cad/calculix/files/patch-cgx_1.0+src+readccx.c
+++ /dev/null
@@ -1,127 +0,0 @@
---- cgx_1.0/src/readccx.c.org Wed Apr 9 00:32:46 2003
-+++ cgx_1.0/src/readccx.c Sun Jul 27 15:24:28 2003
-@@ -357,7 +357,7 @@
- /* delete blanks */
- n=0; for(j=0;j<strlen(dat[i]); j++) if(dat[i][j]!=' ') { buffer[n]=dat[i][j]; n++; }
- buffer[n]=(unsigned char)NULL;
-- for(j=0;j<strlen(buffer); j++) dat[i][j]=_toupper(buffer[j]);
-+ for(j=0;j<strlen(buffer); j++) dat[i][j]=toupper(buffer[j]);
- if(compare(dat[i],"NAME=",5)==5) { strcpy(set,&buffer[5]); }
- }
- if(printFlag) printf("*SURFACE DEFINITION: %s\n",set);
-@@ -479,7 +479,7 @@
-
-
- /* check if it is a node section */
-- for(j=0;j<strlen(rec_str); j++) { if(rec_str[j]==',') break; rec_str[j]=_toupper(rec_str[j]);}
-+ for(j=0;j<strlen(rec_str); j++) { if(rec_str[j]==',') break; rec_str[j]=toupper(rec_str[j]);}
- if((compare(rec_str,"*NODE PRINT",11)==11)||
- (compare(rec_str,"*NODE FILE",10)==10))
- {
-@@ -500,7 +500,7 @@
- /* delete blanks */
- n=0; for(j=0;j<strlen(dat[i]); j++) if(dat[i][j]!=' ') { buffer[n]=dat[i][j]; n++; }
- buffer[n]=(unsigned char)NULL;
-- for(j=0;j<strlen(buffer); j++) dat[i][j]=_toupper(buffer[j]);
-+ for(j=0;j<strlen(buffer); j++) dat[i][j]=toupper(buffer[j]);
- if(compare(dat[i],"NSET=",5)==5) { setFlag=1; strcpy(set,&buffer[5]); }
- }
- if(printFlag) printf("*NODE: NSET=%s\n", set);
-@@ -815,7 +815,7 @@
- /* delete blanks */
- n=0; for(j=0;j<strlen(dat[i]); j++) if(dat[i][j]!=' ') { buffer[n]=dat[i][j]; n++; }
- buffer[n]=(unsigned char)NULL;
-- for(j=0;j<strlen(buffer); j++) dat[i][j]=_toupper(buffer[j]);
-+ for(j=0;j<strlen(buffer); j++) dat[i][j]=toupper(buffer[j]);
- if(compare(dat[i],"TYPE=",5)==5) strcpy(elemtyp,&buffer[5]);
- if(compare(dat[i],"ELSET=",6)==6) { strcpy(set,&buffer[6]); setFlag=1; }
- }
-@@ -977,7 +977,7 @@
- /* delete blanks */
- n=0; for(j=0;j<strlen(dat[i]); j++) if(dat[i][j]!=' ') { buffer[n]=dat[i][j]; n++; }
- buffer[n]=(unsigned char)NULL;
-- for(j=0;j<strlen(buffer); j++) dat[i][j]=_toupper(buffer[j]);
-+ for(j=0;j<strlen(buffer); j++) dat[i][j]=toupper(buffer[j]);
- if(compare(dat[i],"NAME=",5)==5) strcpy(mname,&buffer[5]);
- }
- if(printFlag) printf("*MATERIAL:%s\n", mname);
-@@ -1021,7 +1021,7 @@
- /* delete blanks */
- n=0; for(j=0;j<strlen(dat[i]); j++) if(dat[i][j]!=' ') { buffer[n]=dat[i][j]; n++; }
- buffer[n]=(unsigned char)NULL;
-- for(j=0;j<strlen(buffer); j++) dat[i][j]=_toupper(buffer[j]);
-+ for(j=0;j<strlen(buffer); j++) dat[i][j]=toupper(buffer[j]);
- if(compare(dat[i],"TYPE=",5)==5) strcpy(type,&buffer[5]);
- }
- if(printFlag) printf("*ELASTIC: TYPE:%s\n", type);
-@@ -1073,7 +1073,7 @@
- /* delete blanks */
- n=0; for(j=0;j<strlen(dat[i]); j++) if(dat[i][j]!=' ') { buffer[n]=dat[i][j]; n++; }
- buffer[n]=(unsigned char)NULL;
-- for(j=0;j<strlen(buffer); j++) dat[i][j]=_toupper(buffer[j]);
-+ for(j=0;j<strlen(buffer); j++) dat[i][j]=toupper(buffer[j]);
- if(compare(dat[i],"TYPE=",5)==5) strcpy(type,&buffer[5]);
- }
- if(printFlag) printf("*EXPANSION:TYPE:%s\n", type);
-@@ -1480,7 +1480,7 @@
- /* delete blanks */
- n=0; for(j=0;j<strlen(dat[i]); j++) if(dat[i][j]!=' ') { buffer[n]=dat[i][j]; n++; }
- buffer[n]=(unsigned char)NULL;
-- for(j=0;j<strlen(buffer); j++) dat[i][j]=_toupper(buffer[j]);
-+ for(j=0;j<strlen(buffer); j++) dat[i][j]=toupper(buffer[j]);
- if(compare(dat[i],"ELSET=",6)==6) strcpy(set,&buffer[6]);
- if(compare(dat[i],"GENERATE",5)==5) generate=1;
- }
-@@ -1537,7 +1537,7 @@
- /* delete blanks */
- n=0; for(j=0;j<strlen(dat[i]); j++) if(dat[i][j]!=' ') { buffer[n]=dat[i][j]; n++; }
- buffer[n]=(unsigned char)NULL;
-- for(j=0;j<strlen(buffer); j++) dat[i][j]=_toupper(buffer[j]);
-+ for(j=0;j<strlen(buffer); j++) dat[i][j]=toupper(buffer[j]);
- if(compare(dat[i],"NSET=",5)==5) strcpy(set,&buffer[5]);
- if(compare(dat[i],"GENERATE",5)==5) generate=1;
- }
-@@ -1605,7 +1605,7 @@
- /* delete blanks */
- n=0; for(j=0;j<strlen(dat[i]); j++) if(dat[i][j]!=' ') { buffer[n]=dat[i][j]; n++; }
- buffer[n]=(unsigned char)NULL;
-- for(j=0;j<strlen(buffer); j++) dat[i][j]=_toupper(buffer[j]);
-+ for(j=0;j<strlen(buffer); j++) dat[i][j]=toupper(buffer[j]);
- if(compare(dat[i],"ELSET=",6)==6) strcpy(elset,&buffer[6]);
- if(compare(dat[i],"MATERIAL=",9)==9) strcpy(material,&buffer[9]);
- if((compare(buffer,"NODAL",5)==5)||
-@@ -1672,7 +1672,7 @@
- /* delete blanks */
- n=0; for(j=0;j<strlen(dat[i]); j++) if(dat[i][j]!=' ') { buffer[n]=dat[i][j]; n++; }
- buffer[n]=(unsigned char)NULL;
-- for(j=0;j<strlen(buffer); j++) dat[i][j]=_toupper(buffer[j]);
-+ for(j=0;j<strlen(buffer); j++) dat[i][j]=toupper(buffer[j]);
- if(compare(dat[i],"ELSET=",6)==6) strcpy(elset,&buffer[6]);
- if(compare(dat[i],"MATERIAL=",9)==9) strcpy(material,&buffer[9]);
- if((compare(buffer,"COMPOS",5)==5)||
-@@ -1726,14 +1726,14 @@
- /* delete blanks */
- n=0; for(j=0;j<strlen(dat[i]); j++) if(dat[i][j]!=' ') { buffer[n]=dat[i][j]; n++; }
- buffer[n]=(unsigned char)NULL;
-- for(j=0;j<strlen(buffer); j++) dat[i][j]=_toupper(buffer[j]);
-+ for(j=0;j<strlen(buffer); j++) dat[i][j]=toupper(buffer[j]);
- if(compare(dat[i],"TYPE=",5)==5)
- {
- strcpy(dat[i],&buffer[5]);
- /* delete blanks */
- n=0; for(j=0;j<strlen(dat[i]); j++) if(dat[i][j]!=' ') { buffer[n]=dat[i][j]; n++; }
- buffer[n]=(unsigned char)NULL;
-- for(j=0;j<strlen(buffer); j++) dat[i][j]=_toupper(buffer[j]);
-+ for(j=0;j<strlen(buffer); j++) dat[i][j]=toupper(buffer[j]);
- if(compare(dat[i],"TEMPERATURE",6)==6)
- {
- if(printFlag) printf("*INITIAL CONDITIONS: TYPE:%s \n", buffer);
-@@ -1914,7 +1914,7 @@
- args=crecord(rec_str, dat);
-
- /* get the arguments of the string */
-- i=0; while(dat[0][i]!=(unsigned char)NULL) { dat[0][i]=_toupper(dat[0][i]); i++; }
-+ i=0; while(dat[0][i]!=(unsigned char)NULL) { dat[0][i]=toupper(dat[0][i]); i++; }
-
- /* get the nodes */
- if (compare(dat[0], "*NODE",5)==5) { length=getNodes(rec_str); goto checknextstr; }
diff --git a/cad/calculix/files/patch-cgx_VER+src+Makefile b/cad/calculix/files/patch-cgx_VER+src+Makefile
new file mode 100644
index 000000000000..18ab3835c7df
--- /dev/null
+++ b/cad/calculix/files/patch-cgx_VER+src+Makefile
@@ -0,0 +1,29 @@
+--- cgx_1.1/src/Makefile.orig Tue Aug 5 13:46:07 2003
++++ cgx_1.1/src/Makefile Thu Aug 7 15:52:48 2003
+@@ -1,12 +1,10 @@
+-CFLAGS = -O2 -Wall \
+- -I./ \
+- -I/usr/include \
+- -I/usr/include/GL \
+- -I/usr/X11R6/include
++CFLAGS += -I./ \
++ -I%%X11BASE%%/include/GL \
++ -I%%X11BASE%%/include
+
+ LFLAGS = \
+- -L/usr/lib -lGL -lGLU -lglut \
+- -L/usr/X11R6/lib -lpthread -lX11 -lXext -lXi -lXmu -lXt -lSM -lICE \
++ -L%%X11BASE%%/lib -lGL -lGLU -lglut \
++ -lX11 -lXext -lXi -lXmu -lXt -lSM -lICE \
+ -lm
+
+ # -lpthread is needed if mesaGL is using threading, otherwhise it is not needed
+@@ -114,7 +112,7 @@
+ OLIB = $(SLIB:.c=.o)
+
+ cgx: $(OLIB)
+- g++ $(OLIB) $(CFLAGS) $(LFLAGS) -o $@
++ $(CXX) $(OLIB) $(CXXFLAGS) $(LFLAGS) -o $@
+
+
+
diff --git a/cad/calculix/files/patch-cgx_VER+src+cgx.h b/cad/calculix/files/patch-cgx_VER+src+cgx.h
new file mode 100644
index 000000000000..db8f42863363
--- /dev/null
+++ b/cad/calculix/files/patch-cgx_VER+src+cgx.h
@@ -0,0 +1,13 @@
+--- cgx_1.1/src/cgx.h.orig Tue Aug 5 10:08:37 2003
++++ cgx_1.1/src/cgx.h Thu Aug 7 00:37:38 2003
+@@ -59,8 +59,8 @@
+ #define MILLISECONDS_PER_PERIOD 1200
+
+ /* default location of the help files, please insert the actual one */
+-#define HELPFILE {"/usr/local/CalculiX/cgx_1.1/doc/cgx/cgx.html",\
+- "/usr/local/CalculiX/ccx_1.1/doc/ccx/ccx.html"}
++#define HELPFILE {"%%DOCSDIR%%/cgx/cgx.html",\
++ "%%DOCSDIR%%/ccx/ccx.html"}
+
+ /* html browser, change if necessary */
+ #define BROWSER {"netscape"}
diff --git a/cad/calculix/files/patch-cgx_VER+src+cgxToCdsm.cpp b/cad/calculix/files/patch-cgx_VER+src+cgxToCdsm.cpp
new file mode 100644
index 000000000000..4d8c78b0178c
--- /dev/null
+++ b/cad/calculix/files/patch-cgx_VER+src+cgxToCdsm.cpp
@@ -0,0 +1,11 @@
+--- cgx_1.1/src/cgxToCdsm.cpp.orig Thu Aug 7 15:39:06 2003
++++ cgx_1.1/src/cgxToCdsm.cpp Thu Aug 7 15:42:01 2003
+@@ -28,7 +28,7 @@
+ #include "knotVect.h"
+ #include "nurbsBase.h"
+ #include "ptrList.h"
+-#include "iostream.h"
++#include "iostream"
+
+ sLocn* amb = 0; // Ambiguous points.
+ int ambSize;
diff --git a/cad/calculix/files/patch-cgx_VER+src+ctrlPoint.cpp b/cad/calculix/files/patch-cgx_VER+src+ctrlPoint.cpp
new file mode 100644
index 000000000000..6d8e7276f7a9
--- /dev/null
+++ b/cad/calculix/files/patch-cgx_VER+src+ctrlPoint.cpp
@@ -0,0 +1,12 @@
+--- cgx_1.1/src/ctrlPoint.cpp.orig Mon Aug 4 15:25:08 2003
++++ cgx_1.1/src/ctrlPoint.cpp Thu Aug 7 16:12:47 2003
+@@ -18,7 +18,8 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ */
+
+-#include <iostream.h>
++#include <iostream>
++using std::cout;
+ #include <math.h>
+
+ #include "ctrlPoint.h"
diff --git a/cad/calculix/files/patch-cgx_VER+src+knotVect.cpp b/cad/calculix/files/patch-cgx_VER+src+knotVect.cpp
new file mode 100644
index 000000000000..467b052ea526
--- /dev/null
+++ b/cad/calculix/files/patch-cgx_VER+src+knotVect.cpp
@@ -0,0 +1,11 @@
+--- cgx_1.1/src/knotVect.cpp.orig Thu Aug 7 15:40:23 2003
++++ cgx_1.1/src/knotVect.cpp Thu Aug 7 15:47:46 2003
+@@ -19,7 +19,7 @@
+ */
+
+ #include "knotVect.h"
+-#include <iostream.h>
++#include <iostream>
+
+ knotVector::knotVector ( knot* knotArrayToCopy, unsigned size, unsigned knotVectType )
+ {
diff --git a/cad/calculix/files/patch-cgx_VER+src+nurbsBase.cpp b/cad/calculix/files/patch-cgx_VER+src+nurbsBase.cpp
new file mode 100644
index 000000000000..0a671ac54ebb
--- /dev/null
+++ b/cad/calculix/files/patch-cgx_VER+src+nurbsBase.cpp
@@ -0,0 +1,11 @@
+--- cgx_1.1/src/nurbsBase.cpp.orig Mon Aug 4 15:25:08 2003
++++ cgx_1.1/src/nurbsBase.cpp Thu Aug 7 17:12:46 2003
+@@ -27,7 +27,7 @@
+ #include "ptrList.h"
+ #endif
+
+-#include <iostream.h>
++#include <iostream>
+ #include <math.h>
+ #include <stdio.h>
+
diff --git a/cad/calculix/files/patch-cgx_VER+src+nurbsBase.h b/cad/calculix/files/patch-cgx_VER+src+nurbsBase.h
new file mode 100644
index 000000000000..42f20eca4217
--- /dev/null
+++ b/cad/calculix/files/patch-cgx_VER+src+nurbsBase.h
@@ -0,0 +1,11 @@
+--- cgx_1.1/src/nurbsBase.h.orig Thu Aug 7 09:34:49 2003
++++ cgx_1.1/src/nurbsBase.h Thu Aug 7 09:35:13 2003
+@@ -27,7 +27,7 @@
+ #include "ctrlPoint.h"
+ #include "nurbs.h"
+
+-#include <iostream.h>
++#include <iostream>
+
+ //#define CDSM_COMMENT
+
diff --git a/cad/calculix/files/patch-cgx_VER+src+smeUndo.cpp b/cad/calculix/files/patch-cgx_VER+src+smeUndo.cpp
new file mode 100644
index 000000000000..042a77e43d43
--- /dev/null
+++ b/cad/calculix/files/patch-cgx_VER+src+smeUndo.cpp
@@ -0,0 +1,11 @@
+--- cgx_1.1/src/smeUndo.cpp.orig Thu Aug 7 15:41:36 2003
++++ cgx_1.1/src/smeUndo.cpp Thu Aug 7 15:50:42 2003
+@@ -23,7 +23,7 @@
+
+ #include "smeUndo.h"
+
+-#include <iostream.h>
++#include <iostream>
+
+ bool smeUndoItemBase::isOwner ( const char* ownerString )
+ {
diff --git a/cad/calculix/pkg-plist b/cad/calculix/pkg-plist
index a703c6f96337..0e99ed224cf0 100644
--- a/cad/calculix/pkg-plist
+++ b/cad/calculix/pkg-plist
@@ -1,6 +1,6 @@
bin/ccx
bin/cgx
-%%PORTDOCS%%%%DOCSDIR%%/ccx_1.0.ps.gz
+%%PORTDOCS%%%%DOCSDIR%%/ccx_1.1.ps.gz
%%PORTDOCS%%%%DOCSDIR%%/ccx/ccx.html
%%PORTDOCS%%%%DOCSDIR%%/ccx/index.html
%%PORTDOCS%%%%DOCSDIR%%/ccx/node1.html
@@ -189,6 +189,14 @@ bin/cgx
%%PORTDOCS%%%%DOCSDIR%%/ccx/node97.html
%%PORTDOCS%%%%DOCSDIR%%/ccx/node98.html
%%PORTDOCS%%%%DOCSDIR%%/ccx/node99.html
+%%PORTDOCS%%%%DOCSDIR%%/ccx/node187.html
+%%PORTDOCS%%%%DOCSDIR%%/ccx/node188.html
+%%PORTDOCS%%%%DOCSDIR%%/ccx/node189.html
+%%PORTDOCS%%%%DOCSDIR%%/ccx/node190.html
+%%PORTDOCS%%%%DOCSDIR%%/ccx/node191.html
+%%PORTDOCS%%%%DOCSDIR%%/ccx/node192.html
+%%PORTDOCS%%%%DOCSDIR%%/ccx/node193.html
+%%PORTDOCS%%%%DOCSDIR%%/ccx/node194.html
%%PORTDOCS%%%%DOCSDIR%%/ccx/img1.png
%%PORTDOCS%%%%DOCSDIR%%/ccx/img10.png
%%PORTDOCS%%%%DOCSDIR%%/ccx/img100.png
@@ -452,6 +460,83 @@ bin/cgx
%%PORTDOCS%%%%DOCSDIR%%/ccx/img97.png
%%PORTDOCS%%%%DOCSDIR%%/ccx/img98.png
%%PORTDOCS%%%%DOCSDIR%%/ccx/img99.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img264.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img265.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img266.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img267.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img268.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img269.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img270.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img271.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img272.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img273.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img274.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img275.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img276.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img277.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img278.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img279.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img280.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img281.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img282.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img283.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img284.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img285.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img286.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img287.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img288.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img289.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img290.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img291.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img292.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img293.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img294.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img295.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img296.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img297.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img298.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img299.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img300.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img301.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img302.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img303.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img304.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img305.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img306.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img307.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img308.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img309.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img310.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img311.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img312.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img313.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img314.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img315.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img316.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img317.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img318.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img319.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img320.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img321.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img322.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img323.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img324.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img325.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img326.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img327.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img328.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img329.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img330.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img331.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img332.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img333.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img334.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img335.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img336.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img337.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img338.png
+%%PORTDOCS%%%%DOCSDIR%%/ccx/img339.png
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/ccx
%%PORTDOCS%%%%DOCSDIR%%/cgx.ps.gz
%%PORTDOCS%%%%DOCSDIR%%/cgx/cgx.html
%%PORTDOCS%%%%DOCSDIR%%/cgx/node1.html
@@ -603,6 +688,7 @@ bin/cgx
%%PORTDOCS%%%%DOCSDIR%%/cgx/node147.html
%%PORTDOCS%%%%DOCSDIR%%/cgx/node148.html
%%PORTDOCS%%%%DOCSDIR%%/cgx/node149.html
+%%PORTDOCS%%%%DOCSDIR%%/cgx/node152.html
%%PORTDOCS%%%%DOCSDIR%%/cgx/images.tex
%%PORTDOCS%%%%DOCSDIR%%/cgx/images.aux
%%PORTDOCS%%%%DOCSDIR%%/cgx/images.log
@@ -632,8 +718,8 @@ bin/cgx
%%PORTDOCS%%%%DOCSDIR%%/cgx/img10.gif
%%PORTDOCS%%%%DOCSDIR%%/cgx/node151.html
%%PORTDOCS%%%%DOCSDIR%%/cgx/img19.gif
-@dirrm %%PORTDOCS%%%%DOCSDIR%%/ccx/
-@dirrm %%PORTDOCS%%%%DOCSDIR%%/cgx/
+%%PORTDOCS%%%%DOCSDIR%%/cgx/img20.gif
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/cgx
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/basic/cylinder.fbd
%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/basic/disc.fbd
@@ -647,6 +733,8 @@ bin/cgx
%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/compressor/ccx/lavfm_cyl.bou
%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/compressor/ccx/lavfm.msh
%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/compressor/ccx/cyc/lavfmcyc.inp
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/nurbs/halter.fbd
+%%WITH_EXAMPLES%%@dirrm %%EXAMPLESDIR%%/nurbs
%%WITH_EXAMPLES%%@dirrm %%EXAMPLESDIR%%/compressor/cgx
%%WITH_EXAMPLES%%@dirrm %%EXAMPLESDIR%%/compressor/ccx/cyc
%%WITH_EXAMPLES%%@dirrm %%EXAMPLESDIR%%/compressor/ccx
@@ -671,12 +759,18 @@ bin/cgx
%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/test/achtelp.inp
%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/test/aniso.dat.ref
%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/test/aniso.inp
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/test/anipla.dat.ref
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/test/anipla.inp
%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/test/axial.dat.ref
%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/test/axial.inp
%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/test/axiplane.dat.ref
%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/test/axiplane.inp
%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/test/beam.dat.ref
%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/test/beam.inp
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/test/beammrco.dat.ref
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/test/beammrco.inp
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/test/beamtor.dat.ref
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/test/beamtor.inp
%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/test/beam10p.dat.ref
%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/test/beam10p.inp
%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/test/beam20p.dat.ref