aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2012-07-07 15:15:38 +0000
committerThierry Thomas <thierry@FreeBSD.org>2012-07-07 15:15:38 +0000
commit08fd80756a42e8d19097dac00edd7b26ac226237 (patch)
tree737eed8c214365790693209a1ececd06e1c6fc96 /cad
parentb5c63593da2e8f13e0f798f28e471196a95dbc06 (diff)
downloadports-08fd80756a42e8d19097dac00edd7b26ac226237.tar.gz
ports-08fd80756a42e8d19097dac00edd7b26ac226237.zip
Upgrade to 2.6.0.
Approved by: stephen (maintainer)
Notes
Notes: svn path=/head/; revision=300602
Diffstat (limited to 'cad')
-rw-r--r--cad/gmsh/Makefile13
-rw-r--r--cad/gmsh/distinfo4
-rw-r--r--cad/gmsh/files/patch-CMakeLists.txt65
-rw-r--r--cad/gmsh/files/patch-Common::DefaultOptions.h11
-rw-r--r--cad/gmsh/files/patch-Geo_MZoneBoundary.h18
-rw-r--r--cad/gmsh/files/patch-Graphics_gl2png.cpp10
-rw-r--r--cad/gmsh/pkg-plist40
7 files changed, 78 insertions, 83 deletions
diff --git a/cad/gmsh/Makefile b/cad/gmsh/Makefile
index adefca84103b..634882053486 100644
--- a/cad/gmsh/Makefile
+++ b/cad/gmsh/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gmsh
-PORTVERSION= 2.5.0
-PORTREVISION= 2
+PORTVERSION= 2.6.0
CATEGORIES= cad
MASTER_SITES= http://www.geuz.org/gmsh/src/ \
http://glaros.dtc.umn.edu/gkhome/fetch/sw/metis/
@@ -20,6 +19,8 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= stephen@FreeBSD.org
COMMENT= An automatic 3D finite element mesh generator
+LICENSE= GPLv2
+
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
jpeg.11:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png \
@@ -92,14 +93,14 @@ CMAKE_ARGS+= -DENABLE_TAUCS=OFF
.endif
.if !defined(WITHOUT_MED)
-LIB_DEPENDS+= med.2:${PORTSDIR}/french/med
+LIB_DEPENDS+= med.4:${PORTSDIR}/french/med
CMAKE_ARGS+= -DENABLE_MED=ON
.else
CMAKE_ARGS+= -DENABLE_MED=OFF
.endif
.if !defined(WITHOUT_CGNS)
-LIB_DEPENDS+= cgns.0:${PORTSDIR}/science/cgnslib
+LIB_DEPENDS+= cgns.3:${PORTSDIR}/science/cgnslib
CMAKE_ARGS+= -DENABLE_CGNS=ON
.else
CMAKE_ARGS+= -DENABLE_CGNS=OFF
@@ -118,6 +119,10 @@ CMAKE_ARGS+= -DENABLE_OCC=OFF
CONFLICTS= gmsh-occ-2.*
.endif
+# TODO
+# Dependencies against PythonLibs, swig and petsc are found and registered if installed
+# => add knobs to handle them.
+
PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
diff --git a/cad/gmsh/distinfo b/cad/gmsh/distinfo
index a65b4c032831..bc10c97d33a8 100644
--- a/cad/gmsh/distinfo
+++ b/cad/gmsh/distinfo
@@ -1,4 +1,4 @@
-SHA256 (gmsh/gmsh-2.5.0-source.tgz) = db1d3b92e56a85be9ec1c020aa2c705ccf5b7f0d00fa0f29b50efc73b378debc
-SIZE (gmsh/gmsh-2.5.0-source.tgz) = 3642009
+SHA256 (gmsh/gmsh-2.6.0-source.tgz) = a69773cd00e735acd8ad6908a234115fe48c453431fe24efdc0a21699baf2e45
+SIZE (gmsh/gmsh-2.6.0-source.tgz) = 6172567
SHA256 (gmsh/manual.pdf) = 8a682ee7f02380f52d5efdde5f9f9d8e927a4f4eb29287a878c1016225568911
SIZE (gmsh/manual.pdf) = 206713
diff --git a/cad/gmsh/files/patch-CMakeLists.txt b/cad/gmsh/files/patch-CMakeLists.txt
index aa5568412b56..d93f6326b9da 100644
--- a/cad/gmsh/files/patch-CMakeLists.txt
+++ b/cad/gmsh/files/patch-CMakeLists.txt
@@ -1,48 +1,47 @@
---- CMakeLists.txt.orig 2010-10-15 13:35:00.000000000 +0000
-+++ CMakeLists.txt 2011-07-25 03:34:11.000000000 +0000
-@@ -53,6 +53,7 @@
- option(ENABLE_TAUCS "Enable Taucs linear algebra solver" ON)
- option(ENABLE_TETGEN "Enable Tetgen mesh generator" ON)
+--- CMakeLists.txt.orig 2012-03-03 00:03:38.000000000 +0100
++++ CMakeLists.txt 2012-03-03 16:05:27.000000000 +0100
+@@ -63,6 +63,7 @@
option(ENABLE_TETGEN_NEW "Enable experimental version of Tetgen" OFF)
+ option(ENABLE_WRAP_JAVA "Build Java wrappers" OFF)
+ option(ENABLE_WRAP_PYTHON "Build Python wrappers" ${DEFAULT})
+option(INSTALL_DOCS "Install the docs (FreeBSD only)" ON)
set(GMSH_MAJOR_VERSION 2)
set(GMSH_MINOR_VERSION 5)
-@@ -574,13 +575,17 @@
- endif(NOT HAVE_METIS)
- find_library(TAUCS_LIB taucs PATH_SUFFIXES lib)
- if(TAUCS_LIB)
-- find_path(TAUCS_INC "taucs.h" PATH_SUFFIXES src include taucs)
-- if(TAUCS_INC)
-- set_config_option(HAVE_TAUCS "Taucs")
-- add_definitions(-DTAUCS_CILK)
-- list(APPEND EXTERNAL_LIBRARIES ${TAUCS_LIB})
-- list(APPEND EXTERNAL_INCLUDES ${TAUCS_INC})
-- endif(TAUCS_INC)
-+ find_library(COMPAT_LIB compat)
-+ if (COMPAT_LIB)
-+ find_path(TAUCS_INC "taucs.h" PATH_SUFFIXES src include)
-+ if(TAUCS_INC)
-+ set(HAVE_TAUCS TRUE)
-+ list(APPEND CONFIG_OPTIONS "Taucs")
-+ list(APPEND EXTERNAL_LIBRARIES ${TAUCS_LIB})
-+ list(APPEND EXTERNAL_LIBRARIES ${COMPAT_LIB})
-+ list(APPEND EXTERNAL_INCLUDES ${TAUCS_INC})
-+ endif(TAUCS_INC)
-+ endif(COMPAT_LIB)
- endif(TAUCS_LIB)
- endif(ENABLE_TAUCS)
+@@ -671,13 +672,16 @@
+ endif(NOT HAVE_METIS)
+ find_library(TAUCS_LIB taucs PATH_SUFFIXES lib)
+ if(TAUCS_LIB)
+- find_path(TAUCS_INC "taucs.h" PATH_SUFFIXES src include taucs)
+- if(TAUCS_INC)
+- set_config_option(HAVE_TAUCS "Taucs")
+- add_definitions(-DTAUCS_CILK)
+- list(APPEND EXTERNAL_LIBRARIES ${TAUCS_LIB})
+- list(APPEND EXTERNAL_INCLUDES ${TAUCS_INC})
+- endif(TAUCS_INC)
++ find_library(COMPAT_LIB compat)
++ if (COMPAT_LIB)
++ find_path(TAUCS_INC "taucs.h" PATH_SUFFIXES src include taucs)
++ if(TAUCS_INC)
++ set_config_option(HAVE_TAUCS "Taucs")
++ add_definitions(-DTAUCS_CILK)
++ list(APPEND EXTERNAL_LIBRARIES ${TAUCS_LIB})
++ list(APPEND EXTERNAL_INCLUDES ${TAUCS_INC})
++ endif(TAUCS_INC)
++ endif(COMPAT_LIB)
+ endif(TAUCS_LIB)
+ endif(ENABLE_TAUCS)
-@@ -673,7 +678,7 @@
+@@ -819,7 +823,7 @@
list(LENGTH OCC_LIBS NUM_OCC_LIBS)
if(NUM_OCC_LIBS EQUAL NUM_OCC_LIBS_REQUIRED)
find_path(OCC_INC "BRep_Tool.hxx" PATHS ENV CASROOT PATH_SUFFIXES inc
-- include opencascade)
-+ include opencascade OpenCAS/ros/inc)
+- include include/oce opencascade)
++ include include/oce opencascade OpenCAS/ros/inc)
if(OCC_INC)
set_config_option(HAVE_OCC "OpenCascade")
list(APPEND EXTERNAL_LIBRARIES ${OCC_LIBS})
-@@ -969,11 +974,13 @@
+@@ -1117,11 +1121,13 @@
install(TARGETS gmsh DESTINATION ${GMSH_BIN} OPTIONAL)
install(TARGETS lib shared DESTINATION lib OPTIONAL)
install(FILES ${GMSH_API} DESTINATION include/gmsh)
diff --git a/cad/gmsh/files/patch-Common::DefaultOptions.h b/cad/gmsh/files/patch-Common::DefaultOptions.h
deleted file mode 100644
index daa3e54bf445..000000000000
--- a/cad/gmsh/files/patch-Common::DefaultOptions.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- Common/DefaultOptions.h.orig 2010-01-01 14:21:13.000000000 -0600
-+++ Common/DefaultOptions.h 2010-01-01 14:22:28.000000000 -0600
-@@ -70,7 +70,7 @@
- #elif defined(__APPLE__)
- "open -t %s" ,
- #else
-- "emacs '%s' &" ,
-+ "$EDITOR '%s' &" ,
- #endif
- "System command to launch a text editor" },
- { F|S, "TmpFileName" , opt_general_tmp_filename , ".gmsh-tmp" ,
diff --git a/cad/gmsh/files/patch-Geo_MZoneBoundary.h b/cad/gmsh/files/patch-Geo_MZoneBoundary.h
deleted file mode 100644
index 47b467ad8e5a..000000000000
--- a/cad/gmsh/files/patch-Geo_MZoneBoundary.h
+++ /dev/null
@@ -1,18 +0,0 @@
---- Geo/MZoneBoundary.h-orig 2010-10-15 13:35:00.000000000 +0000
-+++ Geo/MZoneBoundary.h 2011-07-25 03:22:05.000000000 +0000
-@@ -317,12 +317,12 @@
- {
- // NBN: using FaceT* so need to dealloc:
- int icount = 0;
-- GlobalBoVertexMap::iterator itEnd = globalBoVertMap.end();
-- for (GlobalBoVertexMap::iterator itBoV = globalBoVertMap.begin();
-+ typename GlobalBoVertexMap::iterator itEnd = globalBoVertMap.end();
-+ for (typename GlobalBoVertexMap::iterator itBoV = globalBoVertMap.begin();
- itBoV != itEnd; ++itBoV)
- {
- // ... clear the faces
-- typename GlobalVertexData<FaceT>& ref = itBoV->second;
-+ GlobalVertexData<FaceT>& ref = itBoV->second;
- size_t nf = ref.faces.size();
- for (int i=0; i<nf; ++i) {
- ++ icount;
diff --git a/cad/gmsh/files/patch-Graphics_gl2png.cpp b/cad/gmsh/files/patch-Graphics_gl2png.cpp
deleted file mode 100644
index 5cce14f1189b..000000000000
--- a/cad/gmsh/files/patch-Graphics_gl2png.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- Graphics/gl2png.cpp.orig 2010-10-15 15:35:00.000000000 +0200
-+++ Graphics/gl2png.cpp 2012-05-09 13:23:42.000000000 +0200
-@@ -16,6 +16,7 @@
- #else
-
- #include <png.h>
-+#include <zlib.h>
-
- #ifndef png_jmpbuf
- # define png_jmpbuf(png_ptr) ((png_ptr)->jmpbuf)
diff --git a/cad/gmsh/pkg-plist b/cad/gmsh/pkg-plist
index e95397549092..4edcc98e1bfb 100644
--- a/cad/gmsh/pkg-plist
+++ b/cad/gmsh/pkg-plist
@@ -2,10 +2,12 @@ bin/gmsh
%%STATIC_LIB%%lib/libGmsh.a
%%SHARED_LIB%%lib/libGmsh.so
%%SHARED_LIB%%lib/libGmsh.so.0
+include/gmsh/CGNSOptions.h
include/gmsh/Cell.h
include/gmsh/CellComplex.h
+include/gmsh/Chain.h
include/gmsh/ChainComplex.h
-include/gmsh/DILevelset.h
+include/gmsh/Context.h
include/gmsh/GEdge.h
include/gmsh/GEdgeCompound.h
include/gmsh/GEdgeLoop.h
@@ -14,20 +16,24 @@ include/gmsh/GFace.h
include/gmsh/GFaceCompound.h
include/gmsh/GModel.h
include/gmsh/GPoint.h
+include/gmsh/GRbf.h
include/gmsh/GRegion.h
include/gmsh/GRegionCompound.h
include/gmsh/GVertex.h
-include/gmsh/Gauss.h
+include/gmsh/GaussIntegration.h
include/gmsh/Gmsh.h
include/gmsh/GmshConfig.h
include/gmsh/GmshDefines.h
include/gmsh/GmshMessage.h
include/gmsh/GmshVersion.h
include/gmsh/Homology.h
+include/gmsh/Integration3D.h
include/gmsh/JacobianBasis.h
+include/gmsh/Levy3D.h
include/gmsh/MEdge.h
include/gmsh/MElement.h
include/gmsh/MElementCut.h
+include/gmsh/MElementOctree.h
include/gmsh/MFace.h
include/gmsh/MHexahedron.h
include/gmsh/MLine.h
@@ -38,10 +44,17 @@ include/gmsh/MQuadrangle.h
include/gmsh/MTetrahedron.h
include/gmsh/MTriangle.h
include/gmsh/MVertex.h
+include/gmsh/MVertexBoundaryLayerData.h
include/gmsh/Numeric.h
+include/gmsh/Octree.h
+include/gmsh/OctreeInternals.h
+include/gmsh/OctreePost.h
+include/gmsh/OptHOM.h
+include/gmsh/OptHomMesh.h
include/gmsh/PView.h
include/gmsh/PViewData.h
include/gmsh/Pair.h
+include/gmsh/ParamCoord.h
include/gmsh/PluginManager.h
include/gmsh/Range.h
include/gmsh/SBoundingBox3d.h
@@ -51,8 +64,10 @@ include/gmsh/SPoint3.h
include/gmsh/STensor3.h
include/gmsh/SVector3.h
include/gmsh/VertexArray.h
+include/gmsh/Voronoi3D.h
include/gmsh/cartesian.h
include/gmsh/crossConfTerm.h
+include/gmsh/directions3D.h
include/gmsh/discreteEdge.h
include/gmsh/discreteFace.h
include/gmsh/discreteRegion.h
@@ -66,19 +81,28 @@ include/gmsh/fullMatrix.h
include/gmsh/gmp_blas.h
include/gmsh/gmp_matrix.h
include/gmsh/gmp_normal_form.h
+include/gmsh/gmshLevelset.h
include/gmsh/laplaceTerm.h
include/gmsh/linearSystem.h
include/gmsh/linearSystemCSR.h
include/gmsh/linearSystemFull.h
include/gmsh/linearSystemGMM.h
+include/gmsh/mathEvaluator.h
+include/gmsh/mathex.h
include/gmsh/meshGEdge.h
include/gmsh/meshGFace.h
include/gmsh/meshGFaceDelaunayInsertion.h
include/gmsh/meshGFaceOptimize.h
+include/gmsh/meshPartition.h
+include/gmsh/meshPartitionOptions.h
include/gmsh/mpz.h
include/gmsh/orthogonalTerm.h
+include/gmsh/partitionEdge.h
+include/gmsh/periodical.h
include/gmsh/polynomialBasis.h
+include/gmsh/simple3D.h
include/gmsh/simpleFunction.h
+include/gmsh/sparsityPattern.h
%%PORTDOCS%%%%DOCSDIR%%/CREDITS.txt
%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
%%PORTDOCS%%%%DOCSDIR%%/README.txt
@@ -93,6 +117,7 @@ include/gmsh/simpleFunction.h
%%PORTDOCS%%%%DOCSDIR%%/demos/fields.geo
%%PORTDOCS%%%%DOCSDIR%%/demos/filter.geo
%%PORTDOCS%%%%DOCSDIR%%/demos/hex.geo
+%%PORTDOCS%%%%DOCSDIR%%/demos/homology.geo
%%PORTDOCS%%%%DOCSDIR%%/demos/isosurf.script
%%PORTDOCS%%%%DOCSDIR%%/demos/lowmem-anim.geo
%%PORTDOCS%%%%DOCSDIR%%/demos/machine.geo
@@ -120,6 +145,12 @@ include/gmsh/simpleFunction.h
%%PORTDOCS%%%%DOCSDIR%%/demos/transfinite.geo
%%PORTDOCS%%%%DOCSDIR%%/tutorial/bgmesh.pos
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t1.geo
+%%PORTDOCS%%%%DOCSDIR%%/tutorial/t10.geo
+%%PORTDOCS%%%%DOCSDIR%%/tutorial/t11.geo
+%%PORTDOCS%%%%DOCSDIR%%/tutorial/t12.geo
+%%PORTDOCS%%%%DOCSDIR%%/tutorial/t13.geo
+%%PORTDOCS%%%%DOCSDIR%%/tutorial/t13_data.msh
+%%PORTDOCS%%%%DOCSDIR%%/tutorial/t14.geo
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t2.geo
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t3.geo
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t4.geo
@@ -129,15 +160,14 @@ include/gmsh/simpleFunction.h
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t8.geo
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t8.par
%%PORTDOCS%%%%DOCSDIR%%/tutorial/t9.geo
-%%PORTDOCS%%%%DOCSDIR%%/tutorial/t10.geo
%%PORTDOCS%%%%DOCSDIR%%/tutorial/view1.pos
%%PORTDOCS%%%%DOCSDIR%%/tutorial/view2.pos
%%PORTDOCS%%%%DOCSDIR%%/tutorial/view3.pos
%%PORTDOCS%%%%DOCSDIR%%/tutorial/view4.pos
%%PORTDOCS%%%%DOCSDIR%%/tutorial/view5.msh
%%METIS%%%%DOCSDIR%%/metis/manual.pdf
-@dirrm include/gmsh
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/demos
%%PORTDOCS%%@dirrm %%DOCSDIR%%/tutorial
%%METIS%%@dirrm %%DOCSDIR%%/metis
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/demos
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/gmsh