aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-10-27 19:02:54 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-10-27 19:02:54 +0000
commit528bc62a9ea806061c022e23a0e5ddeb09ef3fb8 (patch)
tree04189e53d15cf999afe0f1c7831518970a66bb3e /cad
parent7a83123e230c1e2d39d6a5769f149d8967016be9 (diff)
downloadports-528bc62a9ea806061c022e23a0e5ddeb09ef3fb8.tar.gz
ports-528bc62a9ea806061c022e23a0e5ddeb09ef3fb8.zip
- Update MASTER_SITES and WWW: line
- Add LICENSE - Add MAKE_JOBS_SAFE - Fix build with clang - Respects DOCS PR: ports/172219 Submitted by: KATO Tsuguru <tkato432@yahoo.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=306521
Diffstat (limited to 'cad')
-rw-r--r--cad/admesh/Makefile27
-rw-r--r--cad/admesh/files/patch-admesh.c11
-rw-r--r--cad/admesh/pkg-descr2
3 files changed, 27 insertions, 13 deletions
diff --git a/cad/admesh/Makefile b/cad/admesh/Makefile
index 0806515f6326..0eead78ae6e3 100644
--- a/cad/admesh/Makefile
+++ b/cad/admesh/Makefile
@@ -1,32 +1,35 @@
-# New ports collection makefile for: admesh
-# Date created: 25 June 2003
-# Whom: Pedro F. Giffuni <giffunip@asme.org>
-#
+# Created by: Pedro F. Giffuni <giffunip@asme.org>
# $FreeBSD$
-#
PORTNAME= admesh
PORTVERSION= 0.95
PORTREVISION= 1
CATEGORIES= cad
-MASTER_SITES= http://www.varlog.com/
+MASTER_SITES= http://launchpadlibrarian.net/67068999/ \
+ http://www.sourcefiles.org/Scientific/Numerical_Analysis/
MAINTAINER= ports@FreeBSD.org
COMMENT= Program for processing STL triangulated solid meshes
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2012-10-20
+LICENSE= GPLv2 # (or later)
+
+OPTIONS_DEFINE= DOCS
-FETCH_ARGS?= -Fpr
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
-PLIST_FILES= bin/admesh
PORTDOCS= admesh.doc
+PLIST_FILES= bin/admesh
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/admesh ${PREFIX}/bin/
-.ifndef NOPORTDOCS
- ${MKDIR} ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/ADMESH.DOC ${DOCSDIR}/admesh.doc
.endif
diff --git a/cad/admesh/files/patch-admesh.c b/cad/admesh/files/patch-admesh.c
new file mode 100644
index 000000000000..2dba43b3fba3
--- /dev/null
+++ b/cad/admesh/files/patch-admesh.c
@@ -0,0 +1,11 @@
+--- ./admesh.c.orig 1996-07-27 00:07:15.000000000 +0200
++++ ./admesh.c 2012-10-27 21:01:18.374482756 +0200
+@@ -27,7 +27,7 @@
+
+ static void usage(int status, char *program_name);
+
+-void
++int
+ main(int argc, char **argv)
+ {
+ stl_file stl_in;
diff --git a/cad/admesh/pkg-descr b/cad/admesh/pkg-descr
index 48848a69616f..7603c257903f 100644
--- a/cad/admesh/pkg-descr
+++ b/cad/admesh/pkg-descr
@@ -20,4 +20,4 @@ Features
* Write a DXF file
* Calculate the volume of a part
-WWW: http://www.varlog.com
+WWW: https://launchpad.net/admesh