aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2011-07-28 21:58:16 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2011-07-28 21:58:16 +0000
commitd944917e18f9336f22a9ec9ca1ba0a21806aa393 (patch)
treebe58795dca95fae6087c39965a0a89eae6ed2190 /cad
parent5a296f326acd9886e24bcbc1de2d12b1a0380c6e (diff)
downloadports-d944917e18f9336f22a9ec9ca1ba0a21806aa393.tar.gz
ports-d944917e18f9336f22a9ec9ca1ba0a21806aa393.zip
Fix build under clang [1]
Add LICENSE Fix usage of PORTDOCS in plist, no bump required PR: ports/159173 Submitted by: Pedro Giffuni <giffunip@tutopia.com> [1] Approved by: tabthorpe (mentor)
Notes
Notes: svn path=/head/; revision=278502
Diffstat (limited to 'cad')
-rw-r--r--cad/spice/Makefile4
-rw-r--r--cad/spice/files/patch-src_lib_fte_device_c25
-rw-r--r--cad/spice/files/patch-src_lib_fte_x11_c62
-rw-r--r--cad/spice/files/patch-src_lib_mfb_mfbgnc_c10
-rw-r--r--cad/spice/pkg-plist42
5 files changed, 109 insertions, 34 deletions
diff --git a/cad/spice/Makefile b/cad/spice/Makefile
index 3e3dc58144eb..594721aaa885 100644
--- a/cad/spice/Makefile
+++ b/cad/spice/Makefile
@@ -18,6 +18,8 @@ EXTRACT_ONLY= spice3f5${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= A general-purpose circuit simulation program
+LICENSE= BSD
+
WRKSRC= ${WRKDIR}/${PORTNAME}3f5
MAN1= sconvert.1 nutmeg.1 spice.1
MAN3= mfb.3
@@ -52,8 +54,8 @@ post-install:
${MKDIR} ${DOCSDIR}
${CAT} ${DISTDIR}/${DIST_SUBDIR}/*.ps > ${DOCSDIR}/spice3f3.ps
${GZIP_CMD} ${DOCSDIR}/*.ps
+.endif
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/*.cir ${EXAMPLESDIR}
-.endif
.include <bsd.port.post.mk>
diff --git a/cad/spice/files/patch-src_lib_fte_device_c b/cad/spice/files/patch-src_lib_fte_device_c
index 85e100d92633..ed6414a8835e 100644
--- a/cad/spice/files/patch-src_lib_fte_device_c
+++ b/cad/spice/files/patch-src_lib_fte_device_c
@@ -1,6 +1,23 @@
---- src/lib/fte/device.c.orig Thu Jul 29 19:09:59 1993
-+++ src/lib/fte/device.c Thu Sep 30 13:16:51 2004
-@@ -619,7 +619,7 @@
+--- src/lib/fte/device.c.orig 1993-07-30 02:09:59.000000000 +0000
++++ src/lib/fte/device.c 2011-07-26 23:17:58.000000000 +0000
+@@ -14,6 +14,8 @@
+ #include "ftedefs.h"
+ #include "dgen.h"
+
++void com_alter_common(wordlist *wl, int do_model);
++
+ static wordlist *devexpand();
+
+ /*
+@@ -576,6 +578,7 @@
+ com_alter_common(wl, 1);
+ }
+
++void
+ com_alter_common(wl, do_model)
+ wordlist *wl;
+ int do_model;
+@@ -619,7 +622,7 @@
n2 = names;
}
@@ -9,7 +26,7 @@
fprintf(cp_err, "alter: don't understand \"%s\"\n", names->pn_name);
fprintf(cp_err, "usage: alter dev param = expression\n");
fprintf(cp_err, " or alter @dev[param] = expression\n");
-@@ -661,7 +661,9 @@
+@@ -661,7 +664,9 @@
}
dv = ft_evaluate(n2->pn_right);
diff --git a/cad/spice/files/patch-src_lib_fte_x11_c b/cad/spice/files/patch-src_lib_fte_x11_c
index 05875dc0c429..692480e17f95 100644
--- a/cad/spice/files/patch-src_lib_fte_x11_c
+++ b/cad/spice/files/patch-src_lib_fte_x11_c
@@ -1,6 +1,17 @@
---- src/lib/fte/x11.c.orig Wed Apr 14 21:44:56 1993
-+++ src/lib/fte/x11.c Sun Aug 15 19:06:31 2004
-@@ -120,7 +120,10 @@
+--- src/lib/fte/x11.c.orig 1993-04-14 19:44:56.000000000 +0000
++++ src/lib/fte/x11.c 2011-07-26 23:16:48.000000000 +0000
+@@ -36,6 +36,10 @@
+ extern int _Xdebug;
+ # endif
+
++void initlinestyles(void);
++void initcolors(GRAPH *graph);
++void slopelocation(GRAPH *graph, int x0, int y0);
++
+ /* forward declarations */
+ extern void handlebuttonev(), handlekeypressed(), killwin(), hardcopy(),
+ redraw(), resize();
+@@ -120,7 +124,10 @@
/* "invert" works better than "xor" for B&W */
/* xor gc should be a function of the pixels that are written on */
@@ -12,25 +23,52 @@
gcvalues.line_width = 1;
gcvalues.foreground = 1;
gcvalues.background = 0;
-@@ -302,7 +305,7 @@
+@@ -152,7 +159,7 @@
+ {
+ XGetErrorText(display, errorev->error_code, ErrorMessage, 1024);
+ externalerror(ErrorMessage);
+- return;
++ return (0);
+ }
+
+ /* Recover from bad NewViewPort call. */
+@@ -302,7 +309,8 @@
return (0);
}
-static
+/* PN static */
++void
initlinestyles()
{
-@@ -318,7 +321,7 @@
+@@ -318,7 +326,8 @@
return;
}
-static
+/* PN static */
++void
initcolors(graph)
GRAPH *graph;
{
-@@ -805,8 +808,9 @@
+@@ -405,6 +414,7 @@
+ }
+
+ /*ARGSUSED*/
++void
+ X11_Arc(x0, y0, radius, theta1, theta2)
+ int x0, y0, radius;
+ double theta1, theta2;
+@@ -612,6 +622,7 @@
+ }
+ # endif
+
++void
+ slopelocation(graph, x0, y0)
+ GRAPH *graph;
+ int x0, y0; /* initial position of mouse */
+@@ -805,8 +816,9 @@
/* Iplots are done asynchronously */
DEVDEP(graph).isopen = 0;
@@ -41,7 +79,15 @@
}
-@@ -942,7 +946,8 @@
+@@ -915,6 +927,7 @@
+ }
+ # endif
+
++void
+ X11_Input(request, response)
+ REQUEST *request;
+ RESPONSE *response;
+@@ -942,7 +955,8 @@
1 << ConnectionNumber(display);
/* block on ConnectionNumber and request->fp */
@@ -51,7 +97,7 @@
/* handle X events first */
if (readfds & (1 << ConnectionNumber(display))) {
-@@ -995,7 +1000,8 @@
+@@ -995,7 +1009,8 @@
}
diff --git a/cad/spice/files/patch-src_lib_mfb_mfbgnc_c b/cad/spice/files/patch-src_lib_mfb_mfbgnc_c
new file mode 100644
index 000000000000..06df88c56069
--- /dev/null
+++ b/cad/spice/files/patch-src_lib_mfb_mfbgnc_c
@@ -0,0 +1,10 @@
+--- src/lib/mfb/mfbgnc.c.orig 2011-07-24 22:09:03.000000000 +0000
++++ src/lib/mfb/mfbgnc.c 2011-07-24 22:12:08.000000000 +0000
+@@ -100,6 +100,7 @@
+ * all other characters are ``self-inserting''.
+ */
+
++void
+ MFBGenCode(PM)
+ char *PM;
+ {
diff --git a/cad/spice/pkg-plist b/cad/spice/pkg-plist
index 197b8ddbd8b0..b331e3759f35 100644
--- a/cad/spice/pkg-plist
+++ b/cad/spice/pkg-plist
@@ -14,25 +14,25 @@ bin/multidec
@dirrm %%DATADIR%%/scripts
@dirrm %%DATADIR%%
%%PORTDOCS%%%%DOCSDIR%%/spice3f3.ps.gz
-%%PORTDOCS%%%%EXAMPLESDIR%%/bjtnoise.cir
-%%PORTDOCS%%%%EXAMPLESDIR%%/bsim1tst.cir
-%%PORTDOCS%%%%EXAMPLESDIR%%/bsim2tst.cir
-%%PORTDOCS%%%%EXAMPLESDIR%%/diffpair.cir
-%%PORTDOCS%%%%EXAMPLESDIR%%/diodisto.cir
-%%PORTDOCS%%%%EXAMPLESDIR%%/ltra_1.cir
-%%PORTDOCS%%%%EXAMPLESDIR%%/ltra_2.cir
-%%PORTDOCS%%%%EXAMPLESDIR%%/ltra_3.cir
-%%PORTDOCS%%%%EXAMPLESDIR%%/mixdisto.cir
-%%PORTDOCS%%%%EXAMPLESDIR%%/mos6inv.cir
-%%PORTDOCS%%%%EXAMPLESDIR%%/mosamp2.cir
-%%PORTDOCS%%%%EXAMPLESDIR%%/mosmem.cir
-%%PORTDOCS%%%%EXAMPLESDIR%%/pz2.cir
-%%PORTDOCS%%%%EXAMPLESDIR%%/pzt.cir
-%%PORTDOCS%%%%EXAMPLESDIR%%/rc.cir
-%%PORTDOCS%%%%EXAMPLESDIR%%/rca3040.cir
-%%PORTDOCS%%%%EXAMPLESDIR%%/resnoise.cir
-%%PORTDOCS%%%%EXAMPLESDIR%%/rtlinv.cir
-%%PORTDOCS%%%%EXAMPLESDIR%%/schmitt.cir
-%%PORTDOCS%%%%EXAMPLESDIR%%/simplepz.cir
+%%EXAMPLESDIR%%/bjtnoise.cir
+%%EXAMPLESDIR%%/bsim1tst.cir
+%%EXAMPLESDIR%%/bsim2tst.cir
+%%EXAMPLESDIR%%/diffpair.cir
+%%EXAMPLESDIR%%/diodisto.cir
+%%EXAMPLESDIR%%/ltra_1.cir
+%%EXAMPLESDIR%%/ltra_2.cir
+%%EXAMPLESDIR%%/ltra_3.cir
+%%EXAMPLESDIR%%/mixdisto.cir
+%%EXAMPLESDIR%%/mos6inv.cir
+%%EXAMPLESDIR%%/mosamp2.cir
+%%EXAMPLESDIR%%/mosmem.cir
+%%EXAMPLESDIR%%/pz2.cir
+%%EXAMPLESDIR%%/pzt.cir
+%%EXAMPLESDIR%%/rc.cir
+%%EXAMPLESDIR%%/rca3040.cir
+%%EXAMPLESDIR%%/resnoise.cir
+%%EXAMPLESDIR%%/rtlinv.cir
+%%EXAMPLESDIR%%/schmitt.cir
+%%EXAMPLESDIR%%/simplepz.cir
+@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%