aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2010-12-04 07:34:27 +0000
committerAde Lovett <ade@FreeBSD.org>2010-12-04 07:34:27 +0000
commit4a8684e352ac6d7260613e6ad3743fabd00eaf7d (patch)
treec1022f7df000935302e4c7f143c5b049290dacc2 /cad
parent6029732777f019908166457c71136521713b91f7 (diff)
downloadports-4a8684e352ac6d7260613e6ad3743fabd00eaf7d.tar.gz
ports-4a8684e352ac6d7260613e6ad3743fabd00eaf7d.zip
Sync to new bsd.autotools.mk
Notes
Notes: svn path=/head/; revision=265663
Diffstat (limited to 'cad')
-rw-r--r--cad/brlcad/Makefile2
-rw-r--r--cad/freehdl/Makefile2
-rw-r--r--cad/gerbv/Makefile2
-rw-r--r--cad/gtkwave/Makefile2
-rw-r--r--cad/ngspice_rework/Makefile2
-rw-r--r--cad/pcb/Makefile2
-rw-r--r--cad/salome/Makefile.ext6
-rw-r--r--cad/tclspice/Makefile2
8 files changed, 10 insertions, 10 deletions
diff --git a/cad/brlcad/Makefile b/cad/brlcad/Makefile
index a33b5f307169..81892771037c 100644
--- a/cad/brlcad/Makefile
+++ b/cad/brlcad/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/tnt/jama_lu.h:${PORTSDIR}/math/jama \
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
rle.1:${PORTSDIR}/graphics/urt
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
USE_BZIP2= yes
USE_GL= gl
USE_XORG= x11 xt xi xproto xext inputproto
diff --git a/cad/freehdl/Makefile b/cad/freehdl/Makefile
index 7617381be596..4f2754d4870b 100644
--- a/cad/freehdl/Makefile
+++ b/cad/freehdl/Makefile
@@ -18,7 +18,7 @@ USE_LDCONFIG= yes
USE_PERL5= yes
USE_GNOME= gnomehack \
pkgconfig
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
HAS_CONFIGURE= yes
MAN1= freehdl-config.1 \
diff --git a/cad/gerbv/Makefile b/cad/gerbv/Makefile
index 5749d98f6778..ae0920517821 100644
--- a/cad/gerbv/Makefile
+++ b/cad/gerbv/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A Free Gerber Viewer
USE_GNOME= desktopfileutils gnomehack gtk20
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
diff --git a/cad/gtkwave/Makefile b/cad/gtkwave/Makefile
index 6ab7ebf566be..cef55f9550b3 100644
--- a/cad/gtkwave/Makefile
+++ b/cad/gtkwave/Makefile
@@ -19,7 +19,7 @@ COMMENT= Electronic Waveform Viewer
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
USE_GNOME= gtk12
GNU_CONFIGURE= yes
USE_LDCONFIG= ${PREFIX}/lib/gtkwave
diff --git a/cad/ngspice_rework/Makefile b/cad/ngspice_rework/Makefile
index 9cc36ebb9cdc..e06ea9c9342e 100644
--- a/cad/ngspice_rework/Makefile
+++ b/cad/ngspice_rework/Makefile
@@ -15,7 +15,7 @@ DISTNAME= ng-spice-rework-${PORTVERSION}
MAINTAINER= amakawa@jp.FreeBSD.org
COMMENT= A circuit simulator derived from spice3f5
-USE_AUTOTOOLS= autoconf:268
+USE_AUTOTOOLS= autoconf
USE_GMAKE= yes
#XSPICE doesn't build
diff --git a/cad/pcb/Makefile b/cad/pcb/Makefile
index 5f4c794f695c..aa486d118846 100644
--- a/cad/pcb/Makefile
+++ b/cad/pcb/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= m4>=1.4.11:${PORTSDIR}/devel/m4 \
BUILD_DEPENDS= ${RUN_DEPENDS}
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf:268
+USE_AUTOTOOLS= autoconf
USE_GMAKE= yes
USE_TK_RUN= 83
INSTALLS_ICONS= yes
diff --git a/cad/salome/Makefile.ext b/cad/salome/Makefile.ext
index 084024b90d36..29206e35f07b 100644
--- a/cad/salome/Makefile.ext
+++ b/cad/salome/Makefile.ext
@@ -94,13 +94,13 @@ RUN_DEPENDS+= ${RESOURCEDIR}/visu:${PORTSDIR}/cad/salome-visu \
#Dependency from other ports
###########################################################################
#Dependency from autotools
-USE_AUTOTOOLS= autoconf:268 automake:111 libtool:22 aclocal:111
+USE_AUTOTOOLS= autoconf automake libtool aclocal
.if ${SAL_MODULE} == "kernel"
ACLOCAL_ARGS= -I salome_adm/unix/config_files
.else
. if ${SAL_MODULE} == "yacs"
ACLOCAL_ARGS= -I adm/unix/config_files
- USE_AUTOTOOLS+= autoheader:268
+ USE_AUTOTOOLS+= autoheader
AUTOHEADER_ARGS= -I adm/unix/config_files
. else
ACLOCAL_ARGS= -I adm_local/unix/config_files -I ${LOCALBASE}/salome_adm/unix/config_files
@@ -336,7 +336,7 @@ run-autotools-autoheader:
echo "End of autoheader"
.endif
-patch-autotools:
+patch-autotools-libtool:
@(cd ${PATCH_WRKSRC}; ${LIBTOOLIZE} --force;)
pre-configure:
diff --git a/cad/tclspice/Makefile b/cad/tclspice/Makefile
index d893d5ecc121..c6f001463952 100644
--- a/cad/tclspice/Makefile
+++ b/cad/tclspice/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= bltwish:${PORTSDIR}/x11-toolkits/blt \
BROKEN= does not compile
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_AUTOTOOLS= aclocal:111 automake:111 autoconf:268 libtool:22
+USE_AUTOTOOLS= aclocal automake autoconf libtool
AUTOMAKE_ARGS= -c -a
USE_GMAKE= yes
ALL_TARGET= tcl