aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorTong LIU <nemoliu@FreeBSD.org>2010-01-18 05:04:20 +0000
committerTong LIU <nemoliu@FreeBSD.org>2010-01-18 05:04:20 +0000
commit693358cc83c1574eefa2158d753809b04d5ee843 (patch)
treeb072ffba3db8f18d1b9a26ece916dbbab01817cd /cad
parent93f7cb00335d35c8652d46741d293819ba062d70 (diff)
downloadports-693358cc83c1574eefa2158d753809b04d5ee843.tar.gz
ports-693358cc83c1574eefa2158d753809b04d5ee843.zip
- Fix build error on amd64.
Report by: QAT@ PR: ports/142926 Submitted by: Stephen Montgomery-Smith <stephen@missouri.edu> (maintainer)
Notes
Notes: svn path=/head/; revision=248070
Diffstat (limited to 'cad')
-rw-r--r--cad/gmsh/Makefile1
-rw-r--r--cad/gmsh/files/patch-CMakeLists.txt20
2 files changed, 19 insertions, 2 deletions
diff --git a/cad/gmsh/Makefile b/cad/gmsh/Makefile
index d32a3cf01522..18e1087cfb33 100644
--- a/cad/gmsh/Makefile
+++ b/cad/gmsh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gmsh
PORTVERSION= 2.4.2
+PORTREVISION= 1
CATEGORIES= cad
MASTER_SITES= http://www.geuz.org/gmsh/src/ \
http://glaros.dtc.umn.edu/gkhome/fetch/sw/metis/
diff --git a/cad/gmsh/files/patch-CMakeLists.txt b/cad/gmsh/files/patch-CMakeLists.txt
index af0b6454ebf7..2e0e6b18acc6 100644
--- a/cad/gmsh/files/patch-CMakeLists.txt
+++ b/cad/gmsh/files/patch-CMakeLists.txt
@@ -1,5 +1,5 @@
--- CMakeLists.txt.orig 2009-09-21 13:54:49.000000000 -0500
-+++ CMakeLists.txt 2010-01-02 16:31:27.000000000 -0600
++++ CMakeLists.txt 2010-01-17 21:14:51.000000000 -0600
@@ -41,6 +41,7 @@
option(ENABLE_TAUCS "Enable Taucs linear algebra solver" ON)
option(ENABLE_TETGEN "Enable Tetgen mesh generator" ON)
@@ -42,7 +42,23 @@
if(OCC_INC)
set(HAVE_OCC TRUE)
list(APPEND CONFIG_OPTIONS "OpenCascade")
-@@ -762,13 +767,15 @@
+@@ -654,15 +659,6 @@
+ if(HAVE_LAPACK AND LAPACK_FLAGS)
+ set_target_properties(shared PROPERTIES LINK_FLAGS ${LAPACK_FLAGS})
+ endif(HAVE_LAPACK AND LAPACK_FLAGS)
+-if(HAVE_FLTK)
+- target_link_libraries(shared ${FLTK_LIBRARIES} ${EXTERNAL_LIBRARIES}
+- ${OPENGL_LIBRARIES} ${LAPACK_LIBRARIES})
+-elseif(HAVE_OPENGL)
+- target_link_libraries(shared ${EXTERNAL_LIBRARIES} ${OPENGL_LIBRARIES}
+- ${LAPACK_LIBRARIES})
+-else(HAVE_FLTK)
+- target_link_libraries(shared ${EXTERNAL_LIBRARIES} ${LAPACK_LIBRARIES})
+-endif(HAVE_FLTK)
+
+ # binary targets
+ if(HAVE_FLTK)
+@@ -762,13 +758,15 @@
install(TARGETS gmsh DESTINATION ${GMSH_BIN} OPTIONAL)
install(TARGETS lib shared DESTINATION lib OPTIONAL)
install(FILES ${GMSH_API} DESTINATION include/gmsh)