aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-11-22 11:14:10 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-11-22 11:14:10 +0000
commit004a7c5ac21475f760354371ae4f8fca5e556acb (patch)
tree47b9539be8bb171263921a641d850025fee218cc /cad
parentbcfacab8772c0f3bf72412386eb13f58def6bef2 (diff)
downloadports-004a7c5ac21475f760354371ae4f8fca5e556acb.tar.gz
ports-004a7c5ac21475f760354371ae4f8fca5e556acb.zip
adjust linking and comments in dependent ports after the math/atlas update;
math/atlas-devel will be updated to use the same constructs at a later date PR: 162706 Approved by: miwi (portmgr) Feature safe: yes
Notes
Notes: svn path=/head/; revision=286242
Diffstat (limited to 'cad')
-rw-r--r--cad/calculix/Makefile4
-rw-r--r--cad/pdnmesh/Makefile4
-rw-r--r--cad/tochnog/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/cad/calculix/Makefile b/cad/calculix/Makefile
index 5df49fd6a295..3537b2d597d5 100644
--- a/cad/calculix/Makefile
+++ b/cad/calculix/Makefile
@@ -54,12 +54,12 @@ PSVIEWER?= gv
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
+.if exists(${LOCALBASE}/lib/libatlas.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
-BLAS_LIBS= -lf77blas -latlas
+BLAS_LIBS= -lf77blas
LAPACK_LIBS= -lalapack -lcblas
.else
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
diff --git a/cad/pdnmesh/Makefile b/cad/pdnmesh/Makefile
index 10d7b1c96cb7..b3577d2157cb 100644
--- a/cad/pdnmesh/Makefile
+++ b/cad/pdnmesh/Makefile
@@ -18,12 +18,12 @@ LIB_DEPENDS= gtkglext:${PORTSDIR}/x11-toolkits/gtkglext
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
+.if exists(${LOCALBASE}/lib/libatlas.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
-BLAS= -lf77blas -latlas
+BLAS= -lf77blas
LAPACK= -lalapack -lcblas
.else
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
diff --git a/cad/tochnog/Makefile b/cad/tochnog/Makefile
index 346f7126ee18..7929dd0be1d3 100644
--- a/cad/tochnog/Makefile
+++ b/cad/tochnog/Makefile
@@ -40,9 +40,9 @@ GID_PTYPES= ${PREFIX}/${GIDDIR}/problemtypes
.ifdef WITH_ATLAS
.ifdef WITH_THREADS
-BLAS_LIBS= -lptf77blas -latlas_r
+BLAS_LIBS= -lptf77blas
.else
-BLAS_LIBS= -lf77blas -latlas
+BLAS_LIBS= -lf77blas
.endif
.else #BLAS
BLAS_LIBS?= -lblas