aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-16 03:46:07 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-16 03:46:07 +0000
commit87179c9d15d87d787221a534426758b207496a52 (patch)
tree35a806089c55b27d0b9e78c73461a390122db59d /cad
parent76a35922f9c546618d98614aa014a3b9935a9a56 (diff)
downloadports-87179c9d15d87d787221a534426758b207496a52.tar.gz
ports-87179c9d15d87d787221a534426758b207496a52.zip
- Fix installdirs to address geda directory structure unification
- Use NLS conditional - FIx comment - Bump PORTREVISION - Mark BROKEN on 4.x - Rename to have geda- prefix of directory [2] PR: ports/100224, ports/100222 [2] Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=167953
Diffstat (limited to 'cad')
-rw-r--r--cad/geda-gschem/Makefile29
-rw-r--r--cad/geda-gschem/files/patch-configure11
-rw-r--r--cad/geda-gschem/files/patch-src_x_menus.c14
-rw-r--r--cad/geda-gschem/pkg-plist80
4 files changed, 89 insertions, 45 deletions
diff --git a/cad/geda-gschem/Makefile b/cad/geda-gschem/Makefile
index 303d33db1354..3144d81764e8 100644
--- a/cad/geda-gschem/Makefile
+++ b/cad/geda-gschem/Makefile
@@ -7,25 +7,44 @@
PORTNAME= gschem
PORTVERSION= 20060123
+PORTREVISION= 1
CATEGORIES= cad
MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/devel/${PORTVERSION}/ \
http://geda.seul.org/devel/${PORTVERSION}/ \
http://www.tinkerbox.org/projects/files/gEDA/
-DISTNAME= geda-${PORTNAME}-${PORTVERSION}
+PKGNAMEPREFIX= geda-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= ssedov@mbsd.msk.ru
-COMMENT= gEDA electronic schematic capture tools
+COMMENT= The gEDA's electronic schematic capture tool
-RUN_DEPENDS= ${LOCALBASE}/share/gEDA/sym:${PORTSDIR}/cad/geda-symbols
+RUN_DEPENDS= ${LOCALBASE}/share/geda/sym:${PORTSDIR}/cad/geda-symbols
LIB_DEPENDS= geda.25:${PORTSDIR}/cad/libgeda
+DOCSDIR= ${PREFIX}/share/doc/geda
+DATADIR= ${PREFIX}/share/geda
+
GNU_CONFIGURE= yes
USE_GNOME= gtk20
-CONFIGURE_ARGS= --enable-gdgeda
+CONFIGURE_ARGS= --enable-gdgeda --with-docdir=${DOCSDIR}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
INFO= gschemdoc
MAN1= gschem.1
-.include <bsd.port.mk>
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/cad/geda-gschem/files/patch-configure b/cad/geda-gschem/files/patch-configure
new file mode 100644
index 000000000000..54fae9d07e4c
--- /dev/null
+++ b/cad/geda-gschem/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Thu Jul 13 14:11:39 2006
++++ configure Thu Jul 13 14:11:52 2006
+@@ -7923,7 +7923,7 @@
+ # gEDA/gaf specific setup start
+ #
+
+-DATADIR=gEDA
++DATADIR=geda
+ GEDADATADIR=$datadir/$DATADIR
+
+ if eval "test x$opt_rcdir = x"; then
diff --git a/cad/geda-gschem/files/patch-src_x_menus.c b/cad/geda-gschem/files/patch-src_x_menus.c
new file mode 100644
index 000000000000..726dc21c2ae2
--- /dev/null
+++ b/cad/geda-gschem/files/patch-src_x_menus.c
@@ -0,0 +1,14 @@
+--- src/x_menus.c.orig Thu Jul 13 14:21:07 2006
++++ src/x_menus.c Thu Jul 13 14:21:49 2006
+@@ -284,9 +284,11 @@
+ */
+ item_factory = gtk_item_factory_new(GTK_TYPE_MENU, "<popup>",
+ accel_group);
++#if defined(ENABLE_NLS)
+ gtk_item_factory_set_translate_func(item_factory,
+ (GtkTranslateFunc) gettext,
+ NULL, NULL);
++#endif
+ /* This function creates the pop-up menu itself & attaches it to the
+ GtkItemFactory. Pass the item factory,
+ the number of items in the array, the array itself, and any
diff --git a/cad/geda-gschem/pkg-plist b/cad/geda-gschem/pkg-plist
index aac5bef372cc..d8968cbf5f1b 100644
--- a/cad/geda-gschem/pkg-plist
+++ b/cad/geda-gschem/pkg-plist
@@ -1,39 +1,39 @@
bin/gschem
-share/doc/geda-doc/man/gschem.html
-share/gEDA/bitmap/gschem-bus.xpm
-share/gEDA/bitmap/gschem-comp.xpm
-share/gEDA/bitmap/gschem-copy.xpm
-share/gEDA/bitmap/gschem-delete.xpm
-share/gEDA/bitmap/gschem-edit.xpm
-share/gEDA/bitmap/gschem-mirror.xpm
-share/gEDA/bitmap/gschem-move.xpm
-share/gEDA/bitmap/gschem-net.xpm
-share/gEDA/bitmap/gschem-new.xpm
-share/gEDA/bitmap/gschem-open.xpm
-share/gEDA/bitmap/gschem-redo.xpm
-share/gEDA/bitmap/gschem-rotate.xpm
-share/gEDA/bitmap/gschem-save.xpm
-share/gEDA/bitmap/gschem-select.xpm
-share/gEDA/bitmap/gschem-text.xpm
-share/gEDA/bitmap/gschem-undo.xpm
-share/gEDA/bitmap/gschem-warning.png
-share/gEDA/gschem-darkbg
-share/gEDA/gschem-gtkrc
-share/gEDA/gschem-lightbg
-share/gEDA/scheme/auto-uref.scm
-share/gEDA/scheme/generate_netlist.scm
-share/gEDA/scheme/gschem.scm
-share/gEDA/scheme/list-keys.scm
-share/gEDA/scheme/print-NB-attribs.scm
-share/gEDA/system-gschemrc
-share/locale/de_DE/LC_MESSAGES/geda-gschem.mo
-share/locale/es_ES/LC_MESSAGES/geda-gschem.mo
-share/locale/fr_FR/LC_MESSAGES/geda-gschem.mo
-share/locale/it_IT/LC_MESSAGES/geda-gschem.mo
-share/locale/ja_JP/LC_MESSAGES/geda-gschem.mo
-share/locale/nl_NL/LC_MESSAGES/geda-gschem.mo
-share/locale/pt_BR/LC_MESSAGES/geda-gschem.mo
-share/locale/ru/LC_MESSAGES/geda-gschem.mo
+%%DOCSDIR%%/man/gschem.html
+%%DATADIR%%/bitmap/gschem-bus.xpm
+%%DATADIR%%/bitmap/gschem-comp.xpm
+%%DATADIR%%/bitmap/gschem-copy.xpm
+%%DATADIR%%/bitmap/gschem-delete.xpm
+%%DATADIR%%/bitmap/gschem-edit.xpm
+%%DATADIR%%/bitmap/gschem-mirror.xpm
+%%DATADIR%%/bitmap/gschem-move.xpm
+%%DATADIR%%/bitmap/gschem-net.xpm
+%%DATADIR%%/bitmap/gschem-new.xpm
+%%DATADIR%%/bitmap/gschem-open.xpm
+%%DATADIR%%/bitmap/gschem-redo.xpm
+%%DATADIR%%/bitmap/gschem-rotate.xpm
+%%DATADIR%%/bitmap/gschem-save.xpm
+%%DATADIR%%/bitmap/gschem-select.xpm
+%%DATADIR%%/bitmap/gschem-text.xpm
+%%DATADIR%%/bitmap/gschem-undo.xpm
+%%DATADIR%%/bitmap/gschem-warning.png
+%%DATADIR%%/gschem-darkbg
+%%DATADIR%%/gschem-gtkrc
+%%DATADIR%%/gschem-lightbg
+%%DATADIR%%/scheme/auto-uref.scm
+%%DATADIR%%/scheme/generate_netlist.scm
+%%DATADIR%%/scheme/gschem.scm
+%%DATADIR%%/scheme/list-keys.scm
+%%DATADIR%%/scheme/print-NB-attribs.scm
+%%DATADIR%%/system-gschemrc
+%%NLS%%share/locale/de_DE/LC_MESSAGES/geda-gschem.mo
+%%NLS%%share/locale/es_ES/LC_MESSAGES/geda-gschem.mo
+%%NLS%%share/locale/fr_FR/LC_MESSAGES/geda-gschem.mo
+%%NLS%%share/locale/it_IT/LC_MESSAGES/geda-gschem.mo
+%%NLS%%share/locale/ja_JP/LC_MESSAGES/geda-gschem.mo
+%%NLS%%share/locale/nl_NL/LC_MESSAGES/geda-gschem.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/geda-gschem.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/geda-gschem.mo
@dirrmtry share/locale/nl_NL/LC_MESSAGES
@dirrmtry share/locale/nl_NL
@dirrmtry share/locale/ja_JP/LC_MESSAGES
@@ -44,8 +44,8 @@ share/locale/ru/LC_MESSAGES/geda-gschem.mo
@dirrmtry share/locale/fr_FR
@dirrmtry share/locale/de_DE/LC_MESSAGES
@dirrmtry share/locale/de_DE
-@dirrmtry share/gEDA/scheme
-@dirrmtry share/gEDA/bitmap
-@dirrmtry share/gEDA
-@dirrmtry share/doc/geda-doc/man
-@dirrmtry share/doc/geda-doc
+@dirrmtry %%DATADIR%%/scheme
+@dirrmtry %%DATADIR%%/bitmap
+@dirrmtry %%DATADIR%%
+@dirrmtry %%DOCSDIR%%/man
+@dirrmtry %%DOCSDIR%%