aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2005-06-26 10:06:21 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2005-06-26 10:06:21 +0000
commitabc63ad18e107196f5ad393616fafaccaed502b4 (patch)
tree37947a3233127a35ebbded4caa5fbe90278f2f49 /cad
parent395b750f34ddb019b5f130b6d3923d2ab8590ed2 (diff)
downloadports-abc63ad18e107196f5ad393616fafaccaed502b4.tar.gz
ports-abc63ad18e107196f5ad393616fafaccaed502b4.zip
The tochnog port installs some plugins into a directory which is owned by
the the cad/linux-gid port, but it doesn't adds a dependency to linux-gid, since tochnog can be used standalone. The right thing to do would be to add a slave port which installs the plugins only. The slave port would have to depend upon linux-gid and tochnog. Since the linux-gid port installs now in X11BASE and tochnog installs in LOCALBASE, we have a plist problem ATM too. In light of the recent discussion about the right base directory for ports which use X11 bits I decided to go the quick route until everything is decided: - move linux-gid back to LOCALBASE - let tochnog still install the plugins This reverts back to the status quo (a working tochnog/linux-gid). Someone with a good asbestos suite may want to mark the tochnog port BROKEN. Dependencies explained by: pfgshield-freebsd@yahoo.com
Notes
Notes: svn path=/head/; revision=138033
Diffstat (limited to 'cad')
-rw-r--r--cad/linux-gid/Makefile3
-rw-r--r--cad/tochnog/Makefile11
2 files changed, 11 insertions, 3 deletions
diff --git a/cad/linux-gid/Makefile b/cad/linux-gid/Makefile
index 94d219d139e5..bbacc3139bbc 100644
--- a/cad/linux-gid/Makefile
+++ b/cad/linux-gid/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gid
PORTVERSION= 7.4.9b
+PORTREVISION= 1
CATEGORIES= cad linux
MASTER_SITES= ftp://gid.cimne.upc.es/pub/gid_adds/Linux/Old/
PKGNAMEPREFIX= linux-
@@ -19,7 +20,7 @@ CONFLICTS= id-utils-[0-9]* coreutils-[0-9]*
ONLY_FOR_ARCHS= amd64 i386
USE_LINUX= yes
-USE_X_PREFIX= yes
+#USE_X_PREFIX= yes
USE_REINPLACE= yes
REINPLACE_ARGS= -i ""
NO_WRKSUBDIR= yes
diff --git a/cad/tochnog/Makefile b/cad/tochnog/Makefile
index 2551893d8157..d6ef866319e5 100644
--- a/cad/tochnog/Makefile
+++ b/cad/tochnog/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tochnog
PORTVERSION= 20010211
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= cad
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tochnog
@@ -24,6 +24,13 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libsuperlu.a:${PORTSDIR}/math/superlu
.endif
LIB_DEPENDS= atlas:${PORTSDIR}/math/atlas
+# This port installs some plugins into a directory which is owned by the
+# the cad/linux-gid port, but it doesn't adds a dependency to linux-gid,
+# since tochnog can be used standalone.
+# The right thing to do would be to add a slave port which installs the
+# plugins only. The slave port would have to depend upon linux-gid and
+# tochnog.
+
USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}/src
MAKEFILE= makefile
@@ -31,7 +38,7 @@ MAKEFILE= makefile
GIDDIR?= share/gid
PLIST_SUB+= GIDDIR=${GIDDIR}
-GID_PREFIX?= ${X11BASE}/${GIDDIR}/problemtypes
+GID_PREFIX?= ${LOCALBASE}/${GIDDIR}/problemtypes
.ifdef WITH_THREADS
BLAS_LIBS?= -L${LOCALBASE}/lib -lptf77blas -latlas_r