aboutsummaryrefslogtreecommitdiff
path: root/chinese/fortunetw/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-08 09:37:35 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-08 09:37:35 +0000
commit0683f89dd4765ce96616e75725009cc8b3523575 (patch)
tree4fe8199646d5c6ea9976d4a30dee03eb336d02f9 /chinese/fortunetw/Makefile
parent1ea9982bf0a4a67d5d0c496f549409be0244295c (diff)
downloadports-0683f89dd4765ce96616e75725009cc8b3523575.tar.gz
ports-0683f89dd4765ce96616e75725009cc8b3523575.zip
add fortunetw
A very classic fortune file in Taiwan PR: 32504 Submitted by: Statue <statue@softwareliberty.org>
Notes
Notes: svn path=/head/; revision=51214
Diffstat (limited to 'chinese/fortunetw/Makefile')
-rw-r--r--chinese/fortunetw/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/chinese/fortunetw/Makefile b/chinese/fortunetw/Makefile
new file mode 100644
index 000000000000..01e9af1dacfb
--- /dev/null
+++ b/chinese/fortunetw/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: fortunetw
+# Date created: 10 Mar 2001
+# Whom: Shen Chuan-Hsing
+#
+# $FreeBSD$
+#
+
+PORTNAME= fortunetw
+PORTVERSION= 1.0
+CATEGORIES= chinese
+MASTER_SITES= http://freebsd.sinica.edu.tw/~statue/
+DISTNAME= zh-fortunetw-${PORTVERSION}
+
+MAINTAINER= statue@freebsd.sinica.edu.tw
+
+NO_BUILD= yes
+
+STRCMD= /usr/games/strfile
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/games/fortune
+ @${INSTALL_DATA} ${WRKSRC}/tangshi ${PREFIX}/share/games/fortune
+ @${INSTALL_DATA} ${WRKSRC}/yijing ${PREFIX}/share/games/fortune
+
+pre-install:
+.if !exists(${STRCMD})
+ @${ECHO_MSG} "Please install the games distribution"
+ @exit 1
+.endif
+
+post-install:
+ @${STRCMD} ${PREFIX}/share/games/fortune/tangshi
+ @${STRCMD} ${PREFIX}/share/games/fortune/yijing
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Usage:"
+ @${ECHO_MSG} "/usr/games/fortune ${PREFIX}/share/games/fortune/tangshi"
+ @${ECHO_MSG} "or"
+ @${ECHO_MSG} "/usr/games/fortune ${PREFIX}/share/games/fortune/yijing"
+ @${ECHO_MSG} ""
+
+.include <bsd.port.mk>