aboutsummaryrefslogtreecommitdiff
path: root/chinese/gcin
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2009-02-01 01:10:45 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2009-02-01 01:10:45 +0000
commit1e8431951521b971397d6df2e571abac1e1fc9ac (patch)
tree748d918d80c97e33b1b13fb0225ff66b1e3c767f /chinese/gcin
parent58af17c83b40bddb9a115305dcf25a1095855f46 (diff)
downloadports-1e8431951521b971397d6df2e571abac1e1fc9ac.tar.gz
ports-1e8431951521b971397d6df2e571abac1e1fc9ac.zip
- Update to 1.4.4
Notes
Notes: svn path=/head/; revision=227322
Diffstat (limited to 'chinese/gcin')
-rw-r--r--chinese/gcin/Makefile51
-rw-r--r--chinese/gcin/distinfo6
-rw-r--r--chinese/gcin/files/patch-qt4-im-Makefile41
-rw-r--r--chinese/gcin/pkg-plist11
4 files changed, 90 insertions, 19 deletions
diff --git a/chinese/gcin/Makefile b/chinese/gcin/Makefile
index c4dbfb0eb4d4..69fc89184e5a 100644
--- a/chinese/gcin/Makefile
+++ b/chinese/gcin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gcin
-PORTVERSION= 1.4.2
-PORTREVISION= 1
+PORTVERSION= 1.4.4
CATEGORIES= chinese textproc gnome
MASTER_SITES= http://cle.linux.org.tw/gcin/download/:main \
http://ftp.twaren.net/local-distfiles/gcin/:main \
@@ -18,6 +17,8 @@ EXTRACT_ONLY= gcin-${PORTVERSION}.tar.bz2
MAINTAINER= chinsan@FreeBSD.org
COMMENT= A traditional chinese input utility in X
+BUILD_DEPENDS+= ${LOCALBASE}/include/anthy/anthy.h:${PORTSDIR}/japanese/anthy
+
CONFLICTS= zh-gcin-devel-[0-9]*
LATEST_LINK= yes
@@ -28,7 +29,9 @@ USE_GMAKE= YES
USE_XORG= xtst
INSTALLS_ICONS= YES
USE_LDCONFIG= YES
-OPTIONS= BOSHIAMY "enable Boshiamy Input Method" on
+OPTIONS= ANTHY "enable Japanese anthy IM module" off \
+ BOSHIAMY "enable Boshiamy Input Method" on \
+ QT_IM_MODULE "enable QT IM module" on
MAN1= gcin.1 gcin2tab.1 gcin-gb-toggle.1 gcin-kbm-toggle.1 \
gcin-message.1 gcin-setup.1 gtab-merge.1 juyin-learn.1 \
@@ -36,6 +39,10 @@ MAN1= gcin.1 gcin2tab.1 gcin-gb-toggle.1 gcin-kbm-toggle.1 \
.include <bsd.port.pre.mk>
+.if defined(WITH_ANTHY)
+RUN_DEPENDS+= ${LOCALBASE}/include/anthy/anthy.h:${PORTSDIR}/japanese/anthy
+.endif
+
.if defined(WITH_BOSHIAMY)
MASTER_SITES+= http://cle.linux.org.tw/~edt1023/gcin/:boshiamy \
LOCAL/chinsan/gcin:boshiamy \
@@ -53,26 +60,31 @@ post-extract:
${WRKSRC}/scripts/Makefile
.endif
-pre-patch:
+.if defined(WITH_QT_IM_MODULE)
+USE_QT_VER= 4
+QT_COMPONENTS= inputmethods qmake_build moc_build corelib gui
+LIB_DEPENDS+= mng:${PORTSDIR}/graphics/libmng
+.endif
+
+post-patch:
@${REINPLACE_CMD} -e 's,&,,; 1 s,bash,sh,; \
s,QT_IM_DIR=/usr,QT_IM_DIR=$$prefix,; \
s,mandir=$$datadir,mandir=$$prefix,; \
s,/usr/share,$$prefix/share,; s,libdir)\/gcin,libdir),; \
- 143,150 d; \
+ s,/usr/lib/qt4/plugins/lib,${PREFIX}/lib/qt4/plugins,; \
s,gcc,$$CC,; s,gcin-$$GCIN_VERSION,gcin,' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's,\/usr\/share,$$(prefix)\/share,; \
- 210,211 d; 215,216 d;' \
+ @${REINPLACE_CMD} -e 's,\/usr\/share,$$(prefix)\/share,;' \
${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's,/usr/local,/usr,g' \
${WRKSRC}/gtk-im/Makefile ${WRKSRC}/menu/Makefile
- @${REINPLACE_CMD} -e 's,/usr/lib,${LOCALBASE}/lib,g; \
- s,/usr/include,${LOCALBASE}/include,g; s,Xft2/X11/Xft,X11/Xft,' \
- ${WRKSRC}/qt-im/Makefile
@${REINPLACE_CMD} -e 's,modify-XIM ,,; 8,10 d' \
${WRKSRC}/scripts/Makefile
@${REINPLACE_CMD} -e 's,bash,sh,; s/&//; s,/opt/gnome,${LOCALBASE},;' \
${WRKSRC}/scripts/utf8-edit ${WRKSRC}/scripts/gcin-user-setup \
${WRKSRC}/scripts/gtab.append_prepare
+ @${REINPLACE_CMD} -e 's,bash,sh,; s/&//; 12,13 s/=/ /; \
+ s/export/setenv/; s/mozilla-firefox/firefox3/;' \
+ ${WRKSRC}/scripts/html-browser
@${REINPLACE_CMD} -e 's,wget,fetch,' ${WRKSRC}/scripts/noseeing-inst
@${REINPLACE_CMD} -e 's,gcin-im-client.h,im-client/gcin-im-client.h,;' \
${WRKSRC}/gtk-im/gtkimcontextgcin.c
@@ -83,16 +95,31 @@ pre-patch:
@${REINPLACE_CMD} -e '/make/ d' ${WRKSRC}/IMdkit/lib/Makefile
.if defined(WITH_BOSHIAMY)
-post-patch:
PLIST_SUB+= BOSHIAMY=""
.else
PLIST_SUB+= BOSHIAMY="@comment "
.endif
+.if defined(WITH_QT_IM_MODULE)
+PLIST_SUB+= QT_IM_MODULE=""
+.else
+PLIST_SUB+= QT_IM_MODULE="@comment "
+.endif
+
+post-build:
+.if !defined(DEBUG_FLAGS)
+ @${FIND} ${WRKSRC} -name "*.so*" | ${XARGS} strip
+.endif
+
post-install:
+.if !defined(DEBUG_FLAGS)
+.for f in gcin* gtab-merge juyin-learn phoa2* sim2trad trad2sim ts*
+ @strip ${PREFIX}/bin/${f}
+.endfor
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in Changelog README
+.for file in Changelog.html README.html
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
diff --git a/chinese/gcin/distinfo b/chinese/gcin/distinfo
index 2ebbe1c05cb8..a895d4121add 100644
--- a/chinese/gcin/distinfo
+++ b/chinese/gcin/distinfo
@@ -1,6 +1,6 @@
-MD5 (gcin-1.4.2.tar.bz2) = 86367f1408bcf0a0428e4130003d2174
-SHA256 (gcin-1.4.2.tar.bz2) = 6a34749c95fa98734a191db6362dd99ec2490d926f81d1de118787262e18568a
-SIZE (gcin-1.4.2.tar.bz2) = 2435375
+MD5 (gcin-1.4.4.tar.bz2) = 917874510ebdb8b28bf6a63251600493
+SHA256 (gcin-1.4.4.tar.bz2) = 303e4ddcf221079658c823dc407f595b61d343e9ccd438136439a02c3bbcb01c
+SIZE (gcin-1.4.4.tar.bz2) = 2706008
MD5 (noseeing-12.tar.gz) = ac89cf9bc9ece68b9f287a222197b147
SHA256 (noseeing-12.tar.gz) = 9082f50db64b9e2971873aca1607c45a8eb41e803b99f66bd239fd587e1ce19b
SIZE (noseeing-12.tar.gz) = 416726
diff --git a/chinese/gcin/files/patch-qt4-im-Makefile b/chinese/gcin/files/patch-qt4-im-Makefile
new file mode 100644
index 000000000000..8a9fa21a7034
--- /dev/null
+++ b/chinese/gcin/files/patch-qt4-im-Makefile
@@ -0,0 +1,41 @@
+--- qt4-im/Makefile.orig 2009-02-01 08:50:10.000000000 +0800
++++ qt4-im/Makefile 2009-02-01 08:55:39.000000000 +0800
+@@ -1,29 +1,29 @@
+ include ../config.mak
+ QT=qt4
+-QTIM=$(QT)/plugins/lib/inputmethods
+-IMMODULES=$(libdir)/$(QTIM)
++QTIM=$(QT)/plugins/inputmethods
++IMMODULES=/usr/local/lib/$(QTIM)
+ ifeq ($(LIB), lib64)
+- IMMODULES_LOCAL=/usr/$(LIB)/qt4/plugins/lib64/inputmethods
++ IMMODULES_LOCAL=/usr/local/lib/qt4/plugins/lib64/inputmethods
+ else
+- IMMODULES_LOCAL=/usr/$(LIB)/$(QTIM)
++ IMMODULES_LOCAL=$(IMMODULES)
+ endif
+-QTINC=/usr/lib/$(QT)/include
++QTINC=/usr/local/include/$(QT)
+
+-INCS=-I../im-client -I$(QTINC) -I/usr/include/X11 -I$(QTINC)/QtGui -I$(QTINC)/QtCore
++INCS=-I../im-client -I$(QTINC) -I/usr/local/include -I$(QTINC)/QtGui -I$(QTINC)/QtCore
+ CXXFLAGS=$(OPTFLAGS) $(INCS) -Wall -D_REENTRANT -fPIC -DQT4 -DQT_SHARED \
+ -DQT_IMMODULE -DPIC
+ OBJS= moc_gcin-qt.o gcin-qt.o im-gcin-qt.o gcin-imcontext-qt.o
+ .SUFFIXES: .c .cpp .a .so .E .h
+-LDFLAGS=-L/usr/lib/$(QT)/$(LIB) -L/usr/X11R6/$(LIB) -L../im-client -lQtGui -lQtCore -lmng -ljpeg -lpng -lz \
++LDFLAGS=-L/usr/local/lib/$(QT) -L/usr/local/lib -L../im-client -lQtGui -lQtCore -lmng -ljpeg -lpng -lz \
+ -lXrender -lXrandr -lXft -lfontconfig -lgcin-im-client \
+--lXext -lX11 -lm -lSM -lICE -ldl -lpthread
++-lXext -lX11 -lm -lSM -lICE -lpthread
+ all: im-gcin.so
+
+ .cpp.E:
+ $(CXX) -E $(CFLAGS) $(INCS) $< > $@
+
+ moc_gcin-qt.cpp: gcin-qt.h
+- /usr/lib/$(QT)/bin/moc $< -o moc_gcin-qt.cpp
++ /usr/local/bin/moc-qt4 $< -o moc_gcin-qt.cpp
+
+ im-gcin.so: $(OBJS)
+ export LD_RUN_PATH=$(gcinlibdir) ;\
diff --git a/chinese/gcin/pkg-plist b/chinese/gcin/pkg-plist
index 3713fb5b23fa..dfb970d45175 100644
--- a/chinese/gcin/pkg-plist
+++ b/chinese/gcin/pkg-plist
@@ -17,17 +17,20 @@ bin/tsd2a32
bin/tslearn
include/gcin-im-client.h
lib/gtk-2.0/immodules/im-gcin.so
+%%QT_IM_MODULE%%lib/qt4/plugins/inputmethods/im-gcin.so
lib/gcin1.so
lib/gcin2.so
lib/libgcin-im-client.so
-lib/libgcin-im-client.so.1.0.2
+lib/libgcin-im-client.so.1.1.0
lib/libgcin-im-client.so.1
%%DATADIR%%/script/gcin-user-setup
%%DATADIR%%/script/gtab.append_prepare
+%%DATADIR%%/script/html-browser
%%BOSHIAMY%%%%DATADIR%%/script/noseeadd.rb
%%DATADIR%%/script/noseeing-inst
%%DATADIR%%/script/utf8-edit
%%DATADIR%%/table/ar30.gtab
+%%DATADIR%%/table/ar30-big.gtab
%%DATADIR%%/table/cj-punc.gtab
%%DATADIR%%/table/cj.gtab
%%DATADIR%%/table/cj5.gtab
@@ -42,7 +45,6 @@ lib/libgcin-im-client.so.1
%%DATADIR%%/table/hsu.kbm
%%DATADIR%%/table/ibm.kbm
%%DATADIR%%/table/jyutping.gtab
-%%DATADIR%%/table/kana-nippon.gtab
%%DATADIR%%/table/latin-letters.gtab
%%DATADIR%%/table/mitac.kbm
%%BOSHIAMY%%%%DATADIR%%/table/noseeing.gtab
@@ -64,8 +66,8 @@ lib/libgcin-im-client.so.1
%%DATADIR%%/table/tsin32.idx
%%DATADIR%%/table/zo.kbm
%%DATADIR%%/table/zo-asdf.kbm
-%%PORTDOCS%%%%DOCSDIR%%/Changelog
-%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/Changelog.html
+%%PORTDOCS%%%%DOCSDIR%%/README.html
share/applications/gcin
share/applications/gcin-setup
share/icons/gcin/NewCJ3.png
@@ -80,6 +82,7 @@ share/icons/gcin/erbi.png
share/icons/gcin/ez.png
share/icons/gcin/fcitx-qxm.png
share/icons/gcin/fcitx-wanfeng.png
+share/icons/gcin/gcb.png
share/icons/gcin/gcin-tray.png
share/icons/gcin/gdayi3.png
share/icons/gcin/greek.png