aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:53:03 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:53:03 +0000
commitb185046be2ec03555daaf4f26d38542c403a9955 (patch)
tree0274ce607614533de66837fc1f70d4c35770d9e1 /chinese
parent88d002074007544d532f2495aeb93729291e6275 (diff)
downloadports-b185046be2ec03555daaf4f26d38542c403a9955.tar.gz
ports-b185046be2ec03555daaf4f26d38542c403a9955.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead.
Notes
Notes: svn path=/head/; revision=84842
Diffstat (limited to 'chinese')
-rw-r--r--chinese/oto/Makefile7
-rw-r--r--chinese/oto/files/patch-src::Makefile.in28
2 files changed, 5 insertions, 30 deletions
diff --git a/chinese/oto/Makefile b/chinese/oto/Makefile
index 73867e215b47..7cc5d1332a2c 100644
--- a/chinese/oto/Makefile
+++ b/chinese/oto/Makefile
@@ -7,6 +7,7 @@
PORTNAME= oto
PORTVERSION= 0.4
+PORTREVISION= 1
CATEGORIES= chinese print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,12 +15,14 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= statue@freebsd.sinica.edu.tw
COMMENT= Show you font info and add new 'name' and 'cmap' tables
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
+USE_GETOPT_LONG=yes
HAS_CONFIGURE= YES
USE_GMAKE= YES
USE_REINPLACE= yes
+CPPFLAGS= -I${LOCALBASE}/include
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LIBS="-L${LOCALBASE}/lib -liconv"
.include <bsd.port.pre.mk>
post-patch:
diff --git a/chinese/oto/files/patch-src::Makefile.in b/chinese/oto/files/patch-src::Makefile.in
deleted file mode 100644
index bc62f9295ed8..000000000000
--- a/chinese/oto/files/patch-src::Makefile.in
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/Makefile.in.orig Sun Dec 15 19:11:54 2002
-+++ src/Makefile.in Sun Dec 15 19:20:48 2002
-@@ -75,14 +75,14 @@
- directory.c name.c cmap.c
-
-
--oto_LDADD = -lm
-+oto_LDADD = -lm -L/usr/local/lib -liconv -lgnugetopt
- mkinstalldirs = $(SHELL) $(top_srcdir)/config/mkinstalldirs
- CONFIG_HEADER = ../config.h
- CONFIG_CLEAN_FILES =
- PROGRAMS = $(bin_PROGRAMS)
-
-
--DEFS = @DEFS@ -I. -I$(srcdir) -I..
-+DEFS = @DEFS@ -I. -I$(srcdir) -I.. -I/usr/local/include
- CPPFLAGS = @CPPFLAGS@
- LDFLAGS = @LDFLAGS@
- LIBS = @LIBS@
-@@ -92,7 +92,7 @@
- CFLAGS = @CFLAGS@
- COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
- CCLD = $(CC)
--LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
-+LINK = $(CCLD) $(DEFS) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
- DATA = $(pkgdata_DATA)
-
- DIST_COMMON = Makefile.am Makefile.in