aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-12-04 04:21:39 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-12-04 04:21:39 +0000
commit9a8f225ab9e9bcae3fada50732c8b4b3848a897f (patch)
tree54169f4891750e40197f6ae81da9b1c973c3ca11 /chinese
parentfcf9e9d1d0a39438ddde5dcacce334592093573e (diff)
downloadports-9a8f225ab9e9bcae3fada50732c8b4b3848a897f.tar.gz
ports-9a8f225ab9e9bcae3fada50732c8b4b3848a897f.zip
- fix word order in gcin2tab
PR: ports/106262 Submitted by: chinsan (maintainer)
Notes
Notes: svn path=/head/; revision=178802
Diffstat (limited to 'chinese')
-rw-r--r--chinese/gcin-devel/Makefile1
-rw-r--r--chinese/gcin-devel/files/patch-gcin2tab.c26
-rw-r--r--chinese/gcin/Makefile1
-rw-r--r--chinese/gcin/files/patch-gcin2tab.c26
4 files changed, 54 insertions, 0 deletions
diff --git a/chinese/gcin-devel/Makefile b/chinese/gcin-devel/Makefile
index fd61e5deb241..29fe2201ebb0 100644
--- a/chinese/gcin-devel/Makefile
+++ b/chinese/gcin-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gcin
PORTVERSION= 1.3.1
+PORTREVISION= 1
CATEGORIES= chinese textproc gnome
MASTER_SITES= http://cle.linux.org.tw/gcin/download/:main \
http://yilan.twbbs.org/chinsan/gcin/:main \
diff --git a/chinese/gcin-devel/files/patch-gcin2tab.c b/chinese/gcin-devel/files/patch-gcin2tab.c
new file mode 100644
index 000000000000..0eb3e39b7121
--- /dev/null
+++ b/chinese/gcin-devel/files/patch-gcin2tab.c
@@ -0,0 +1,26 @@
+--- gcin2tab.c.orig Sun Dec 3 11:05:26 2006
++++ gcin2tab.c Sun Dec 3 11:08:36 2006
+@@ -129,7 +129,10 @@
+ int d;
+ if ((d = a->key - b->key)) return d;
+
+- return memcmp(a->ch ,b->ch, CH_SZ);
++ d = memcmp(a->ch ,b->ch, CH_SZ);
++ if (d) return d;
++
++ return a->oseq - b->oseq;
+ }
+
+ int qcmp2_64(const void *aa, const void *bb)
+@@ -139,7 +142,10 @@
+ if (a->key > b->key) return 1;
+ if (a->key < b->key) return -1;
+
+- return memcmp(a->ch ,b->ch, CH_SZ);
++ int d = memcmp(a->ch ,b->ch, CH_SZ);
++ if (d) return d;
++
++ return a->oseq - b->oseq;
+ }
+
+ int qcmp(const void *aa, const void *bb)
diff --git a/chinese/gcin/Makefile b/chinese/gcin/Makefile
index fd61e5deb241..29fe2201ebb0 100644
--- a/chinese/gcin/Makefile
+++ b/chinese/gcin/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gcin
PORTVERSION= 1.3.1
+PORTREVISION= 1
CATEGORIES= chinese textproc gnome
MASTER_SITES= http://cle.linux.org.tw/gcin/download/:main \
http://yilan.twbbs.org/chinsan/gcin/:main \
diff --git a/chinese/gcin/files/patch-gcin2tab.c b/chinese/gcin/files/patch-gcin2tab.c
new file mode 100644
index 000000000000..0eb3e39b7121
--- /dev/null
+++ b/chinese/gcin/files/patch-gcin2tab.c
@@ -0,0 +1,26 @@
+--- gcin2tab.c.orig Sun Dec 3 11:05:26 2006
++++ gcin2tab.c Sun Dec 3 11:08:36 2006
+@@ -129,7 +129,10 @@
+ int d;
+ if ((d = a->key - b->key)) return d;
+
+- return memcmp(a->ch ,b->ch, CH_SZ);
++ d = memcmp(a->ch ,b->ch, CH_SZ);
++ if (d) return d;
++
++ return a->oseq - b->oseq;
+ }
+
+ int qcmp2_64(const void *aa, const void *bb)
+@@ -139,7 +142,10 @@
+ if (a->key > b->key) return 1;
+ if (a->key < b->key) return -1;
+
+- return memcmp(a->ch ,b->ch, CH_SZ);
++ int d = memcmp(a->ch ,b->ch, CH_SZ);
++ if (d) return d;
++
++ return a->oseq - b->oseq;
+ }
+
+ int qcmp(const void *aa, const void *bb)