aboutsummaryrefslogtreecommitdiff
path: root/comms/asmodem
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-10-10 23:47:40 +0000
committerSteve Price <steve@FreeBSD.org>1999-10-10 23:47:40 +0000
commit440b7948707c11e9d912cf6559457939fd592169 (patch)
tree509c0e97244e7f32c9bb38fa3da851e6c198e094 /comms/asmodem
parenta46f787de0794267ad1852d95813f492ff1217d9 (diff)
downloadports-440b7948707c11e9d912cf6559457939fd592169.tar.gz
ports-440b7948707c11e9d912cf6559457939fd592169.zip
Update to version 0.6.1.
PR: 14062 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Notes
Notes: svn path=/head/; revision=22335
Diffstat (limited to 'comms/asmodem')
-rw-r--r--comms/asmodem/Makefile26
-rw-r--r--comms/asmodem/distinfo2
-rw-r--r--comms/asmodem/files/patch-aa61
-rw-r--r--comms/asmodem/files/patch-ac17
-rw-r--r--comms/asmodem/pkg-descr2
5 files changed, 56 insertions, 52 deletions
diff --git a/comms/asmodem/Makefile b/comms/asmodem/Makefile
index 2558ec93babe..a4594329900b 100644
--- a/comms/asmodem/Makefile
+++ b/comms/asmodem/Makefile
@@ -1,25 +1,23 @@
-# New ports collection makefile for: asmodem
-# Version required: 0.6
-# Date created: 11 May 1998
-# Whom: Sean Cole <scole@aracnet.com>
+# New ports collection makefile for: asmodem
+# Version required: 0.6.1
+# Date created: 11 May 1998
+# Whom: Sean Cole <scole@aracnet.com>
#
# $FreeBSD$
#
-DISTNAME= asmodem-0.6
-CATEGORIES= comms
-MASTER_SITES= ftp://afterstep.foo.net/pub/AfterStep/apps/asmodem/ \
- ftp://ftp.cs.tu-berlin.de/pub/X/afterstep/apps/asmodem/
+DISTNAME= asmodem-0.6-1
+PKGNAME= asmodem-0.6.1
+CATEGORIES= comms
+MASTER_SITES= ${MASTER_SITE_AFTERSTEP}
+MASTER_SITE_SUBDIR= apps/asmodem
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
+LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
-USE_GMAKE= yes
USE_IMAKE= yes
-MAN1= asmodem.1
-post-install:
- strip ${PREFIX}/bin/asmodem
+MAN1= asmodem.1
.include <bsd.port.mk>
diff --git a/comms/asmodem/distinfo b/comms/asmodem/distinfo
index e4b5c71c7967..41495c40906b 100644
--- a/comms/asmodem/distinfo
+++ b/comms/asmodem/distinfo
@@ -1 +1 @@
-MD5 (asmodem-0.6.tar.gz) = 601b8cc81a741011046b5dfcb3224f22
+MD5 (asmodem-0.6-1.tar.gz) = 357c46651b33c0dcf3df3eb133ff4dc5
diff --git a/comms/asmodem/files/patch-aa b/comms/asmodem/files/patch-aa
index 1ab65d00646a..7961efa87534 100644
--- a/comms/asmodem/files/patch-aa
+++ b/comms/asmodem/files/patch-aa
@@ -1,16 +1,18 @@
---- asmodem-0.6/asmodem.c Mon May 11 15:38:04 1998
-+++ asmodem.c Mon May 11 15:58:52 1998
-@@ -22,8 +22,7 @@
- #include <sys/ioctl.h>
+--- asmodem.c.orig Mon Oct 5 04:56:57 1998
++++ asmodem.c Thu Sep 30 05:30:03 1999
+@@ -25,9 +25,8 @@
#include <sys/socket.h>
#include <net/if.h>
+
+-#include <asm/types.h>
+-#include <linux/types.h>
-#include <linux/ppp_defs.h>
--
++#include <machine/types.h>
+#include <net/if_ppp.h>
+
/* XPM struct and icons ******************************************************/
- typedef struct _XpmIcon {
-@@ -58,7 +57,7 @@
+@@ -63,7 +62,7 @@
#define DEFINTERVAL 3 /* Default interval 2 sec */
#define TRUE 1;
#define FALSE 0;
@@ -19,7 +21,7 @@
int withdrawn= FALSE;
Display *Disp;
-@@ -109,8 +108,8 @@
+@@ -114,8 +113,8 @@
fprintf(stderr,"options:\n");
fprintf(stderr," -w withdrawn mode (For WindowMaker's Dock)\n");
fprintf(stderr," -s transparent edge mode\n");
@@ -30,52 +32,41 @@
fprintf(stderr," -u <sec> update frequency (default 5 sec)\n");
fprintf(stderr," -p [+|-]x[+|-]y position of asmodem\n");
fprintf(stderr," -d <program> program to execute on click while disconnected (dial?)\n");
-@@ -293,7 +292,7 @@
+@@ -298,7 +297,7 @@
{
XEvent Event;
XpmIcon Prev;
- struct ifreq ifreq;
-+ struct ifpppstatsreq ifreq;
++ struct ifpppstatsreq ifreq;
struct ppp_stats stats;
int rb, tb;
-@@ -309,13 +308,14 @@
- }
+@@ -315,12 +314,12 @@
//fprintf(stderr, "x ");
if (CarrierOn) {
-- memset(&ifreq, 0, sizeof(ifreq));
+ memset(&ifreq, 0, sizeof(ifreq));
- strcpy(ifreq.ifr_ifrn.ifrn_name, "ppp0");
- ifreq.ifr_ifru.ifru_data = (caddr_t)&stats;
- if ((ioctl(sock,SIOCDEVPRIVATE,(caddr_t)&ifreq) < 0)){
-+ memset(&ifreq, 0, sizeof(ifreq));
-+
-+ strcpy(ifreq.ifr_name, "ppp0");
++ strcpy(ifreq.ifr_name, "ppp0");
+ if ((ioctl(sock,SIOCGPPPSTATS,&ifreq) < 0)){
fprintf(stderr, "asmodem: ioctl f*cked\n");
prb = ptb = 0;
} else {
-+ stats = ifreq.stats;
++ stats = ifreq.stats;
rb = stats.p.ppp_ibytes;
tb = stats.p.ppp_obytes;
if (rb > prb) {
-@@ -398,14 +398,14 @@
- /****************************************************************************/
- int IsNewMail(char *Mbox)
- {
-+
- FILE* MailFile;
- int Ret = 0;
- char Buffer[30] = "";
+@@ -409,7 +408,7 @@
int WasStatus = 1;
int NewMailn = 0;
- MailFile = fopen(Mbox, "r");
--
+/* MailFile = fopen(Mbox, "r");
+
while(!feof(MailFile))
{
- fgets(Buffer, 29, MailFile);
-@@ -420,6 +420,8 @@
+@@ -425,6 +424,8 @@
fclose(MailFile);
return (NewMailn||!WasStatus);
@@ -84,26 +75,22 @@
}
/****************************************************************************/
-@@ -427,8 +429,9 @@
- {
+@@ -433,7 +434,7 @@
FILE* MailFile = 0;
int Ret = 0;
-+
-+/* MailFile = fopen(Mbox, "r");
- MailFile = fopen(Mbox, "r");
++/* MailFile = fopen(Mbox, "r");
if(MailFile == 0)
Ret = 0;
else
-@@ -441,7 +444,15 @@
+@@ -447,6 +448,14 @@
}
- fclose(MailFile);
-- return Ret;
-+ return Ret;
+ return Ret;
+*/
+
-+ if ((MailFile=fopen(Mbox,"r"))==NULL)
++ if ((MailFile=fopen(Mbox,"r"))==NULL)
+ return 0;
+ else {
+ fclose(MailFile);
diff --git a/comms/asmodem/files/patch-ac b/comms/asmodem/files/patch-ac
new file mode 100644
index 000000000000..70c13384e1c8
--- /dev/null
+++ b/comms/asmodem/files/patch-ac
@@ -0,0 +1,17 @@
+--- Imakefile.orig Sat Mar 1 09:48:45 1997
++++ Imakefile Fri Oct 1 02:09:36 1999
+@@ -1,12 +1,12 @@
+
+-XPMLIB = -L/usr/lib/X11 -lXpm
++XPMLIB = -lXpm
+ DEPLIBS = $(DEPXLIB)
+
+ LOCAL_LIBRARIES = $(XPMLIB) $(XLIB)
+
+ LINTLIBS = $(LINTXLIB)
+
+-SRCS = asmodem.cpp
++SRCS = asmodem.c
+ OBJS = asmodem.o
+
+ ComplexProgramTarget(asmodem)
diff --git a/comms/asmodem/pkg-descr b/comms/asmodem/pkg-descr
index 1cca9e9b2835..50fb753e7d17 100644
--- a/comms/asmodem/pkg-descr
+++ b/comms/asmodem/pkg-descr
@@ -4,3 +4,5 @@ blinking lights that indicate when the modem is connected, transmitting,
and receiving. It is especially useful for internal modems.
It can execute programs to dial, re-dial, and hang-up when clicked on.
It only works on device ppp0.
+
+WWW: http://www.cmdrtaco.net/linux/mystuff.shtml