aboutsummaryrefslogtreecommitdiff
path: root/comms/cutecom
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2004-07-15 00:21:07 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2004-07-15 00:21:07 +0000
commita5c2db5a19ab26c6cd0209065b6d322720cddc4c (patch)
tree1bb901cdf3bfd6e8d3e22e384edd17754a43c838 /comms/cutecom
parent44dd2efdea4b0bf7e15ecf2ebe7705a7344639e7 (diff)
downloadports-a5c2db5a19ab26c6cd0209065b6d322720cddc4c.tar.gz
ports-a5c2db5a19ab26c6cd0209065b6d322720cddc4c.zip
Add cutecom 0.0.5, a graphical serial terminal.
Notes
Notes: svn path=/head/; revision=113676
Diffstat (limited to 'comms/cutecom')
-rw-r--r--comms/cutecom/Makefile37
-rw-r--r--comms/cutecom/distinfo2
-rw-r--r--comms/cutecom/files/current-cutecommdlg.ui.patch14
-rw-r--r--comms/cutecom/files/patch-qcppdialogimpl.cpp54
-rw-r--r--comms/cutecom/files/stable-cutecommdlg.ui.patch24
-rw-r--r--comms/cutecom/pkg-descr3
-rw-r--r--comms/cutecom/pkg-plist3
7 files changed, 137 insertions, 0 deletions
diff --git a/comms/cutecom/Makefile b/comms/cutecom/Makefile
new file mode 100644
index 000000000000..39924f23e5d4
--- /dev/null
+++ b/comms/cutecom/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: cutecom
+# Date created: Thu Jul 15 02:07:06 CEST 2004
+# Whom: Markus Brueffer <markus@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= cutecom
+PORTVERSION= 0.0.5
+CATEGORIES= comms
+MASTER_SITES= http://cutecom.sourceforge.net/
+
+MAINTAINER= markus@FreeBSD.org
+COMMENT= Graphical serial terminal
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+
+USE_QT_VER= 3
+MAKE_ENV+= QTDIR="${X11BASE}"
+
+do-configure:
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} qmake \
+ -spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ cutecom.pro
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/cutecom ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/applnk/Utilities
+ ${INSTALL_DATA} ${WRKSRC}/cutecom.desktop ${PREFIX}/share/applnk/Utilities
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+EXTRA_PATCHES= ${FILESDIR}/current-cutecommdlg.ui.patch
+.else
+EXTRA_PATCHES= ${FILESDIR}/stable-cutecommdlg.ui.patch
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/comms/cutecom/distinfo b/comms/cutecom/distinfo
new file mode 100644
index 000000000000..6b40b4ff1660
--- /dev/null
+++ b/comms/cutecom/distinfo
@@ -0,0 +1,2 @@
+MD5 (cutecom-0.0.5.tar.gz) = dea531a2ac9f82312f4888b9a2e7dc28
+SIZE (cutecom-0.0.5.tar.gz) = 16150
diff --git a/comms/cutecom/files/current-cutecommdlg.ui.patch b/comms/cutecom/files/current-cutecommdlg.ui.patch
new file mode 100644
index 000000000000..67276a99aebf
--- /dev/null
+++ b/comms/cutecom/files/current-cutecommdlg.ui.patch
@@ -0,0 +1,14 @@
+--- cutecommdlg.ui.orig Thu Jul 15 01:11:45 2004
++++ cutecommdlg.ui Thu Jul 15 01:12:07 2004
+@@ -248,11 +248,6 @@
+ </item>
+ <item>
+ <property name="text">
+- <string>576000</string>
+- </property>
+- </item>
+- <item>
+- <property name="text">
+ <string>921600</string>
+ </property>
+ </item>
diff --git a/comms/cutecom/files/patch-qcppdialogimpl.cpp b/comms/cutecom/files/patch-qcppdialogimpl.cpp
new file mode 100644
index 000000000000..fa5fa98af744
--- /dev/null
+++ b/comms/cutecom/files/patch-qcppdialogimpl.cpp
@@ -0,0 +1,54 @@
+--- qcppdialogimpl.cpp.orig Tue Jul 13 21:30:51 2004
++++ qcppdialogimpl.cpp Thu Jul 15 01:45:55 2004
+@@ -44,6 +44,9 @@
+ #include <ctype.h>
+ #include <sys/ioctl.h>
+ #include <sys/termios.h>
++#ifdef __FreeBSD__
++#include <sys/time.h>
++#endif
+ #include <fcntl.h>
+
+ QCPPDialogImpl::QCPPDialogImpl(QWidget* parent)
+@@ -147,11 +150,19 @@
+ bool entryFound=false;
+ QStringList devices=settings.readListEntry("/cutecom/AllDevices", &entryFound);
+ if (!entryFound)
++#ifdef __FreeBSD__
++ devices<<"/dev/cuaa0"<<"/dev/cuaa1"<<"/dev/cuaa2"<<"/dev/cuaa3";
++#else
+ devices<<"/dev/ttyS0"<<"/dev/ttyS1"<<"/dev/ttyS2"<<"/dev/ttyS3";
++#endif
+
+ m_deviceCb->insertStringList(devices);
+
++#ifdef __FreeBSD__
++ m_deviceCb->setCurrentText(settings.readEntry("/cutecom/CurrentDevice", "/dev/cuaa0"));
++#else
+ m_deviceCb->setCurrentText(settings.readEntry("/cutecom/CurrentDevice", "/dev/ttyS0"));
++#endif
+ }
+
+ void QCPPDialogImpl::showAboutMsg()
+@@ -610,15 +621,21 @@
+ case 230400:
+ _baud=B230400;
+ break;
++#if !defined(__FreeBSD__) || (_FreeBSD_version > 500000)
+ case 460800:
+ _baud=B460800;
+ break;
++#endif
++#ifndef __FreeBSD__
+ case 576000:
+ _baud=B576000;
+ break;
++#endif
++#if !defined(__FreeBSD__) || (_FreeBSD_version >= 500000)
+ case 921600:
+ _baud=B921600;
+ break;
++#endif
+ // case 128000:
+ // _baud=B128000;
+ // break;
diff --git a/comms/cutecom/files/stable-cutecommdlg.ui.patch b/comms/cutecom/files/stable-cutecommdlg.ui.patch
new file mode 100644
index 000000000000..bf1adf1ac921
--- /dev/null
+++ b/comms/cutecom/files/stable-cutecommdlg.ui.patch
@@ -0,0 +1,24 @@
+--- cutecommdlg.ui.orig Tue Jul 13 21:24:38 2004
++++ cutecommdlg.ui Thu Jul 15 01:47:55 2004
+@@ -241,21 +241,6 @@
+ <string>230400</string>
+ </property>
+ </item>
+- <item>
+- <property name="text">
+- <string>460800</string>
+- </property>
+- </item>
+- <item>
+- <property name="text">
+- <string>576000</string>
+- </property>
+- </item>
+- <item>
+- <property name="text">
+- <string>921600</string>
+- </property>
+- </item>
+ <property name="name">
+ <cstring>m_baudCb</cstring>
+ </property>
diff --git a/comms/cutecom/pkg-descr b/comms/cutecom/pkg-descr
new file mode 100644
index 000000000000..e713c1b6b21d
--- /dev/null
+++ b/comms/cutecom/pkg-descr
@@ -0,0 +1,3 @@
+CuteCom is a graphical serial terminal, like minicom.
+
+WWW: http://cutecom.sourceforge.net/
diff --git a/comms/cutecom/pkg-plist b/comms/cutecom/pkg-plist
new file mode 100644
index 000000000000..e319d7e4b6f8
--- /dev/null
+++ b/comms/cutecom/pkg-plist
@@ -0,0 +1,3 @@
+bin/cutecom
+share/applnk/Utilities/cutecom.desktop
+@unexec rmdir %D/share/applnk/Utilities 2>/dev/null || true