aboutsummaryrefslogtreecommitdiff
path: root/comms/ecu
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2002-01-26 07:41:23 +0000
committerKris Kennaway <kris@FreeBSD.org>2002-01-26 07:41:23 +0000
commitcb9dd529510223116603c68fd5915e8ec5432ac9 (patch)
tree0e0aef070e43620218186d759942bab7919f439d /comms/ecu
parentac4c0121f10a9a03f74e1384bbed9dc1c0c4573d (diff)
downloadports-cb9dd529510223116603c68fd5915e8ec5432ac9.tar.gz
ports-cb9dd529510223116603c68fd5915e8ec5432ac9.zip
Unbreak on -current, and don't hardwire CC or CFLAGS
Notes
Notes: svn path=/head/; revision=53765
Diffstat (limited to 'comms/ecu')
-rw-r--r--comms/ecu/Makefile5
-rw-r--r--comms/ecu/files/patch-ac34
-rw-r--r--comms/ecu/files/patch-ad11
3 files changed, 48 insertions, 2 deletions
diff --git a/comms/ecu/Makefile b/comms/ecu/Makefile
index 77faada2cf7f..3a4f191e5d0f 100644
--- a/comms/ecu/Makefile
+++ b/comms/ecu/Makefile
@@ -15,6 +15,11 @@ MAINTAINER= ache@FreeBSD.org
do-configure:
cd ${WRKSRC}; yes "" | ./Configure
+pre-patch:
+ @${PERL} -pi.orig -e "s@#include +<malloc.h>@@g" \
+ ${WRKSRC}/ecu.h ${WRKSRC}/ecunumrev.c ${WRKSRC}/ptyfork.c \
+ ${WRKSRC}/qmake.c ${WRKSRC}/unsupported/tts/tts.c
+
post-install:
cd ${WRKSRC}/doc; \
${INSTALL_MAN} ecu.man ${PREFIX}/man/cat1/ecu.1; \
diff --git a/comms/ecu/files/patch-ac b/comms/ecu/files/patch-ac
index 600970b36044..048a8c1a0353 100644
--- a/comms/ecu/files/patch-ac
+++ b/comms/ecu/files/patch-ac
@@ -1,5 +1,17 @@
---- config.c.bak Wed Sep 2 21:55:04 1998
-+++ config.c Sun Mar 11 09:49:40 2001
+--- config.c.orig Wed Sep 2 10:55:04 1998
++++ config.c Fri Jan 25 23:36:18 2002
+@@ -311,9 +311,9 @@
+ char *gcc_opts[] =
+ {
+ #ifdef PEDANTIC
+- "\t-pedantic -ansi -O2 -fno-builtin\\\n", /* UH OH: see ecu README */
++ "\t-pedantic -ansi -fno-builtin\\\n", /* UH OH: see ecu README */
+ #else
+- "\t-O2 -fno-builtin\\\n",
++ "\t-fno-builtin\\\n",
+ #endif
+ "\t-fpcc-struct-return -fwritable-strings -finline-functions\\\n",
+ "\t-W -Wuninitialized -Wunused -Wshadow -Wcomment -Wswitch\\\n",
@@ -447,7 +447,7 @@
char *bsd_libs = "-lcurses -ltermcap";
@@ -9,3 +21,21 @@
char *sco_system[] =
{
+@@ -729,7 +729,7 @@
+ {
+ char **strs;
+
+- fputs("CFLAGS = \\\n", fpmake);
++ fputs("CFLAGS += \\\n", fpmake);
+ strs = gcc_opts;
+ while (*strs)
+ fputs(*strs++, fpmake);
+@@ -1235,7 +1235,7 @@
+ break;
+ case C_GCC:
+ if (sys == S_FREEBSD)
+- fputs("CC = cc\n", fpmake);
++ fputs("CC ?= cc\n", fpmake);
+ else
+ fputs("CC = gcc\n", fpmake);
+ gen_gcc_cflags();
diff --git a/comms/ecu/files/patch-ad b/comms/ecu/files/patch-ad
new file mode 100644
index 000000000000..cb619ea92f8f
--- /dev/null
+++ b/comms/ecu/files/patch-ad
@@ -0,0 +1,11 @@
+--- ecushm.c.orig Fri Jan 25 23:15:09 2002
++++ ecushm.c Fri Jan 25 23:15:19 2002
+@@ -124,7 +124,7 @@
+
+ #if defined(CFG_MmapSHM)
+ shm = (ECU_SDS *) mmap(0, sizeof(ECU_SDS), PROT_READ | PROT_WRITE,
+- MAP_ANON | MAP_INHERIT | MAP_SHARED, -1, 0);
++ MAP_ANON | MAP_SHARED, -1, 0);
+ if (shm == (ECU_SDS *) - 1)
+ {
+ perror("mmap");