aboutsummaryrefslogtreecommitdiff
path: root/comms/gammu
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2009-03-12 08:01:19 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2009-03-12 08:01:19 +0000
commitb1c875c5613252e166f5865e933abbc7ce5f423f (patch)
tree5a7eb61140c1f45fadc4e95e8ae08636291d02e3 /comms/gammu
parent18966d31a5acfb9a49da12cd117db952ceee6d76 (diff)
downloadports-b1c875c5613252e166f5865e933abbc7ce5f423f.tar.gz
ports-b1c875c5613252e166f5865e933abbc7ce5f423f.zip
. fix build at FreeBSD-6.x (add a variable initialization,
the patch submitted upstream); . bump PORTREVISION (the logic has changed).
Notes
Notes: svn path=/head/; revision=229923
Diffstat (limited to 'comms/gammu')
-rw-r--r--comms/gammu/Makefile5
-rw-r--r--comms/gammu/files/patch-gammu-backupsms.c11
2 files changed, 12 insertions, 4 deletions
diff --git a/comms/gammu/Makefile b/comms/gammu/Makefile
index 758d59a9ab99..534774da10ce 100644
--- a/comms/gammu/Makefile
+++ b/comms/gammu/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gammu
PORTVERSION= 1.23.1
+PORTREVISION= 1
CATEGORIES= comms
MASTER_SITES= ftp://dl.cihar.com/gammu/releases/ \
http://dl.cihar.com/gammu/releases/
@@ -49,8 +50,4 @@ post-patch:
@${REINPLACE_CMD} -e 's@ -Wno-pointer-sign@@g' ${WRKSRC}/CMakeLists.txt
.endif
-.if ${OSVERSION} < 700000
-BROKEN= does not build at 6.x
-.endif
-
.include <bsd.port.post.mk>
diff --git a/comms/gammu/files/patch-gammu-backupsms.c b/comms/gammu/files/patch-gammu-backupsms.c
new file mode 100644
index 000000000000..e1299e151bb9
--- /dev/null
+++ b/comms/gammu/files/patch-gammu-backupsms.c
@@ -0,0 +1,11 @@
+--- gammu/backupsms.c.orig 2009-03-12 10:06:22.000000000 +0300
++++ gammu/backupsms.c 2009-03-12 10:06:38.000000000 +0300
+@@ -23,7 +23,7 @@
+ GSM_SMSFolders folders;
+ bool BackupFromFolder[GSM_MAX_SMS_FOLDERS];
+ bool start = true;
+- bool DeleteAfter, askdelete = true;
++ bool DeleteAfter = false, askdelete = true;
+ int j, smsnum = 0;
+
+ if (argc == 4) {