aboutsummaryrefslogtreecommitdiff
path: root/comms/hylafax
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-09-18 21:58:04 +0000
committerAde Lovett <ade@FreeBSD.org>2000-09-18 21:58:04 +0000
commite307881cab9257bc2aba5a4cdcc3189d6fe7f757 (patch)
tree63aaee8686345a3043ebd8c55e9179809a1fc29e /comms/hylafax
parentaeb00f7e3f873c9c3d3ab20a8e5c4bfabe3e3854 (diff)
downloadports-e307881cab9257bc2aba5a4cdcc3189d6fe7f757.tar.gz
ports-e307881cab9257bc2aba5a4cdcc3189d6fe7f757.zip
Fix incorrect use of snprintf() that causes pid of process
trying to lock a serial device in /var/spool/lock to be incorrectly written into the lock file. PORTREVISION bumped. PR: 20141 Submitted by: Cyrus Rahman <cr@jcmax.com>
Notes
Notes: svn path=/head/; revision=32825
Diffstat (limited to 'comms/hylafax')
-rw-r--r--comms/hylafax/Makefile1
-rw-r--r--comms/hylafax/files/patch-ad9
2 files changed, 1 insertions, 9 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index f9e231fce46e..99f906ece8ec 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hylafax
PORTVERSION= 4.1.b2
+PORTREVISION= 1
CATEGORIES= comms
MASTER_SITES= ftp://ftp.hylafax.org/hylafax/source/BETA/
DISTNAME= ${PORTNAME}-4.1beta2
diff --git a/comms/hylafax/files/patch-ad b/comms/hylafax/files/patch-ad
index aa3c2c17026a..4b89dab9bf90 100644
--- a/comms/hylafax/files/patch-ad
+++ b/comms/hylafax/files/patch-ad
@@ -156,15 +156,6 @@ diff -ruN faxd/UUCPLock.c++.orig faxd/UUCPLock.c++
}
}
uid_t UUCPLock::getUUCPUid() { setupIDs(); return UUCPuid; }
-@@ -307,7 +315,7 @@
- AsciiUUCPLock::setPID(pid_t pid)
- {
- // XXX should this be %d or %ld? depends on pid_t
-- sprintf((char*) data, "%*d\n", UUCP_PIDDIGITS, pid);
-+ snprintf((char*) data, sizeof(data), "%*d\n", UUCP_PIDDIGITS, pid);
- }
-
- bool
diff -ruN faxd/faxApp.c++.orig faxd/faxApp.c++
--- faxd/faxApp.c++.orig Sun Jun 13 00:41:05 1999
+++ faxd/faxApp.c++ Mon Jun 12 21:52:39 2000