aboutsummaryrefslogtreecommitdiff
path: root/comms/kpsk
diff options
context:
space:
mode:
authorPatrick S. Gardella <patrick@FreeBSD.org>2002-11-03 00:30:26 +0000
committerPatrick S. Gardella <patrick@FreeBSD.org>2002-11-03 00:30:26 +0000
commitbbf6d7f322e88be5b27622ff2cdee0f60e2a3181 (patch)
treec2b08f8d122ccf892e6440587e42961280d0c77a /comms/kpsk
parent2063bea8a361faa1db8e2a416c907d75671d752c (diff)
downloadports-bbf6d7f322e88be5b27622ff2cdee0f60e2a3181.tar.gz
ports-bbf6d7f322e88be5b27622ff2cdee0f60e2a3181.zip
Create a port for kpsk, a PSK-31 radio package for amateur radio users
Notes
Notes: svn path=/head/; revision=69312
Diffstat (limited to 'comms/kpsk')
-rw-r--r--comms/kpsk/Makefile33
-rw-r--r--comms/kpsk/distinfo1
-rw-r--r--comms/kpsk/files/patch-aa11
-rw-r--r--comms/kpsk/files/patch-ab12
-rw-r--r--comms/kpsk/files/patch-ac14
-rw-r--r--comms/kpsk/pkg-comment1
-rw-r--r--comms/kpsk/pkg-descr20
-rw-r--r--comms/kpsk/pkg-plist13
8 files changed, 105 insertions, 0 deletions
diff --git a/comms/kpsk/Makefile b/comms/kpsk/Makefile
new file mode 100644
index 000000000000..8928069c7a34
--- /dev/null
+++ b/comms/kpsk/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: kpsk
+# Date created: 2002-06-12
+# Whom: Patrick Gardella <patrick@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= kpsk
+PORTVERSION= 1.0
+CATEGORIES= comms kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+
+MAINTAINER= patrick@FreeBSD.org
+
+LIB_DEPENDS= db4:${PORTSDIR}/databases/db4
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_KDELIBS_VER=3
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-D_POSIX_C_SOURCE -I${LOCALBASE}/include" \
+ USER_LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --enable-debug=full
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's/-ldb-4.0/-ldb4/g' ${WRKSRC}/configure
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${INSTALL_MAN} ${WRKSRC}/doc/en/HTML/handbook.html ${PREFIX}/share/doc/HTML/en/kpsk/
+.endif
+
+.include <bsd.port.mk>
diff --git a/comms/kpsk/distinfo b/comms/kpsk/distinfo
new file mode 100644
index 000000000000..f2b67a4f0969
--- /dev/null
+++ b/comms/kpsk/distinfo
@@ -0,0 +1 @@
+MD5 (kpsk-1.0.tar.bz2) = 16ce49f3c3124765dd58efc0ddf79230
diff --git a/comms/kpsk/files/patch-aa b/comms/kpsk/files/patch-aa
new file mode 100644
index 000000000000..0ea71b84facc
--- /dev/null
+++ b/comms/kpsk/files/patch-aa
@@ -0,0 +1,11 @@
+--- configure.orig Thu Oct 24 11:17:10 2002
++++ configure Thu Oct 24 11:17:32 2002
+@@ -8703,7 +8703,7 @@
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-ldb-4.0 $LIBS"
++LIBS="-ldb-4.0 $USER_LDFLAGS $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 8709 "configure"
+ #include "confdefs.h"
diff --git a/comms/kpsk/files/patch-ab b/comms/kpsk/files/patch-ab
new file mode 100644
index 000000000000..c745b731655e
--- /dev/null
+++ b/comms/kpsk/files/patch-ab
@@ -0,0 +1,12 @@
+--- kpsk/server/server-main.C.orig Mon Oct 21 22:07:45 2002
++++ kpsk/server/server-main.C Wed Oct 23 07:11:02 2002
+@@ -18,6 +18,9 @@
+ * mutex operations for accesing en-/decoder classes from en/decoding
+ * thread and from user interface thread (==interface functions)
+ */
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#endif
+
+ #include <sys/mman.h>
+
diff --git a/comms/kpsk/files/patch-ac b/comms/kpsk/files/patch-ac
new file mode 100644
index 000000000000..90d4f573f06e
--- /dev/null
+++ b/comms/kpsk/files/patch-ac
@@ -0,0 +1,14 @@
+--- kpsk/modes/psk31-transmitter.C.orig Thu Oct 24 10:44:21 2002
++++ kpsk/modes/psk31-transmitter.C Thu Oct 24 10:46:41 2002
+@@ -11,7 +11,11 @@
+ #include <errno.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#ifdef __FreeBSD__
++#include <machine/soundcard.h>
++#else
+ #include <linux/soundcard.h>
++#endif
+ #include <sys/ioctl.h>
+ #include "psk31-coder.h"
+ #include "psk31-transmitter.h"
diff --git a/comms/kpsk/pkg-comment b/comms/kpsk/pkg-comment
new file mode 100644
index 000000000000..d3eb66af6022
--- /dev/null
+++ b/comms/kpsk/pkg-comment
@@ -0,0 +1 @@
+A PSK31 digital radio communications application for the KDE 3.x
diff --git a/comms/kpsk/pkg-descr b/comms/kpsk/pkg-descr
new file mode 100644
index 000000000000..6bc031672494
--- /dev/null
+++ b/comms/kpsk/pkg-descr
@@ -0,0 +1,20 @@
+KPSK is a PSK31 digital radio communications application for use by
+licensed amateur radio operators and designed specifically for the
+KDE 3.x desktop environment.
+
+Features include:
+
+ * Simple, feature-filled user interface
+ * Simultaneous monitoring of up to four PSK31 signals
+ * User-configurable waterfall colors, fonts.
+ * Auto-scaling waterfall
+ * Optimization to provide IMD data only when the measurement is valid
+ * Twelve user-defined fixedtexts (TX macros), available by mouse
+ or F1-F12 keys
+ * Integral BerkeleyDB-based QSO logbook
+ * BPSK or QPSK operation
+ * Automatic and manual modes for calling CQ
+ * Ability to send an ASCII text file
+ * Extensive application documentation
+
+WWW: http://1409.org/projects/kpsk/
diff --git a/comms/kpsk/pkg-plist b/comms/kpsk/pkg-plist
new file mode 100644
index 000000000000..127b5fb6c3f5
--- /dev/null
+++ b/comms/kpsk/pkg-plist
@@ -0,0 +1,13 @@
+bin/kpsk
+share/applnk/Applications/HamRadio/kpsk.desktop
+share/icons/locolor/32x32/apps/kpsk.png
+share/icons/locolor/16x16/apps/kpsk.png
+share/locale/es/LC_MESSAGES/kpsk.mo
+share/doc/HTML/en/kpsk/index.docbook
+share/doc/HTML/en/kpsk/index.cache.bz2
+share/apps/kpsk/dxcc.db
+share/doc/HTML/en/kpsk/common
+%%PORTDOCS%%share/doc/HTML/en/kpsk/handbook.html
+@dirrm share/apps/kpsk
+@dirrm share/doc/HTML/en/kpsk
+@dirrm share/applnk/Applications/HamRadio