aboutsummaryrefslogtreecommitdiff
path: root/comms/libimobiledevice
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2013-05-07 00:35:40 +0000
committerAlberto Villa <avilla@FreeBSD.org>2013-05-07 00:35:40 +0000
commit66e1dc43a54d99351683d4288835e6bd21b61787 (patch)
tree9ebfe1585debeacef8ee21fbe5923a2b5e906d7c /comms/libimobiledevice
parent7bbf12108c31a87fe31bf8cd9d65fa866ab279af (diff)
downloadports-66e1dc43a54d99351683d4288835e6bd21b61787.tar.gz
ports-66e1dc43a54d99351683d4288835e6bd21b61787.zip
- Update libimobiledevice to 1.1.5.
- Add a port with its Python bindings. The update brings important improvements: * backup/restore support on iOS 4+; * OpenSSL support; * compatibility with iOS 6+.
Notes
Notes: svn path=/head/; revision=317564
Diffstat (limited to 'comms/libimobiledevice')
-rw-r--r--comms/libimobiledevice/Makefile76
-rw-r--r--comms/libimobiledevice/distinfo4
-rw-r--r--comms/libimobiledevice/files/patch-configure10
-rw-r--r--comms/libimobiledevice/pkg-descr18
-rw-r--r--comms/libimobiledevice/pkg-plist14
5 files changed, 72 insertions, 50 deletions
diff --git a/comms/libimobiledevice/Makefile b/comms/libimobiledevice/Makefile
index ced2dc073d76..a97d5ecdef34 100644
--- a/comms/libimobiledevice/Makefile
+++ b/comms/libimobiledevice/Makefile
@@ -1,61 +1,61 @@
# $FreeBSD$
PORTNAME= libimobiledevice
-PORTVERSION= 1.0.7
-PORTREVISION= 3
-CATEGORIES= comms
+PORTVERSION= 1.1.5
+PORTREVISION?= 0
+CATEGORIES?= comms
MASTER_SITES= http://www.${PORTNAME}.org/downloads/
-MAINTAINER= avilla@FreeBSD.org
-COMMENT= Library to communicate with Apple iPhone/iPod Touch devices
+MAINTAINER?= avilla@FreeBSD.org
+COMMENT?= Library to communicate with Apple iOS devices
-LICENSE= LGPL21
-LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
+LICENSE?= LGPL21
-LIB_DEPENDS= gnutls.26:${PORTSDIR}/security/gnutls \
- tasn1.5:${PORTSDIR}/security/libtasn1 \
- gcrypt:${PORTSDIR}/security/libgcrypt \
- plist.1:${PORTSDIR}/devel/libplist \
- usbmuxd.1:${PORTSDIR}/comms/usbmuxd
+SLAVE_PORT?= no
-USE_GNOME= glib20
+USES= pkgconfig
USE_BZIP2= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= openssl_LIBS=-lssl
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_CSTD= gnu89
MAKE_JOBS_SAFE= yes
+
+.if ${SLAVE_PORT} == "no"
+
+LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls \
+ tasn1:${PORTSDIR}/security/libtasn1 \
+ gcrypt:${PORTSDIR}/security/libgcrypt \
+ plist:${PORTSDIR}/devel/libplist \
+ usbmuxd:${PORTSDIR}/comms/usbmuxd
+
+USE_GNOME= glib20
+CONFIGURE_ARGS+=--without-cython
+USE_CSTD= gnu89
USE_LDCONFIG= yes
PORTDOCS= AUTHORS NEWS README
-MAN1= idevice_id.1 idevicebackup.1 ideviceenterrecovery.1 \
- ideviceimagemounter.1 ideviceinfo.1 idevicepair.1 \
- idevicescreenshot.1 idevicesyslog.1
-
-#OPTIONS= PYTHON "Enable Python bindings (needs Swig)" off
-#
-#.include <bsd.port.options.mk>
-#
-#.ifdef(WITH_PYTHON)
-#BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
-#USE_PYTHON= yes
-#PLIST_SUB+= PYTHON=""
-#.else
-CONFIGURE_ARGS+= --without-swig
-#PLIST_SUB+= PYTHON="@comment "
-#.endif
-
-pre-configure:
- ${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
+MAN1= idevice_id.1 idevicebackup.1 idevicebackup2.1 idevicedate.1 \
+ idevicedebugserverproxy.1 idevicediagnostics.1 \
+ ideviceenterrecovery.1 ideviceimagemounter.1 ideviceinfo.1 \
+ idevicepair.1 ideviceprovision.1 idevicescreenshot.1 \
+ idevicesyslog.1
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's, *@ssl_requires@,,' \
+ ${WRKSRC}/${PORTNAME}*.pc.in
+ @${REINPLACE_CMD} -e 's,$$(libdir)/pkgconfig,${PREFIX}/libdata/pkgconfig,g' \
${WRKSRC}/Makefile.in
post-install:
-.ifndef(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
+.endif # ${SLAVE_PORT} == "no"
+
.include <bsd.port.mk>
diff --git a/comms/libimobiledevice/distinfo b/comms/libimobiledevice/distinfo
index 7c03abf99b73..c332c2b2d692 100644
--- a/comms/libimobiledevice/distinfo
+++ b/comms/libimobiledevice/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libimobiledevice-1.0.7.tar.bz2) = 0ed823ac06966c93eb8f7eba3555f5ec9186431efbc114f89adc795118b65f96
-SIZE (libimobiledevice-1.0.7.tar.bz2) = 469897
+SHA256 (libimobiledevice-1.1.5.tar.bz2) = d52ecd069dfc0abe8a81ed0718540df2def2f84b44e88ea783d44312b6f5f33e
+SIZE (libimobiledevice-1.1.5.tar.bz2) = 577138
diff --git a/comms/libimobiledevice/files/patch-configure b/comms/libimobiledevice/files/patch-configure
new file mode 100644
index 000000000000..c286b6f000ac
--- /dev/null
+++ b/comms/libimobiledevice/files/patch-configure
@@ -0,0 +1,10 @@
+--- ./configure.orig 2013-03-18 10:28:26.000000000 +0100
++++ ./configure 2013-04-30 14:56:00.356777062 +0200
+@@ -17262,6 +17262,7 @@
+ $as_echo "yes" >&6; }
+ have_openssl=yes
+ fi
++have_openssl=yes
+ if test "x$have_openssl" = "xyes"; then
+ if test "x$use_openssl" != "xyes"; then
+ enable_openssl=no
diff --git a/comms/libimobiledevice/pkg-descr b/comms/libimobiledevice/pkg-descr
index 0a4cd845ab1d..ab693aedd4c1 100644
--- a/comms/libimobiledevice/pkg-descr
+++ b/comms/libimobiledevice/pkg-descr
@@ -1,11 +1,11 @@
-libimobiledevice is a software library that talks the protocols to
-support iPhone, iPod Touch and iPad devices on Linux. Unlike other
-projects, it does not depend on using any existing proprietary
-libraries and does not require jailbreaking. It allows other software
-to easily access the device's filesystem, retrieve information about
-the device and its internals, backup/restore the device, manage
-SpringBoard icons, manage installed applications, retrieve
-addressbook/calendars/notes and bookmarks and synchronize music and
-video to the device.
+libimobiledevice is a cross-platform software library that talks the
+protocols to support iPhone, iPod Touch, iPad and Apple TV devices.
+Unlike other projects, it does not depend on using any existing
+proprietary libraries and does not require jailbreaking. It allows
+other software to easily access the device's filesystem, retrieve
+information about the device and its internals, backup/restore the
+device, manage SpringBoard icons, manage installed applications,
+retrieve addressbook/calendars/notes and bookmarks and synchronize
+music and video to the device.
WWW: http://www.libimobiledevice.org
diff --git a/comms/libimobiledevice/pkg-plist b/comms/libimobiledevice/pkg-plist
index ba20836a07ce..054c58bb8eb2 100644
--- a/comms/libimobiledevice/pkg-plist
+++ b/comms/libimobiledevice/pkg-plist
@@ -1,25 +1,37 @@
bin/idevice_id
bin/idevicebackup
+bin/idevicebackup2
+bin/idevicedate
+bin/idevicedebugserverproxy
+bin/idevicediagnostics
bin/ideviceenterrecovery
bin/ideviceimagemounter
bin/ideviceinfo
bin/idevicepair
+bin/ideviceprovision
bin/idevicescreenshot
bin/idevicesyslog
include/libimobiledevice/afc.h
+include/libimobiledevice/diagnostics_relay.h
include/libimobiledevice/file_relay.h
+include/libimobiledevice/heartbeat.h
+include/libimobiledevice/house_arrest.h
include/libimobiledevice/installation_proxy.h
include/libimobiledevice/libimobiledevice.h
include/libimobiledevice/lockdown.h
+include/libimobiledevice/misagent.h
include/libimobiledevice/mobile_image_mounter.h
include/libimobiledevice/mobilebackup.h
+include/libimobiledevice/mobilebackup2.h
include/libimobiledevice/mobilesync.h
include/libimobiledevice/notification_proxy.h
+include/libimobiledevice/restore.h
include/libimobiledevice/sbservices.h
include/libimobiledevice/screenshotr.h
+include/libimobiledevice/webinspector.h
lib/libimobiledevice.a
lib/libimobiledevice.la
lib/libimobiledevice.so
-lib/libimobiledevice.so.1
+lib/libimobiledevice.so.4
libdata/pkgconfig/libimobiledevice-1.0.pc
@dirrm include/libimobiledevice