aboutsummaryrefslogtreecommitdiff
path: root/comms/libimobiledevice
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-09-09 22:22:43 +0000
committerJohn Marino <marino@FreeBSD.org>2016-09-09 22:22:43 +0000
commit73b9b079f79309a56b6c090d327546a5dfff872c (patch)
tree4cf92ff18ed67d7d28a6bf4d987617a1e0457d1b /comms/libimobiledevice
parentbe88cafb1ef453cf4eef0408e8777d4cf1735057 (diff)
downloadports-73b9b079f79309a56b6c090d327546a5dfff872c.tar.gz
ports-73b9b079f79309a56b6c090d327546a5dfff872c.zip
comms/libimobiledevice: Handle missing SSLv3 case
Approved by: SSL blanket
Notes
Notes: svn path=/head/; revision=421640
Diffstat (limited to 'comms/libimobiledevice')
-rw-r--r--comms/libimobiledevice/Makefile3
-rw-r--r--comms/libimobiledevice/files/patch-src_idevice.c11
2 files changed, 12 insertions, 2 deletions
diff --git a/comms/libimobiledevice/Makefile b/comms/libimobiledevice/Makefile
index eb6a7b3e6a89..d92ec6e07519 100644
--- a/comms/libimobiledevice/Makefile
+++ b/comms/libimobiledevice/Makefile
@@ -13,8 +13,7 @@ LICENSE?= LGPL21
SLAVE_PORT?= no
-USES+= cpe libtool pathfix pkgconfig tar:bzip2
-USE_OPENSSL= yes
+USES+= cpe libtool pathfix pkgconfig ssl tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=openssl_CFLAGS="-I${OPENSSLINC}" \
openssl_LIBS="-L${OPENSSLLIB} -lssl -lcrypto"
diff --git a/comms/libimobiledevice/files/patch-src_idevice.c b/comms/libimobiledevice/files/patch-src_idevice.c
new file mode 100644
index 000000000000..33254cc20d84
--- /dev/null
+++ b/comms/libimobiledevice/files/patch-src_idevice.c
@@ -0,0 +1,11 @@
+--- src/idevice.c.orig 2015-01-28 01:10:32 UTC
++++ src/idevice.c
+@@ -678,7 +678,7 @@ LIBIMOBILEDEVICE_API idevice_error_t ide
+ }
+ BIO_set_fd(ssl_bio, (int)(long)connection->data, BIO_NOCLOSE);
+
+- SSL_CTX *ssl_ctx = SSL_CTX_new(SSLv3_method());
++ SSL_CTX *ssl_ctx = SSL_CTX_new(SSLv23_method());
+ if (ssl_ctx == NULL) {
+ debug_info("ERROR: Could not create SSL context.");
+ BIO_free(ssl_bio);