aboutsummaryrefslogtreecommitdiff
path: root/comms/py-lirc/Makefile
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2004-01-07 06:41:40 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2004-01-07 06:41:40 +0000
commit7df08c14991f8dd971207af02a318617313c27fd (patch)
treeada7b4b1799c74eea9569de3021e8e6aedadd189 /comms/py-lirc/Makefile
parentefd39c1777dea4461c6409573c0870de0b3f194c (diff)
downloadports-7df08c14991f8dd971207af02a318617313c27fd.tar.gz
ports-7df08c14991f8dd971207af02a318617313c27fd.zip
Add port for py-lirc 0.0.4,
An infra-red remote controller library interface for Python. PR: 60989 Submitted by: Lewis Thompson <purple@lewiz.net>
Notes
Notes: svn path=/head/; revision=97543
Diffstat (limited to 'comms/py-lirc/Makefile')
-rw-r--r--comms/py-lirc/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/comms/py-lirc/Makefile b/comms/py-lirc/Makefile
new file mode 100644
index 000000000000..5331441d3eb7
--- /dev/null
+++ b/comms/py-lirc/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: py23-lirc
+# Date created: 6 January 2004
+# Whom: Lewis Thompson (purple@lewiz.net)
+#
+# $FreeBSD$
+#
+
+PORTNAME= lirc
+PORTVERSION= 0.0.4
+CATEGORIES= comms python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pylirc
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pylirc-${PORTVERSION}
+
+MAINTAINER= purple@lewiz.net
+COMMENT= Lirc support library for Python
+
+LIB_DEPENDS= lirc_client.0:${PORTSDIR}/comms/lirc
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+MAKE_ENV= LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS}"
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_PYTHON_PREFIX= yes
+
+.include <bsd.port.mk>