aboutsummaryrefslogtreecommitdiff
path: root/comms/qtpcr
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2003-12-12 05:22:45 +0000
committerMark Linimon <linimon@FreeBSD.org>2003-12-12 05:22:45 +0000
commit03bb01f488095fac404dd17ddffa1b1985f21d15 (patch)
tree8ce905721f7c87bc0f77f180ee3dfd8f29f4aebb /comms/qtpcr
parent9c66d150cfd3324cfbb5a69d4ed06836c37fdb4f (diff)
downloadports-03bb01f488095fac404dd17ddffa1b1985f21d15.tar.gz
ports-03bb01f488095fac404dd17ddffa1b1985f21d15.zip
Add comms/qtpcr, software that controls the ICOM PCR-1000 Receiver.
PR: ports/52319 Submitted by: Sebastian Yepes <esn@x123.info>
Notes
Notes: svn path=/head/; revision=95642
Diffstat (limited to 'comms/qtpcr')
-rw-r--r--comms/qtpcr/Makefile51
-rw-r--r--comms/qtpcr/distinfo1
-rw-r--r--comms/qtpcr/pkg-descr10
-rw-r--r--comms/qtpcr/pkg-plist1
4 files changed, 63 insertions, 0 deletions
diff --git a/comms/qtpcr/Makefile b/comms/qtpcr/Makefile
new file mode 100644
index 000000000000..bd586f5e5769
--- /dev/null
+++ b/comms/qtpcr/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: qtpcr
+# Date created: 31 Jan 2003
+# Whom: Sebastian Yepes <esn@x123.info>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qtpcr
+PORTVERSION= 1.1.3
+CATEGORIES= comms
+MASTER_SITES= http://www.physics.purdue.edu/~teepanis/qtpcr/
+DISTNAME= qtpcr-${PORTVERSION}
+
+MAINTAINER= esn@x123.info
+COMMENT= Software that controls the ICOM PCR-1000 Receiver
+
+WRKSRC= ${WRKDIR}/qtpcr-${PORTVERSION}/src
+
+USE_X_PREFIX= yes
+ALL_TARGET=
+INSTALL_TARGET=
+
+.if defined(WITH_QT23)
+USE_QT_VER= 2
+LIB_DEPENDS+= pthread:${PORTSDIR}/devel/pth
+MAKE_ENV= INCPATH=-I${X11BASE}/include/qt2 MOC=moc2 LIBS="-lqt2-mt -L${X11BASE}/lib -lpthread -L${LOCALBASE}/lib/pth"
+.else
+USE_QT_VER= 3
+LIB_DEPENDS+= pthread:${PORTSDIR}/devel/pth
+MAKE_ENV= INCPATH=-I${X11BASE}/include MOC=moc LIBS="-lqt-mt -L${X11BASE}/lib -lpthread -L${LOCALBASE}/lib/pth"
+.endif
+
+.include <bsd.port.pre.mk>
+
+pre-everything::
+.if !defined(WITH_QT23)
+ @${ECHO_MSG} "You may specify the following on the command line:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "WITH_QT23=yes to use qt23, else it will use the current qt"
+ @${ECHO_MSG} ""
+.endif
+
+post-install:
+ @${ECHO_MSG} "===> Installing qtpcr in ${X11BASE}/bin/qtpcr"
+ @${ECHO_MSG} ""
+ ${INSTALL_PROGRAM} ${WRKSRC}/qtpcr ${X11BASE}/bin
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Remember to create a symbolic link from your com(0|1) to /dev/pcr1000"
+ @${ECHO_MSG} ""
+
+.include <bsd.port.post.mk>
diff --git a/comms/qtpcr/distinfo b/comms/qtpcr/distinfo
new file mode 100644
index 000000000000..f91c37d31f54
--- /dev/null
+++ b/comms/qtpcr/distinfo
@@ -0,0 +1 @@
+MD5 (qtpcr-1.1.3.tar.gz) = 65655b26b2a289d0223eb0a865612ffa
diff --git a/comms/qtpcr/pkg-descr b/comms/qtpcr/pkg-descr
new file mode 100644
index 000000000000..bc2ac8b8c3fe
--- /dev/null
+++ b/comms/qtpcr/pkg-descr
@@ -0,0 +1,10 @@
+Software that controls the ICOM PCR-1000 Receiver.
+
+Features
+ - GUI Controls
+ - Bandscope
+ - Hierachy Channels Database
+ - Graphical Scan
+ - Monitor and run script files
+
+WWW: http://www.physics.purdue.edu/~teepanis/qtpcr/
diff --git a/comms/qtpcr/pkg-plist b/comms/qtpcr/pkg-plist
new file mode 100644
index 000000000000..1f3f8a506bac
--- /dev/null
+++ b/comms/qtpcr/pkg-plist
@@ -0,0 +1 @@
+bin/qtpcr