aboutsummaryrefslogtreecommitdiff
path: root/comms/ruby-termios
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-02-13 20:28:39 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-02-13 20:28:39 +0000
commite8794ac0533794dcd043550e290a8b68b5847bee (patch)
tree640246413db4c543696cf57fef06ebec6e52ffd7 /comms/ruby-termios
parentbed94467814e67b7046a66143da4b8b451559e48 (diff)
downloadports-e8794ac0533794dcd043550e290a8b68b5847bee.tar.gz
ports-e8794ac0533794dcd043550e290a8b68b5847bee.zip
- Fix build with ruby 1.8.7.
- Set maintainer to ruby@. Reported by: pav
Notes
Notes: svn path=/head/; revision=228227
Diffstat (limited to 'comms/ruby-termios')
-rw-r--r--comms/ruby-termios/Makefile2
-rw-r--r--comms/ruby-termios/files/patch-extconf.rb11
2 files changed, 12 insertions, 1 deletions
diff --git a/comms/ruby-termios/Makefile b/comms/ruby-termios/Makefile
index a2dbdd89fd4a..18192613a128 100644
--- a/comms/ruby-termios/Makefile
+++ b/comms/ruby-termios/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= ruby
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby interface to termios
USE_RUBY= yes
diff --git a/comms/ruby-termios/files/patch-extconf.rb b/comms/ruby-termios/files/patch-extconf.rb
new file mode 100644
index 000000000000..5f3a757fe836
--- /dev/null
+++ b/comms/ruby-termios/files/patch-extconf.rb
@@ -0,0 +1,11 @@
+--- extconf.rb.orig 2009-02-13 23:17:58.000000000 +0300
++++ extconf.rb 2009-02-13 23:18:05.000000000 +0300
+@@ -3,7 +3,7 @@
+ if have_header('termios.h') &&
+ have_header('unistd.h')
+
+- unless RUBY_VERSION < '1.7' || have_type("rb_io_t", ["ruby.h", "rubyio.h"])
++ unless RUBY_VERSION < '1.7'
+ have_struct_member("OpenFile", "fd", ["ruby.h", "rubyio.h"])
+ end
+