aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2012-03-18 20:11:43 +0000
committerPav Lucistnik <pav@FreeBSD.org>2012-03-18 20:11:43 +0000
commit7e77d921eba7d764c0b598f80d6d4389ef324acc (patch)
tree092be35fb768aee302c3b17b1550a8d1e81d08e2 /comms
parenteed05d4126e0bf247569705be7c80d328423f200 (diff)
downloadports-7e77d921eba7d764c0b598f80d6d4389ef324acc.tar.gz
ports-7e77d921eba7d764c0b598f80d6d4389ef324acc.zip
- Mark BROKEN on FreeBSD 7: does not compile
openssl_cert.cpp:1296:2: error: #error "Unexpected OpenSSL version; check X509_ATTRIBUTE struct compatibility" openssl_cert.cpp: In function 'int tqsl_getCertificatePrivateKeyType(void*)': openssl_cert.cpp:1053: warning: deprecated conversion from string constant to 'char*' openssl_cert.cpp: In function 'int tqsl_add_bag_attribute(PKCS12_SAFEBAG*, const char*, const std::string&)': openssl_cert.cpp:1271: error: 'asc2uni' was not declared in this scope openssl_cert.cpp: In function 'int tqsl_exportPKCS12File(void*, const char*, const char*)': openssl_cert.cpp:1484: error: conditional expression between distinct pointer types 'int (*)()' and 'int (*)(PKCS7*, unsigned char**)' lacks a cast openssl_cert.cpp:1484: error: invalid conversion from 'int (*)()' to 'void*' openssl_cert.cpp:1484: error: invalid conversion from 'int (*)(PKCS7*, unsigned char**)' to 'void*' openssl_cert.cpp:1484: error: invalid conversion from 'void*' to 'stack_st_OPENSSL_BLOCK*' openssl_cert.cpp:1484: error: initializing argument 1 of 'unsigned char* ASN1_seq_pack(stack_st_OPENSSL_BLOCK*, int (*)(void*, unsigned char**), unsigned char**, int*)' openssl_cert.cpp: In function 'int tqsl_get_bag_attribute(PKCS12_SAFEBAG*, const char*, std::string&)': openssl_cert.cpp:1549: error: 'uni2asc' was not declared in this scope openssl_cert.cpp: At global scope: openssl_cert.cpp:2407: warning: 'int tqsl_cert_get_subject_name_count(X509*)' defined but not used openssl_cert.cpp:2416: warning: 'int tqsl_cert_get_subject_name_index(X509*, int, TQSL_X509_NAME_ITEM*)' defined but not used openssl_cert.cpp:2442: warning: 'int tqsl_cert_get_subject_date(X509*, const char*, tQSL_Date*)' defined but not used *** Error code 1 Reported by: pointyhat Feature safe: yes
Notes
Notes: svn path=/head/; revision=293535
Diffstat (limited to 'comms')
-rw-r--r--comms/trustedqsl/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/comms/trustedqsl/Makefile b/comms/trustedqsl/Makefile
index 78a5054ea67b..f76abb69cba3 100644
--- a/comms/trustedqsl/Makefile
+++ b/comms/trustedqsl/Makefile
@@ -26,6 +26,12 @@ MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800000
+BROKEN= does not compile on FreeBSD 7.X
+.endif
+
post-patch:
@${CP} ${FILESDIR}/Makefile ${WRKSRC}
@${REINPLACE_CMD} -e 's|%%INSTALL%%|${INSTALL_PROGRAM}|' \
@@ -64,4 +70,4 @@ post-install:
@${ECHO} before this program will run correctly.
@${ECHO}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>