aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-11-23 18:44:22 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-11-23 18:44:22 +0000
commitcb5fd331032ec62965f252257965b2168c01f8a2 (patch)
tree50086b0ed034453f864d56b24a67cce0742e9528 /comms
parentd2641c5ee74e97419707dd688d6129f98f099b04 (diff)
downloadports-cb5fd331032ec62965f252257965b2168c01f8a2.tar.gz
ports-cb5fd331032ec62965f252257965b2168c01f8a2.zip
Add uird, a Universal IR Receiver Daemon
PR: 89404 Submitted by: lx@deepthought.redundancy.org
Notes
Notes: svn path=/head/; revision=149202
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/uird/Makefile40
-rw-r--r--comms/uird/distinfo3
-rw-r--r--comms/uird/pkg-descr15
4 files changed, 59 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 856eba1d7c61..75f74418bf03 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -101,6 +101,7 @@
SUBDIR += tlf
SUBDIR += trustedqsl
SUBDIR += twpsk
+ SUBDIR += uird
SUBDIR += viewfax
SUBDIR += vpb-driver
SUBDIR += vpb2
diff --git a/comms/uird/Makefile b/comms/uird/Makefile
new file mode 100644
index 000000000000..6afe590aad97
--- /dev/null
+++ b/comms/uird/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: uird
+# Date created: 2005-11-21
+# Whom: David Thiel <lx@redundancy.redundancy.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uird
+PORTVERSION= 1.1
+CATEGORIES= comms
+MASTER_SITES= http://vvv.purjo.nu/uird/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= lx@deepthought.redundancy.org
+COMMENT= The Universal IR Receiver Daemon
+
+USE_GMAKE= yes
+USE_PERL5= yes
+USE_REINPLACE= yes
+
+MAKE_ENV+= CC="${CC}"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+ALL_TARGET= ${PORTNAME}
+
+PLIST_FILES= bin/uird
+PORTDOCS= Documentation
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|gcc|$${CC}\ $${CFLAGS}|; /strip/d' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/uird ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/comms/uird/distinfo b/comms/uird/distinfo
new file mode 100644
index 000000000000..2063a2aa793a
--- /dev/null
+++ b/comms/uird/distinfo
@@ -0,0 +1,3 @@
+MD5 (uird-1.1.tgz) = bccfb171d475308546204da8174f1003
+SHA256 (uird-1.1.tgz) = 22b896b885d9f05356680d0b813d2fe29a2de73038755376701313ac21ccf1e5
+SIZE (uird-1.1.tgz) = 11409
diff --git a/comms/uird/pkg-descr b/comms/uird/pkg-descr
new file mode 100644
index 000000000000..bd8bdb94485a
--- /dev/null
+++ b/comms/uird/pkg-descr
@@ -0,0 +1,15 @@
+UIRD is software to control your PC via a normal remote control. It is designed
+to interface with the UIRR (Universal IR Receiver), which is a piece of
+hardware that you can easily build yourself.
+
+Features:
+
+ * Embedded perl-interpreter for advanced scripting features
+ * Learning mode - interactively press a button on your remote and then enter
+ what should happend every time you push that button
+ * Simple configuration-file for specifying what should happen when you push a
+ particular button
+ * Network mode sends IR-data encapsulated in UDP-packets over the network to a
+ remote host
+
+WWW: http://vvv.purjo.nu/uird/