aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-03-19 00:35:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-03-19 00:35:19 +0000
commit883803337e6717d853df7e2b67d420300766a7aa (patch)
treee091220c3fe8503f02e36c78f5db58a8038ebf82 /comms
parentfe9fbeb23042a25894bebdba8de44bec62684b36 (diff)
downloadports-883803337e6717d853df7e2b67d420300766a7aa.tar.gz
ports-883803337e6717d853df7e2b67d420300766a7aa.zip
Xnecview is a program for visualizing the input and output files of the NEC
antenna simulation software. It runs on Linux/Unix systems with the X window system. WWW: http://wwwhome.cs.utwente.nl/%7Eptdeboer/ham/xnecview/ PR: ports/94644 Submitted by: Soeren Straarup <xride@beacon.x12.dk>
Notes
Notes: svn path=/head/; revision=157637
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/xnecview/Makefile30
-rw-r--r--comms/xnecview/distinfo3
-rw-r--r--comms/xnecview/files/patch-Makefile21
-rw-r--r--comms/xnecview/files/patch-draw.c11
-rw-r--r--comms/xnecview/files/patch-parse_output.c15
-rw-r--r--comms/xnecview/files/patch-xwin.c28
-rw-r--r--comms/xnecview/pkg-descr5
8 files changed, 114 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 76a2d4a217e4..3f5eda6e6b62 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -112,6 +112,7 @@
SUBDIR += xcept
SUBDIR += xdx
SUBDIR += xlog
+ SUBDIR += xnecview
SUBDIR += yagiuda
SUBDIR += yaps
SUBDIR += yawmppp
diff --git a/comms/xnecview/Makefile b/comms/xnecview/Makefile
new file mode 100644
index 000000000000..99ec40609568
--- /dev/null
+++ b/comms/xnecview/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: xnecview
+# Date created: 2006-03-18
+# Whom: Søren Straarup <xride@x12.dk>
+#
+# $FreeBSD$
+
+PORTNAME= xnecview
+PORTVERSION= 1.34
+CATEGORIES= comms hamradio
+MASTER_SITES= http://wwwhome.cs.utwente.nl/%7Eptdeboer/ham/xnecview/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= xride@x12.dk
+COMMENT= A X viewer of nec2c data
+
+LIB_DEPENDS= png:${PORTSDIR}/graphics/png
+RUN_DEPENDS= nec2c:${PORTSDIR}/comms/nec2c
+
+USE_GNOME= gtk20
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+
+MAN1= xnecview.1
+PLIST_FILES= bin/xnecview
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xnecview ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/xnecview.man ${MANPREFIX}/man/man1/xnecview.1
+
+.include <bsd.port.mk>
diff --git a/comms/xnecview/distinfo b/comms/xnecview/distinfo
new file mode 100644
index 000000000000..443620bb1735
--- /dev/null
+++ b/comms/xnecview/distinfo
@@ -0,0 +1,3 @@
+MD5 (xnecview-1.34.tgz) = e496c0b04bd908911bb675bfc28c6c53
+SHA256 (xnecview-1.34.tgz) = 987ab674c5be33a6a017f2a6962352bfed75b2a0371c6dfa81b7cb2b01ea9803
+SIZE (xnecview-1.34.tgz) = 76863
diff --git a/comms/xnecview/files/patch-Makefile b/comms/xnecview/files/patch-Makefile
new file mode 100644
index 000000000000..f9ec5eff786c
--- /dev/null
+++ b/comms/xnecview/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.orig Fri Dec 27 23:23:23 2002
++++ Makefile Fri Mar 17 17:59:24 2006
+@@ -4,14 +4,14 @@
+
+
+ CC = gcc
+-CFLAGS = -O2 -g -Wall `gtk-config --cflags`
++CFLAGS = -O2 -g -Wall `pkg-config --cflags gtk+-2.0`
+
+ LD = $(CC)
+-LDFLAGS = `gtk-config --libs` -lm
++LDFLAGS = `pkg-config --libs gtk+-2.0` -lm
+
+ ifeq ($(PNG),yes)
+-CFLAGS += -DHAVE_LIBPNG
+-LDFLAGS += -lpng
++CFLAGS += `pkg-config --cflags ${LOCALBASE}/libdata/pkgconfig/libpng12.pc`
++LDFLAGS += `pkg-config --libs ${LOCALBASE}/libdata/pkgconfig/libpng12.pc`
+ endif
+
+ SRCS = xnecview.c xwin.c parse_input.c parse_output.c draw.c draw_opaque.c freqplot.c postscript.c icon.xbm
diff --git a/comms/xnecview/files/patch-draw.c b/comms/xnecview/files/patch-draw.c
new file mode 100644
index 000000000000..c0c550306b92
--- /dev/null
+++ b/comms/xnecview/files/patch-draw.c
@@ -0,0 +1,11 @@
+--- draw.c.orig Mon Jul 21 21:49:28 2003
++++ draw.c Fri Mar 17 17:59:24 2006
+@@ -605,7 +605,7 @@
+ #define R270 (1.5*M_PI)
+ #define R360 (2*M_PI)
+
+-#include <sys/timeb.h>
++#include <sys/time.h>
+
+ void draw_gain(int ie,Radpattern *rp)
+ {
diff --git a/comms/xnecview/files/patch-parse_output.c b/comms/xnecview/files/patch-parse_output.c
new file mode 100644
index 000000000000..44962cab24bb
--- /dev/null
+++ b/comms/xnecview/files/patch-parse_output.c
@@ -0,0 +1,15 @@
+--- parse_output.c.orig Fri Mar 17 20:32:22 2006
++++ parse_output.c Fri Mar 17 20:30:42 2006
+@@ -749,9 +749,10 @@
+ EXPAND_IF_NECESSARY(numneco,maxfreqs,neco)
+
+ /* search for the frequency and read it */
+- do fgets(s,200,f); while (!feof(f) && !strstr(s,"FREQUENCY="));
++ do fgets(s,200,f); while (!feof(f) && !strstr(s,"FREQUENCY : "));
+ if (feof(f)) break;
+- p = strchr(s,'=');
++printf("XXX\n");
++ p = strchr(s,':');
+ freq = atof(p+1);
+
+ /* find the right place in the neco array (data is sorted by frequency) */
diff --git a/comms/xnecview/files/patch-xwin.c b/comms/xnecview/files/patch-xwin.c
new file mode 100644
index 000000000000..e1ee2fccbde4
--- /dev/null
+++ b/comms/xnecview/files/patch-xwin.c
@@ -0,0 +1,28 @@
+--- xwin.c.orig Fri Mar 17 20:50:07 2006
++++ xwin.c Fri Mar 17 20:50:52 2006
+@@ -13,6 +13,7 @@
+ #include <math.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <gtk/gtk.h>
+ #include <gdk/gdkx.h>
+ #include <gdk/gdkkeysyms.h>
+@@ -1378,7 +1379,7 @@
+
+ gtk_widget_grab_focus(gdraw1);
+
+- gtk_accel_group_attach(acc, GTK_OBJECT(win1));
++ gtk_window_add_accel_group(GTK_WINDOW(win1), acc);
+
+ ggc = gdk_gc_new(w->window);
+
+@@ -1478,7 +1479,7 @@
+
+ gtk_widget_grab_focus(gdraw2);
+
+- gtk_accel_group_attach(acc, GTK_OBJECT(win2));
++ gtk_window_add_accel_group(GTK_WINDOW(win2), acc);
+
+ ggc2 = gdk_gc_new(w->window);
+
diff --git a/comms/xnecview/pkg-descr b/comms/xnecview/pkg-descr
new file mode 100644
index 000000000000..1077c9527a2c
--- /dev/null
+++ b/comms/xnecview/pkg-descr
@@ -0,0 +1,5 @@
+Xnecview is a program for visualizing the input and output files of the NEC
+antenna simulation software. It runs on Linux/Unix systems with the X window
+system.
+
+WWW: http://wwwhome.cs.utwente.nl/%7Eptdeboer/ham/xnecview/