aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
committerAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
commit54a0b86543e9ffa811825f0afecea56e89aac2a5 (patch)
treef56fb969c6a70f5e63287a4f791d035ab1ef0ddc /comms
parent1fccb46f1497a538f24ec00f14b7826570bc0a3a (diff)
downloadports-54a0b86543e9ffa811825f0afecea56e89aac2a5.tar.gz
ports-54a0b86543e9ffa811825f0afecea56e89aac2a5.zip
Mass-conversion to the USE_AUTOTOOLS New World Order. The code present
in bsd.autotools.mk essentially makes this a no-op given that all the old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in exactly the same way as USE_AUTOTOOLS itself. Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME team -- all GNOME 2.12.x ports use it. Preliminary documentation can be found at: http://people.FreeBSD.org/~ade/autotools.txt which is in the process of being SGMLized before introduction into the Porters Handbook. Light blue touch-paper. Run.
Notes
Notes: svn path=/head/; revision=148323
Diffstat (limited to 'comms')
-rw-r--r--comms/gammu-devel/Makefile2
-rw-r--r--comms/gammu/Makefile2
-rw-r--r--comms/gfax/Makefile2
-rw-r--r--comms/ghfaxviewer/Makefile2
-rw-r--r--comms/gsmlib/Makefile2
-rw-r--r--comms/hamlib/Makefile2
-rw-r--r--comms/libticables/Makefile2
-rw-r--r--comms/linrad/Makefile2
-rw-r--r--comms/lirc/Makefile2
-rw-r--r--comms/openobex/Makefile5
-rw-r--r--comms/rxtx/Makefile2
-rw-r--r--comms/spandsp-devel/Makefile2
-rw-r--r--comms/spandsp-devel5/Makefile2
-rw-r--r--comms/spandsp/Makefile2
-rw-r--r--comms/tilp/Makefile2
-rw-r--r--comms/vpb2/Makefile3
16 files changed, 16 insertions, 20 deletions
diff --git a/comms/gammu-devel/Makefile b/comms/gammu-devel/Makefile
index 90025ddf0b52..9cf99e43157a 100644
--- a/comms/gammu-devel/Makefile
+++ b/comms/gammu-devel/Makefile
@@ -19,7 +19,7 @@ USE_GMAKE= yes
USE_GNOME= pkgconfig
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-WANT_AUTOCONF_VER=259
+USE_AUTOTOOLS= autoconf:259:env
INSTALLS_SHLIB= yes
PORTDOCS= *
diff --git a/comms/gammu/Makefile b/comms/gammu/Makefile
index 90025ddf0b52..9cf99e43157a 100644
--- a/comms/gammu/Makefile
+++ b/comms/gammu/Makefile
@@ -19,7 +19,7 @@ USE_GMAKE= yes
USE_GNOME= pkgconfig
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-WANT_AUTOCONF_VER=259
+USE_AUTOTOOLS= autoconf:259:env
INSTALLS_SHLIB= yes
PORTDOCS= *
diff --git a/comms/gfax/Makefile b/comms/gfax/Makefile
index d8f4cc325bac..d347a30357c5 100644
--- a/comms/gfax/Makefile
+++ b/comms/gfax/Makefile
@@ -26,7 +26,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
USE_GNOME= gnomeprefix gnomehier libgnomeprint
STRIP=
diff --git a/comms/ghfaxviewer/Makefile b/comms/ghfaxviewer/Makefile
index 8ba762cc7b88..afd21bc21d79 100644
--- a/comms/ghfaxviewer/Makefile
+++ b/comms/ghfaxviewer/Makefile
@@ -23,7 +23,7 @@ USE_GMAKE= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GNOME= yes
-USE_LIBTOOL_VER= 13
+USE_AUTOTOOLS= libtool:13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/comms/gsmlib/Makefile b/comms/gsmlib/Makefile
index 258f90e73704..d5b44d1b318c 100644
--- a/comms/gsmlib/Makefile
+++ b/comms/gsmlib/Makefile
@@ -19,7 +19,7 @@ USE_GNOME= gnometarget lthack
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
diff --git a/comms/hamlib/Makefile b/comms/hamlib/Makefile
index 9401b75ea01c..b68bccdd134d 100644
--- a/comms/hamlib/Makefile
+++ b/comms/hamlib/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= esn@x123.info
COMMENT= Shared libraries for Amateur Radio Equipment Control Applications
USE_PERL5= yes
-USE_INC_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15:inc
USE_GNOME= pkgconfig gnomehack
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
diff --git a/comms/libticables/Makefile b/comms/libticables/Makefile
index 8027b036b1a3..c68bfe1dabad 100644
--- a/comms/libticables/Makefile
+++ b/comms/libticables/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
GNU_CONFIGURE= yes
USE_GETTEXT= yes
USE_GNOME= gnomehack pkgconfig
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
INSTALLS_SHLIB= yes
diff --git a/comms/linrad/Makefile b/comms/linrad/Makefile
index b1c41df72700..af4f2091719e 100644
--- a/comms/linrad/Makefile
+++ b/comms/linrad/Makefile
@@ -21,7 +21,7 @@ BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
WRKSRC= ${WRKDIR}/${PORTNAME}-01.20
-USE_AUTOCONF_VER= 253
+USE_AUTOTOOLS= autoconf:253
HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_REINPLACE= yes
diff --git a/comms/lirc/Makefile b/comms/lirc/Makefile
index 2ab9ca2a3677..44ebe152c457 100644
--- a/comms/lirc/Makefile
+++ b/comms/lirc/Makefile
@@ -17,7 +17,7 @@ COMMENT= Linux Infared Remote Control
USE_XLIB= yes
USE_GETOPT_LONG=yes
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
USE_REINPLACE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/comms/openobex/Makefile b/comms/openobex/Makefile
index d8e1b7e46f22..96ad8b5192b7 100644
--- a/comms/openobex/Makefile
+++ b/comms/openobex/Makefile
@@ -14,10 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= mad@madpilot.net
COMMENT= Open source implementation of the OBEX protocol
-USE_AUTOCONF_VER= 253
-USE_AUTOHEADER_VER= 253
-WANT_AUTOMAKE_VER= 14
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= automake:14:env autoheader:253 autoconf:253 libtool:15
USE_GMAKE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
diff --git a/comms/rxtx/Makefile b/comms/rxtx/Makefile
index ae9d1c696569..3f6eba0942ca 100644
--- a/comms/rxtx/Makefile
+++ b/comms/rxtx/Makefile
@@ -19,7 +19,7 @@ USE_GMAKE= yes
USE_JAVA= yes
JAVA_VERSION= 1.2+
JAVA_OS= native
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
INSTALLS_SHLIB= yes
CONFIGURE_ENV= JAVA_HOME=${JAVA_HOME}
diff --git a/comms/spandsp-devel/Makefile b/comms/spandsp-devel/Makefile
index 1987f992e0ce..5a51d6e7ff78 100644
--- a/comms/spandsp-devel/Makefile
+++ b/comms/spandsp-devel/Makefile
@@ -22,7 +22,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C/pre.*$//}
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/comms/spandsp-devel5/Makefile b/comms/spandsp-devel5/Makefile
index 1987f992e0ce..5a51d6e7ff78 100644
--- a/comms/spandsp-devel5/Makefile
+++ b/comms/spandsp-devel5/Makefile
@@ -22,7 +22,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C/pre.*$//}
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/comms/spandsp/Makefile b/comms/spandsp/Makefile
index 1987f992e0ce..5a51d6e7ff78 100644
--- a/comms/spandsp/Makefile
+++ b/comms/spandsp/Makefile
@@ -22,7 +22,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C/pre.*$//}
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/comms/tilp/Makefile b/comms/tilp/Makefile
index 86a32a8dfca8..e00a5efbf6f6 100644
--- a/comms/tilp/Makefile
+++ b/comms/tilp/Makefile
@@ -24,7 +24,7 @@ USE_GETTEXT= yes
USE_GNOME= gtk20 libglade2
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"\
diff --git a/comms/vpb2/Makefile b/comms/vpb2/Makefile
index 8a1464b0af74..54de9fc19fd6 100644
--- a/comms/vpb2/Makefile
+++ b/comms/vpb2/Makefile
@@ -18,8 +18,7 @@ DEPRECATED= "mastersite disappeared, no longer maintained by author"
EXPIRATION_DATE= 2005-12-31
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER= 13
-USE_AUTOCONF_VER= 213
+USE_AUTOTOOLS= autoconf:213 libtool:13:inc
USE_REINPLACE= yes
INSTALLS_SHLIB= yes