aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2004-10-15 17:17:48 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2004-10-15 17:17:48 +0000
commit31899d0b9e98fcc67d271fd6abb1e7df989a1c16 (patch)
tree15a91464e936c343e173b96c3458d6ffbbd6a255 /comms
parent74b552997486b6c956c4db46c768f1fdf336d01a (diff)
downloadports-31899d0b9e98fcc67d271fd6abb1e7df989a1c16.tar.gz
ports-31899d0b9e98fcc67d271fd6abb1e7df989a1c16.zip
Update to version 0.11.0
Notes
Notes: svn path=/head/; revision=119516
Diffstat (limited to 'comms')
-rw-r--r--comms/cutecom/Makefile3
-rw-r--r--comms/cutecom/distinfo4
-rw-r--r--comms/cutecom/files/patch-qcppdialogimpl.cpp28
3 files changed, 27 insertions, 8 deletions
diff --git a/comms/cutecom/Makefile b/comms/cutecom/Makefile
index 8ea0ceef0308..68c752b61662 100644
--- a/comms/cutecom/Makefile
+++ b/comms/cutecom/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= cutecom
-PORTVERSION= 0.0.7
+PORTVERSION= 0.11.0
CATEGORIES= comms
MASTER_SITES= http://cutecom.sourceforge.net/
@@ -13,6 +13,7 @@ MAINTAINER= markus@FreeBSD.org
COMMENT= Graphical serial terminal
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+RUN_DEPENDS= lsz:${PORTSDIR}/comms/lrzsz
USE_QT_VER= 3
MAKE_ENV+= QTDIR="${X11BASE}"
diff --git a/comms/cutecom/distinfo b/comms/cutecom/distinfo
index c9562dbc0ea1..3c0792261894 100644
--- a/comms/cutecom/distinfo
+++ b/comms/cutecom/distinfo
@@ -1,2 +1,2 @@
-MD5 (cutecom-0.0.7.tar.gz) = ef068d73bb27704c395557a5883179a0
-SIZE (cutecom-0.0.7.tar.gz) = 16682
+MD5 (cutecom-0.11.0.tar.gz) = e3c43a9f22ac297cc21875e67cf9f411
+SIZE (cutecom-0.11.0.tar.gz) = 18431
diff --git a/comms/cutecom/files/patch-qcppdialogimpl.cpp b/comms/cutecom/files/patch-qcppdialogimpl.cpp
index c3add52a2c08..c010f0e60cc3 100644
--- a/comms/cutecom/files/patch-qcppdialogimpl.cpp
+++ b/comms/cutecom/files/patch-qcppdialogimpl.cpp
@@ -1,6 +1,6 @@
---- qcppdialogimpl.cpp.orig Thu Jul 29 22:24:43 2004
-+++ qcppdialogimpl.cpp Fri Jul 30 10:22:04 2004
-@@ -167,11 +167,19 @@
+--- qcppdialogimpl.cpp.orig Wed Oct 13 23:28:30 2004
++++ qcppdialogimpl.cpp Fri Oct 15 19:04:08 2004
+@@ -190,11 +190,19 @@
bool entryFound=false;
QStringList devices=settings.readListEntry("/cutecom/AllDevices", &entryFound);
if (!entryFound)
@@ -19,8 +19,26 @@
+#endif
QStringList history=settings.readListEntry("/cutecom/History");
- m_oldCmdsLb->insertStringList(history);
-@@ -659,15 +667,21 @@
+
+@@ -295,7 +303,7 @@
+ m_sz->addArgument("sh");
+ m_sz->addArgument("-c");
+ // QString tmp=QString("sx -vv \"")+filename+"\" < "+m_deviceCb->currentText()+" > "+m_deviceCb->currentText();
+- QString tmp=QString("sz ");
++ QString tmp=QString("lsz ");
+ if (m_protoPb->currentText()=="XModem")
+ tmp+="--xmodem ";
+ else if (m_protoPb->currentText()=="YModem")
+@@ -414,7 +422,7 @@
+
+ void QCPPDialogImpl::sendDone()
+ {
+- cerr<<"sx exited"<<endl;
++ cerr<<"lsx exited"<<endl;
+ }
+
+ bool QCPPDialogImpl::eventFilter(QObject* watched, QEvent *e)
+@@ -773,15 +781,21 @@
case 230400:
_baud=B230400;
break;