aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-05-20 14:33:52 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-05-20 14:33:52 +0000
commite79def562916f1ebedbda3e8e910107b6987f8f8 (patch)
tree8f1f35f7ac9406edbd96ab1f753f68ae612c94a0 /comms
parent2ec4a1d756fdb77931d1560f2305f5ba02137ea2 (diff)
downloadports-e79def562916f1ebedbda3e8e910107b6987f8f8.tar.gz
ports-e79def562916f1ebedbda3e8e910107b6987f8f8.zip
Patch configure instead of configure.in & aclocal.m4. Drop USE_AUTOCONF,
to avoid auto* trouble people have had with this port. Use sed instead of Perl for patching in Makefile. Make /dev/cuaa0 default port when doing batch builds, as we have no idea whether /dev/modem is there. Unbreak: Bento builds should have no problems with minicom now.
Notes
Notes: svn path=/head/; revision=59533
Diffstat (limited to 'comms')
-rw-r--r--comms/minicom/Makefile24
-rw-r--r--comms/minicom/files/patch-configure11
-rw-r--r--comms/minicom/files/patch-configure.in11
3 files changed, 25 insertions, 21 deletions
diff --git a/comms/minicom/Makefile b/comms/minicom/Makefile
index c6be98ac306e..36589168a33c 100644
--- a/comms/minicom/Makefile
+++ b/comms/minicom/Makefile
@@ -17,30 +17,34 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}.src
MAINTAINER= anders@FreeBSD.org
-BROKEN= "Configure fails"
-
RUN_DEPENDS= lrz:${PORTSDIR}/comms/lrzsz \
lsz:${PORTSDIR}/comms/lrzsz
WRKSRC= ${WRKDIR}/${DISTNAME:S/.src//}
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-dfl-baud=57600 \
- --enable-dfl-port=/dev/modem \
--sysconfdir=${PREFIX}/etc/minicom \
--enable-lock-dir=/var/spool/lock
-
-USE_AUTOCONF= yes
+.if defined(BATCH)
+CONFIGURE_ARGS+= --enable-dfl-port=/dev/cuaa0
+.else
+CONFIGURE_ARGS+= --enable-dfl-port=/dev/modem
+.endif
MAN1= minicom.1 runscript.1 ascii-xfr.1
post-patch:
- ${PERL} -pi -e "s@/usr/local/bin/@${LOCALBASE}/bin/@g;s@/sz@/lsz@g; \
- s@/sb@/lsb@g;s@/sx@/lsx@g;s@/rz@/lrz@g;s@/rb@/lrb@g; \
- s@/rx@/lrx@g" ${WRKSRC}/src/rwconf.c
+ ${MV} ${WRKSRC}/src/rwconf.c ${WRKSRC}/src/rwconf.c.pre_sed
+ ${SED} -e "s:/usr/local/bin/:${LOCALBASE}/bin/:g" \
+ -e "s:/sz:/lsz:g" \
+ -e "s:/sb:/lsb:g" \
+ -e "s:/sx:/lsx:g" \
+ -e "s:/rz:/lrz:g" \
+ -e "s:/rb:/lrb:g" \
+ -e "s:/rx:/lrx:g" \
+ < ${WRKSRC}/src/rwconf.c.pre_sed > ${WRKSRC}/src/rwconf.c
pre-configure:
- ${PERL} -pi -e "s@autoheader@${AUTOHEADER}@;s@autoconf@${AUTOCONF}@" \
- ${WRKSRC}/aclocal.m4
.if !defined(BATCH)
# this script creates a link from your comm port to /dev/modem
${SH} ${SCRIPTDIR}/create-dev-link
diff --git a/comms/minicom/files/patch-configure b/comms/minicom/files/patch-configure
new file mode 100644
index 000000000000..449071237c31
--- /dev/null
+++ b/comms/minicom/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Mon Oct 1 14:21:54 2001
++++ configure Mon May 20 14:24:41 2002
+@@ -4893,7 +4893,7 @@
+ fi
+
+
+-for ac_func in snprintf usleep getopt getopt_long
++for ac_func in snprintf usleep
+ do
+ echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
+ echo "configure:4900: checking for $ac_func" >&5
diff --git a/comms/minicom/files/patch-configure.in b/comms/minicom/files/patch-configure.in
deleted file mode 100644
index fdce96459ccb..000000000000
--- a/comms/minicom/files/patch-configure.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.in.orig Sun Sep 30 15:10:33 2001
-+++ configure.in Sun Jan 27 23:12:28 2002
-@@ -249,7 +242,7 @@
- KEYSERV="",
- KEYSERV="minicom.keyserv")
- AC_SUBST(KEYSERV)
--AC_REPLACE_FUNCS(snprintf usleep getopt getopt_long)
-+AC_REPLACE_FUNCS(snprintf usleep)
-
- dnl system capabilities
- AC_SYS_LONG_FILE_NAMES