aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-02-20 16:07:53 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-02-20 16:07:53 +0000
commit269cfff0e2e85138f95ffdef736ff8291c292b39 (patch)
treec3587a4299c9b96a4b4838d175142147d62af020 /comms
parent995bd9e729a2cb3d517deb3f5d3a99e806184072 (diff)
downloadports-269cfff0e2e85138f95ffdef736ff8291c292b39.tar.gz
ports-269cfff0e2e85138f95ffdef736ff8291c292b39.zip
Add ruby-serialport, a Ruby library to communicate via the RS232 port.
Notes
Notes: svn path=/head/; revision=75945
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/ruby-serialport/Makefile44
-rw-r--r--comms/ruby-serialport/distinfo1
-rw-r--r--comms/ruby-serialport/pkg-descr5
-rw-r--r--comms/ruby-serialport/pkg-plist6
5 files changed, 57 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 3e140ebc5651..49d34a8b85ad 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -37,6 +37,7 @@
SUBDIR += py-serial
SUBDIR += qico
SUBDIR += qpage
+ SUBDIR += ruby-serialport
SUBDIR += ruby-termios
SUBDIR += scmxx
SUBDIR += scud
diff --git a/comms/ruby-serialport/Makefile b/comms/ruby-serialport/Makefile
new file mode 100644
index 000000000000..8148d30bdac2
--- /dev/null
+++ b/comms/ruby-serialport/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: Ruby/SerialPort
+# Date created: 21 February 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= serialport
+PORTVERSION= 0.6
+CATEGORIES= comms ruby
+MASTER_SITES= http://davedd.free.fr/ruby-serialport/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A Ruby library to communicate via the RS232 port
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+DOCS= CHANGELOG README
+EXAMPLES= test/*.rb
+
+post-patch:
+.for f in ${EXAMPLES}
+ ${RUBY} -i -pe 'sub!(%r"\.\./serialport", "serialport")' ${WRKSRC}/${f}
+.endfor
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}/
+.endfor
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/comms/ruby-serialport/distinfo b/comms/ruby-serialport/distinfo
new file mode 100644
index 000000000000..8fbe2a8b41f3
--- /dev/null
+++ b/comms/ruby-serialport/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby-serialport-0.6.tar.gz) = c38aec045ebc7560bbaee69038d94b69
diff --git a/comms/ruby-serialport/pkg-descr b/comms/ruby-serialport/pkg-descr
new file mode 100644
index 000000000000..a750e7091a78
--- /dev/null
+++ b/comms/ruby-serialport/pkg-descr
@@ -0,0 +1,5 @@
+Ruby/SerialPort is a Ruby library that allows you to communicate via
+the RS232 port.
+
+Author: Guillaume Pierronnet <moumar@netcourrier.com>
+WWW: http://davedd.free.fr/ruby-serialport/
diff --git a/comms/ruby-serialport/pkg-plist b/comms/ruby-serialport/pkg-plist
new file mode 100644
index 000000000000..954fce6ff4d1
--- /dev/null
+++ b/comms/ruby-serialport/pkg-plist
@@ -0,0 +1,6 @@
+%%RUBY_SITEARCHLIBDIR%%/serialport.so
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/miniterm.rb
+%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/CHANGELOG
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%