aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorTom Rhodes <trhodes@FreeBSD.org>2006-01-03 20:17:12 +0000
committerTom Rhodes <trhodes@FreeBSD.org>2006-01-03 20:17:12 +0000
commit5019835482349907a92b8cef00ee656ed6a42324 (patch)
treebb7798e21f1128e722efe4f762e52d735eb00499 /comms
parentc3dfc34ff0765c5e57be8a164ff28c389e980167 (diff)
downloadports-5019835482349907a92b8cef00ee656ed6a42324.tar.gz
ports-5019835482349907a92b8cef00ee656ed6a42324.zip
Fix build.
Requested by: kris
Notes
Notes: svn path=/head/; revision=152682
Diffstat (limited to 'comms')
-rw-r--r--comms/hcidump/Makefile4
-rw-r--r--comms/hcidump/files/timet.patch19
2 files changed, 23 insertions, 0 deletions
diff --git a/comms/hcidump/Makefile b/comms/hcidump/Makefile
index 5bd014e94218..89b6a8929c42 100644
--- a/comms/hcidump/Makefile
+++ b/comms/hcidump/Makefile
@@ -30,4 +30,8 @@ IGNORE= it needs Bluetooth stack (FreeBSD 5.2 or newer)
ONLY_FOR_ARCHS= i386
.endif
+.if ${OSVERSION} <= 700011
+EXTRA_PATCHES= files/timet.patch
+.endif
+
.include <bsd.port.post.mk>
diff --git a/comms/hcidump/files/timet.patch b/comms/hcidump/files/timet.patch
new file mode 100644
index 000000000000..ed96df401261
--- /dev/null
+++ b/comms/hcidump/files/timet.patch
@@ -0,0 +1,19 @@
+--- parser/parser.c Fri Sep 12 19:38:11 2003
++++ parser/parser.c Tue Jan 3 15:09:30 2006
+@@ -29,6 +29,7 @@
+ #include <ctype.h>
+ #include <stdio.h>
+ #include <string.h>
++#include <inttypes.h>
+
+ #include "parser.h"
+
+@@ -65,7 +66,7 @@
+
+ if (!parser.state) {
+ if (parser.flags & DUMP_TSTAMP)
+- printf("%8lu.%06lu ", f->ts.tv_sec, f->ts.tv_usec);
++ printf("%8jd.%06lu ", (intmax_t)f->ts.tv_sec, f->ts.tv_usec);
+ printf("%c ", (f->in ? '>' : '<'));
+ parser.state = 1;
+ } else