aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorSoeren Straarup <xride@FreeBSD.org>2010-07-23 19:01:27 +0000
committerSoeren Straarup <xride@FreeBSD.org>2010-07-23 19:01:27 +0000
commit67e1d3cf6ad92bcb827f79dc184c4e766c7937ef (patch)
treed345015602ac690cfc7640939793a8a961ab8b18 /comms
parent988951de412ade228b3a70f85d66a3bcea81f650 (diff)
downloadports-67e1d3cf6ad92bcb827f79dc184c4e766c7937ef.tar.gz
ports-67e1d3cf6ad92bcb827f79dc184c4e766c7937ef.zip
Update to fix an issue with Xastir/Motif and a certain level of Xorg server.
PR: ports/148491 Submitted by: Carl Makin <carl@stagecraft.cx> (maintainer)
Notes
Notes: svn path=/head/; revision=258106
Diffstat (limited to 'comms')
-rw-r--r--comms/xastir/Makefile4
-rw-r--r--comms/xastir/files/patch-main.c19
2 files changed, 21 insertions, 2 deletions
diff --git a/comms/xastir/Makefile b/comms/xastir/Makefile
index 0e9372316914..0b57ffe35148 100644
--- a/comms/xastir/Makefile
+++ b/comms/xastir/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xastir
PORTVERSION= 1.9.8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= comms hamradio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-stable/${PORTNAME}-${PORTVERSION}
@@ -58,7 +58,7 @@ CONFIGURE_ARGS+= --without-shapelib
CONFIGURE_ARGS+= --without-imagemagick --without-graphicsmagick
.else
.if defined(WITH_GRAPHICK)
-LIB_DEPENDS+= GraphicsMagickWand.3:${PORTSDIR}/graphics/GraphicsMagick
+LIB_DEPENDS+= GraphicsMagickWand.4:${PORTSDIR}/graphics/GraphicsMagick13
.else
LIB_DEPENDS+= MagickWand.3:${PORTSDIR}/graphics/ImageMagick
CONFIGURE_ARGS+= --without-graphicsmagick
diff --git a/comms/xastir/files/patch-main.c b/comms/xastir/files/patch-main.c
new file mode 100644
index 000000000000..6eaa14c20a2c
--- /dev/null
+++ b/comms/xastir/files/patch-main.c
@@ -0,0 +1,19 @@
+
+--- src/main.c 11 Mar 2010 04:03:58 -0000 1.792
++++ src/main.c 7 May 2010 16:23:16 -0000 1.793
+@@ -9018,6 +9018,12 @@
+ "create_appshell Menu Popup",
+ al,
+ ac);
++#if XmVersion >= 2000
++ XtVaSetValues(right_menu_popup, XmNpopupEnabled, XmPOPUP_DISABLED, NULL);
++ XtUngrabButton(da, AnyButton, AnyModifier);
++#else
++ XtVaSetValues(right_menu_popup, XmNpopupEnabled, False, NULL);
++#endif
+ //XtVaSetValues(right_menu_popup, XmNwhichButton, 3, NULL);
+
+ ac = 0;
+
+
+