aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-12-06 17:17:38 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-12-06 17:17:38 +0000
commit185ceb675cf8b26e316a037b83225c000ff26f23 (patch)
tree529039d77da5b882444fb862a40d4fea197d5466 /comms
parent06b18b4580a6e989c99e4e95831869330142325e (diff)
downloadports-185ceb675cf8b26e316a037b83225c000ff26f23.tar.gz
ports-185ceb675cf8b26e316a037b83225c000ff26f23.zip
Introduce a knob RUBY_NO_RD_HTML and enable it by default on alpha. This
replaces the non-working NOPORTDOCS workaround and fixes build on the alpha, where rd2 coredumps. Tested on: the axp cluster Approved by: kris
Notes
Notes: svn path=/head/; revision=71402
Diffstat (limited to 'comms')
-rw-r--r--comms/ruby-termios/Makefile18
-rw-r--r--comms/ruby-termios/pkg-plist2
2 files changed, 10 insertions, 10 deletions
diff --git a/comms/ruby-termios/Makefile b/comms/ruby-termios/Makefile
index a654b22b16e9..36340c962873 100644
--- a/comms/ruby-termios/Makefile
+++ b/comms/ruby-termios/Makefile
@@ -18,22 +18,24 @@ MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-USE_RUBY_RDTOOL= yes
INSTALL_TARGET= site-install
-DOCS= ChangeLog README termios.html termios.rd
+RUBY_RD_FILES= termios.rd
+
+DOCS= ChangeLog README \
+ ${RUBY_RD_FILES} \
+ ${RUBY_RD_HTML_FILES}
post-patch:
${RUBY} -i -pe 'gsub(/ttyS\d/, "cuaa0")' ${WRKSRC}/examples/*.rb
${RUBY} -i -pe 'gsub(/\.c_/, ".")' ${WRKSRC}/examples/*.rb
-post-build:
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${RUBY_RD2} termios.rd > termios.html
-.endif
+post-install: doc-install
-post-install:
+.include <bsd.port.mk>
+
+doc-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/*.rb ${RUBY_MODEXAMPLESDIR}/
@@ -42,5 +44,3 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
.endfor
.endif
-
-.include <bsd.port.mk>
diff --git a/comms/ruby-termios/pkg-plist b/comms/ruby-termios/pkg-plist
index b762482c3efc..03d879f8e0bf 100644
--- a/comms/ruby-termios/pkg-plist
+++ b/comms/ruby-termios/pkg-plist
@@ -1,7 +1,7 @@
%%RUBY_SITEARCHLIBDIR%%/termios.so
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/termios.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/termios.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/termios.rd
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/modem_check0.rb