aboutsummaryrefslogtreecommitdiff
path: root/converters/base64
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2000-11-26 14:41:30 +0000
committerKevin Lo <kevlo@FreeBSD.org>2000-11-26 14:41:30 +0000
commit9022193986a16dcdb41f60367566029de4a35695 (patch)
tree3186e59a14e8c27e481b50faebd167c209ec89d4 /converters/base64
parentdcb3d9ca04e53e363b1a6cd5d438e8e8a00eca20 (diff)
downloadports-9022193986a16dcdb41f60367566029de4a35695.tar.gz
ports-9022193986a16dcdb41f60367566029de4a35695.zip
- Support CC/CFLAGS properly
- Add manpage PR: 23071 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=35442
Diffstat (limited to 'converters/base64')
-rw-r--r--converters/base64/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/converters/base64/Makefile b/converters/base64/Makefile
index 6059696a29f8..2a719d848210 100644
--- a/converters/base64/Makefile
+++ b/converters/base64/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: groach
+# New ports collection makefile for: base64
# Date created: 29 Oct 2000
# Whom: will
#
@@ -13,10 +13,17 @@ DISTNAME= b64
MAINTAINER= ports@FreeBSD.org
-ALL_TARGET= clean all
WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
+ALL_TARGET= clean all
+MAN1= base64.1
+
+post-patch:
+ @${PERL} -pi.in -e "s|b64|base64|g" ${WRKSRC}/*.c
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/base64 ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/base64.1 ${MANPREFIX}/man/man1
.include <bsd.port.mk>