aboutsummaryrefslogtreecommitdiff
path: root/converters/libiconv
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-08-15 18:07:49 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-08-15 18:07:49 +0000
commit2d2eff3b88b5699d11ff3efde1f4cd732d08f311 (patch)
treea8368aeedcc1b19b410cc95da94409e84bdc21fd /converters/libiconv
parenta532919c0c5a73bdb2bdefdb92f0613a58011f88 (diff)
downloadports-2d2eff3b88b5699d11ff3efde1f4cd732d08f311.tar.gz
ports-2d2eff3b88b5699d11ff3efde1f4cd732d08f311.zip
Fix with build with llvm/clang.
Submitted by: Ryan Flynn <parseerror@gmail.com>
Notes
Notes: svn path=/head/; revision=239611
Diffstat (limited to 'converters/libiconv')
-rw-r--r--converters/libiconv/files/patch-lib_Makefile.in11
-rw-r--r--converters/libiconv/files/patch-libcharset::lib::Makefile.in13
-rw-r--r--converters/libiconv/files/patch-src::Makefile.in11
-rw-r--r--converters/libiconv/files/patch-test::Makefile.in13
4 files changed, 48 insertions, 0 deletions
diff --git a/converters/libiconv/files/patch-lib_Makefile.in b/converters/libiconv/files/patch-lib_Makefile.in
index d91a17541e7e..5129cc869d8c 100644
--- a/converters/libiconv/files/patch-lib_Makefile.in
+++ b/converters/libiconv/files/patch-lib_Makefile.in
@@ -1,5 +1,16 @@
--- lib/Makefile.in.orig 2009-03-25 22:14:26.000000000 -0400
+++ lib/Makefile.in 2009-06-06 15:26:31.000000000 -0400
+@@ -26,8 +26,8 @@
+ -Dset_relocation_prefix=libiconv_set_relocation_prefix \
+ -Drelocate=libiconv_relocate @DEFS@
+ LIBTOOL = @LIBTOOL@
+-LIBTOOL_COMPILE = $(LIBTOOL) --mode=compile
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link
++LIBTOOL_COMPILE = $(LIBTOOL) --mode=compile --tag=CC
++LIBTOOL_LINK = $(LIBTOOL) --mode=link --tag=CC
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install
+ LIBTOOL_UNINSTALL = $(LIBTOOL) --mode=uninstall
+ # Windows resource compiler (windres). Used via libtool.
@@ -50,7 +50,7 @@ SHELL = /bin/sh
# Before making a release, change this according to the libtool documentation,
diff --git a/converters/libiconv/files/patch-libcharset::lib::Makefile.in b/converters/libiconv/files/patch-libcharset::lib::Makefile.in
new file mode 100644
index 000000000000..6ff9ccfd5d61
--- /dev/null
+++ b/converters/libiconv/files/patch-libcharset::lib::Makefile.in
@@ -0,0 +1,13 @@
+--- libcharset/lib/Makefile.in.orig Thu Jan 30 03:43:59 2003
++++ libcharset/lib/Makefile.in Tue Oct 14 16:55:29 2003
+@@ -25,8 +25,8 @@
+ -Dset_relocation_prefix=libcharset_set_relocation_prefix \
+ -Drelocate=libcharset_relocate @DEFS@
+ LIBTOOL = @LIBTOOL@
+-LIBTOOL_COMPILE = $(LIBTOOL) --mode=compile
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link
++LIBTOOL_COMPILE = $(LIBTOOL) --mode=compile --tag=CC
++LIBTOOL_LINK = $(LIBTOOL) --mode=link --tag=CC
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install
+ LIBTOOL_UNINSTALL = $(LIBTOOL) --mode=uninstall
+ RM = rm -f
diff --git a/converters/libiconv/files/patch-src::Makefile.in b/converters/libiconv/files/patch-src::Makefile.in
index ba1da2b0eedf..919c44d2b116 100644
--- a/converters/libiconv/files/patch-src::Makefile.in
+++ b/converters/libiconv/files/patch-src::Makefile.in
@@ -1,5 +1,16 @@
--- src/Makefile.in.orig 2009-06-21 07:17:33.000000000 -0400
+++ src/Makefile.in 2009-07-04 19:46:15.000000000 -0400
+@@ -23,8 +23,8 @@
+ LDFLAGS = @LDFLAGS@
+ INCLUDES = -I. -I$(srcdir) -I.. -I../include -I$(srcdir)/../include -I../srclib -I$(srcdir)/../srclib
+ LIBTOOL = @LIBTOOL@
+-LIBTOOL_COMPILE = $(LIBTOOL) --mode=compile
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link
++LIBTOOL_COMPILE = $(LIBTOOL) --mode=compile --tag=CC
++LIBTOOL_LINK = $(LIBTOOL) --mode=link --tag=CC
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install
+ LIBTOOL_UNINSTALL = $(LIBTOOL) --mode=uninstall
+ WINDRES = @WINDRES@
@@ -113,6 +113,7 @@ install : all force
if [ ! -d $(DESTDIR)$(bindir) ] ; then $(mkinstalldirs) $(DESTDIR)$(bindir) ; fi
case "@host_os@" in \
diff --git a/converters/libiconv/files/patch-test::Makefile.in b/converters/libiconv/files/patch-test::Makefile.in
new file mode 100644
index 000000000000..7d3898255c8c
--- /dev/null
+++ b/converters/libiconv/files/patch-test::Makefile.in
@@ -0,0 +1,13 @@
+--- tests/Makefile.in.orig 2009-08-11 23:52:40.000000000 +0000
++++ tests/Makefile.in 2009-08-11 23:56:06.000000000 +0000
+@@ -12,8 +12,8 @@
+ LDFLAGS = @LDFLAGS@
+ INCLUDES = -I. -I$(srcdir) -I../include -I$(srcdir)/../include -I../srclib -I$(srcdir)/../srclib -I../lib
+ LIBTOOL = @LIBTOOL@
+-LIBTOOL_COMPILE = $(LIBTOOL) --mode=compile
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link
++LIBTOOL_COMPILE = $(LIBTOOL) --mode=compile --tag=CC
++LIBTOOL_LINK = $(LIBTOOL) --mode=link --tag=CC
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install
+ LIBTOOL_UNINSTALL = $(LIBTOOL) --mode=uninstall
+ RM = rm -f