aboutsummaryrefslogtreecommitdiff
path: root/converters/py-iconv
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-09-16 17:25:13 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-09-16 17:25:13 +0000
commitcc7bbaf4822e5ed9cba9f41e74117c7c568bf714 (patch)
treec02d2e23c4b7fe1c09cb2df6298c8a5fcbb69934 /converters/py-iconv
parent62cd7024672285353f795b018a55f808ff9bff11 (diff)
downloadports-cc7bbaf4822e5ed9cba9f41e74117c7c568bf714.tar.gz
ports-cc7bbaf4822e5ed9cba9f41e74117c7c568bf714.zip
Initial import of py-iconv-0.1.2.
This is an iconv wrapper for Python. PR: 30505 Submitted by: Hye-Shik Chang <perky@python.or.kr>
Notes
Notes: svn path=/head/; revision=47879
Diffstat (limited to 'converters/py-iconv')
-rw-r--r--converters/py-iconv/Makefile28
-rw-r--r--converters/py-iconv/distinfo1
-rw-r--r--converters/py-iconv/pkg-comment1
-rw-r--r--converters/py-iconv/pkg-descr4
-rw-r--r--converters/py-iconv/pkg-plist1
5 files changed, 35 insertions, 0 deletions
diff --git a/converters/py-iconv/Makefile b/converters/py-iconv/Makefile
new file mode 100644
index 000000000000..a7c69103e1d9
--- /dev/null
+++ b/converters/py-iconv/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py-iconv
+# Date created: 11 September 2001
+# Whom: Hye-Shik Chang <perky@python.or.kr>
+#
+# $FreeBSD$
+
+PORTNAME= iconv
+PORTVERSION= 0.1.2
+CATEGORIES= converters python
+MASTER_SITES= http://www.mx1.ru/iconv/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= perky@python.or.kr
+
+BUILD_DEPENDS= ${PYDISTUTILS}
+LIB_DEPENDS= iconv.2:${PORTSDIR}/converters/iconv
+
+USE_PYTHON= yes
+SETUP_CMD= cd ${WRKSRC} && ${PYTHON_CMD} setup.py
+PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S|^${LOCALBASE}/||g}
+
+do-build:
+ ${SETUP_CMD} build
+
+do-install:
+ ${SETUP_CMD} install
+
+.include <bsd.port.mk>
diff --git a/converters/py-iconv/distinfo b/converters/py-iconv/distinfo
new file mode 100644
index 000000000000..474de7db1e7e
--- /dev/null
+++ b/converters/py-iconv/distinfo
@@ -0,0 +1 @@
+MD5 (iconv-0.1.2.tar.gz) = b077173868e512453ecec8f45ae8eedc
diff --git a/converters/py-iconv/pkg-comment b/converters/py-iconv/pkg-comment
new file mode 100644
index 000000000000..37cb1e79d9c1
--- /dev/null
+++ b/converters/py-iconv/pkg-comment
@@ -0,0 +1 @@
+An iconv wrapper for Python
diff --git a/converters/py-iconv/pkg-descr b/converters/py-iconv/pkg-descr
new file mode 100644
index 000000000000..62c815ebe9da
--- /dev/null
+++ b/converters/py-iconv/pkg-descr
@@ -0,0 +1,4 @@
+This is an iconv wrapper for Python.
+
+WWW: http://freshmeat.net/projects/iconv4python/
+(author's homepage is http://www.mx1.ru/iconv/ but it's not available now)
diff --git a/converters/py-iconv/pkg-plist b/converters/py-iconv/pkg-plist
new file mode 100644
index 000000000000..95dada866c26
--- /dev/null
+++ b/converters/py-iconv/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/iconv.so