aboutsummaryrefslogtreecommitdiff
path: root/converters/ruby-iconv
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-09-07 14:39:47 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-09-07 14:39:47 +0000
commit6be33926020dcfa43ec8a1bf94700238962f3b92 (patch)
treeb915338a31558eaf368cfd16cdf2b7ec1e6e80db /converters/ruby-iconv
parent79507948280cacb290417077cbdc3e8420c3f9c1 (diff)
downloadports-6be33926020dcfa43ec8a1bf94700238962f3b92.tar.gz
ports-6be33926020dcfa43ec8a1bf94700238962f3b92.zip
Update with bsd.ruby.mk. :>
Notes
Notes: svn path=/head/; revision=32391
Diffstat (limited to 'converters/ruby-iconv')
-rw-r--r--converters/ruby-iconv/Makefile29
-rw-r--r--converters/ruby-iconv/pkg-plist8
2 files changed, 14 insertions, 23 deletions
diff --git a/converters/ruby-iconv/Makefile b/converters/ruby-iconv/Makefile
index a9c89cf4f286..c9704a2fc6d7 100644
--- a/converters/ruby-iconv/Makefile
+++ b/converters/ruby-iconv/Makefile
@@ -9,45 +9,36 @@ PORTNAME= iconv
PORTVERSION= 0.4.2.p3
CATEGORIES= converters ruby
MASTER_SITES= http://member.nifty.ne.jp/nokada/archive/
-PKGNAMEPREFIX= ruby-
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/-pre/}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
LIB_DEPENDS= giconv.2:${PORTSDIR}/converters/libiconv
-RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
.if !defined(NOPORTDOCS)
-BUILD_DEPENDS+= rd2:${PORTSDIR}/textproc/ruby-rdtool
+USE_RUBY_RD= yes
.endif
INSTALL_TARGET= site-install
-CONFIGURE_ARGS= --with-opt-dir="${LOCALBASE}"
-
-PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
-
-RUBY?= ${LOCALBASE}/bin/ruby
-RUBY_VER?= 1.4
-RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
-
-do-configure:
- @cd ${WRKSRC}; \
- ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb ${CONFIGURE_ARGS}
.if !defined(NOPORTDOCS)
post-build:
@cd ${WRKSRC}; \
- rd2 iconv.c > iconv.html
+ ${RUBY_RD} iconv.c > iconv.html
.endif
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/ruby/iconv
+ ${MKDIR} ${RUBY_DOCDIR}/iconv
.for f in iconv.html rd.css
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/iconv/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/iconv/
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.ruby.mk"
+.include <bsd.port.post.mk>
diff --git a/converters/ruby-iconv/pkg-plist b/converters/ruby-iconv/pkg-plist
index 3fd7415f8310..7d1a2df9df44 100644
--- a/converters/ruby-iconv/pkg-plist
+++ b/converters/ruby-iconv/pkg-plist
@@ -1,4 +1,4 @@
-lib/ruby/site_ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/iconv.so
-share/doc/ruby/iconv/iconv.html
-share/doc/ruby/iconv/rd.css
-@dirrm share/doc/ruby/iconv
+%%RUBY_SITEARCHLIBDIR%%/iconv.so
+%%RUBY_DOCDIR%%/iconv/iconv.html
+%%RUBY_DOCDIR%%/iconv/rd.css
+@dirrm %%RUBY_DOCDIR%%/iconv