aboutsummaryrefslogtreecommitdiff
path: root/converters/xdeview/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /converters/xdeview/Makefile
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Notes
Notes: svn path=/head/; revision=282282
Diffstat (limited to 'converters/xdeview/Makefile')
-rw-r--r--converters/xdeview/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/converters/xdeview/Makefile b/converters/xdeview/Makefile
index a5b3a96c9962..c067f444a69a 100644
--- a/converters/xdeview/Makefile
+++ b/converters/xdeview/Makefile
@@ -32,12 +32,12 @@ DOCFILES= ${FILESDIR}/porting.notes
USE_TK= 82+
.include <bsd.port.pre.mk>
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib \
- -lX11 -ltcl${TCL_VER:S/.//} \
- -ltk${TCL_VER:S/.//} -lm" \
- CPPFLAGS="-I${TCL_INCLUDEDIR} -DHAVE_TCL \
- -I${TK_INCLUDEDIR} -DHAVE_TK \
- -I${LOCALBASE}/include"
+CPPFLAGS+= -I${TCL_INCLUDEDIR} -DHAVE_TCL \
+ -I${TK_INCLUDEDIR} -DHAVE_TK \
+ -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib \
+ -lX11 -ltcl${TCL_VER:S/.//} \
+ -ltk${TCL_VER:S/.//} -lm
post-install:
${STRIP_CMD} ${PREFIX}/bin/uuwish