aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-06-10 18:42:48 +0000
committerSteve Wills <swills@FreeBSD.org>2012-06-10 18:42:48 +0000
commit63d09c9c9b84669faec2c94444cb4ba43ca65ec0 (patch)
tree897864e11191cee1fd0515a4af0b3aa5ab400840 /converters
parent17363b49d179d9fa2c2ddac86f2a984508354712 (diff)
downloadports-63d09c9c9b84669faec2c94444cb4ba43ca65ec0.tar.gz
ports-63d09c9c9b84669faec2c94444cb4ba43ca65ec0.zip
- Convert all remaining instances of BUILD_DEPENDS=${RUN_DEPENDS} or
RUN_DEPENDS=${BUILD_DEPENDS} to use := which portlint has warned about for a while. PR: ports/168208 Approved by: portmgr (miwi)
Notes
Notes: svn path=/head/; revision=298970
Diffstat (limited to 'converters')
-rw-r--r--converters/p5-Convert-PEM/Makefile2
-rw-r--r--converters/p5-Data-AMF/Makefile2
-rw-r--r--converters/p5-Encode-Punycode/Makefile2
-rw-r--r--converters/p5-JSON-XS-VersionOneAndTwo/Makefile2
-rw-r--r--converters/p5-JSON1/Makefile2
-rw-r--r--converters/p5-MIME-Base64-URLSafe/Makefile2
-rw-r--r--converters/p5-Net-IDN-Nameprep/Makefile2
7 files changed, 7 insertions, 7 deletions
diff --git a/converters/p5-Convert-PEM/Makefile b/converters/p5-Convert-PEM/Makefile
index bf4299502d8d..f69c81d0f02b 100644
--- a/converters/p5-Convert-PEM/Makefile
+++ b/converters/p5-Convert-PEM/Makefile
@@ -17,7 +17,7 @@ COMMENT= Read/write access to ASN.1-encoded PEM files with optional encryption
RUN_DEPENDS= p5-Class-ErrorHandler>=0:${PORTSDIR}/devel/p5-Class-ErrorHandler \
p5-Convert-ASN1>=0.10:${PORTSDIR}/converters/p5-Convert-ASN1 \
p5-Crypt-DES_EDE3>=0:${PORTSDIR}/security/p5-Crypt-DES_EDE3
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= YES
diff --git a/converters/p5-Data-AMF/Makefile b/converters/p5-Data-AMF/Makefile
index 0df2efbda4ec..c77edabb5b7b 100644
--- a/converters/p5-Data-AMF/Makefile
+++ b/converters/p5-Data-AMF/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= \
p5-Any-Moose>0:${PORTSDIR}/devel/p5-Any-Moose \
p5-UNIVERSAL-require>0:${PORTSDIR}/devel/p5-UNIVERSAL-require \
p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/converters/p5-Encode-Punycode/Makefile b/converters/p5-Encode-Punycode/Makefile
index 620c85b332d3..b6ddfbdf4760 100644
--- a/converters/p5-Encode-Punycode/Makefile
+++ b/converters/p5-Encode-Punycode/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= timur@FreeBSD.org
COMMENT= Encode plugin for Punycode
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/IDN/Encode.pm:${PORTSDIR}/textproc/p5-Net-IDN-Encode
-BUILD_DEPENDS= ${RUN_DEPENDS} \
+BUILD_DEPENDS:= ${RUN_DEPENDS} \
${SITE_PERL}/Test/NoWarnings.pm:${PORTSDIR}/devel/p5-Test-NoWarnings
PERL_MODBUILD= yes
diff --git a/converters/p5-JSON-XS-VersionOneAndTwo/Makefile b/converters/p5-JSON-XS-VersionOneAndTwo/Makefile
index 477523be86db..babcb7209847 100644
--- a/converters/p5-JSON-XS-VersionOneAndTwo/Makefile
+++ b/converters/p5-JSON-XS-VersionOneAndTwo/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= catone@cpan.org
COMMENT= Support versions 1 and 2 of JSON::XS
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/JSON/XS.pm:${PORTSDIR}/converters/p5-JSON-XS
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/converters/p5-JSON1/Makefile b/converters/p5-JSON1/Makefile
index d38e96a54a21..3762ab2ff237 100644
--- a/converters/p5-JSON1/Makefile
+++ b/converters/p5-JSON1/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension to convert to JSON (JavaScript Object Notation)
RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS:= ${RUN_DEPENDS}
CONFLICTS= p5-JSON-2.*
PERL_CONFIGURE= yes
diff --git a/converters/p5-MIME-Base64-URLSafe/Makefile b/converters/p5-MIME-Base64-URLSafe/Makefile
index ebb86406fef7..0837367af6f6 100644
--- a/converters/p5-MIME-Base64-URLSafe/Makefile
+++ b/converters/p5-MIME-Base64-URLSafe/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= citric@cubicone.tmetic.com
COMMENT= Perl version of Python's URL-safe base64 codec
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS:= ${RUN_DEPENDS}
WRKSRC= ${WRKDIR}/${DISTNAME:S/00//}
diff --git a/converters/p5-Net-IDN-Nameprep/Makefile b/converters/p5-Net-IDN-Nameprep/Makefile
index d91603634fcc..291b6c75bf20 100644
--- a/converters/p5-Net-IDN-Nameprep/Makefile
+++ b/converters/p5-Net-IDN-Nameprep/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= timur@FreeBSD.org
COMMENT= normalization of domain names (Nameprep, RFC 3491)
RUN_DEPENDS= ${SITE_PERL}/Unicode/Stringprep.pm:${PORTSDIR}/converters/p5-Unicode-Stringprep
-BUILD_DEPENDS= ${RUN_DEPENDS} \
+BUILD_DEPENDS:= ${RUN_DEPENDS} \
${SITE_PERL}/Test/NoWarnings.pm:${PORTSDIR}/devel/p5-Test-NoWarnings
PERL_MODBUILD= yes